X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Prefs names for about:preferences#home

Kuphostiwe

I want untick all checkboxes about:preferences#home here (not myself). Can I have prefs for my pref.js file for get rid Web Search , Top Sites, Recommended by Pocket, Highlights , Snippets, and usage statistics collection also?

I want untick all checkboxes about:preferences#home here (not myself). Can I have prefs for my pref.js file for get rid Web Search , Top Sites, Recommended by Pocket, Highlights , Snippets, and usage statistics collection also?

Isisombululo esikhethiwe

Did you place autoconfig.js in the defaults\pref folder as well? without this file Firefox doesn't know what file to load.

This requires a autoconfig.js file in the "defaults\pref" folder where the channel-prefs.js file is located that specifies to use autoconfig.cfg.

//
pref("general.config.filename", "autoconfig.cfg");
pref("general.config.obscure_value", 0);
  • autoconfig.cfg and autoconfig.js need to start with a comment line (//)
  • autoconfig.js needs to use Unix line endings (LF instead of CR/LF).

From:

<<< NOTE: The autoconfig.js file must use Unix end-of-line (LF), even on Windows systems with Firefox 60 or higher. >>>
The data URI I posted above creates this autoconfig.js file with %0A line endings.

You can verify this in a Hex file viewing utility.

Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

none

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Eminye Imininingwane

McCoy
  • Top 10 Contributor
464 izisombululo 4222 izimpendulo
Kuphostiwe

Hello Lexx76,

Wouldn't you rather set the homepage to open a blank page ?

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Hello Lexx76, Wouldn't you rather set the homepage to open a blank page ? https://support.mozilla.org/en-US/kb/how-to-set-the-home-page
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

McCoy said

Hello Lexx76, Wouldn't you rather set the homepage to open a blank page ? https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

No, I just want uncheck all checkboxes in settings. But not myself. Because I have several profiles for testing and want uncheck all boxes for whole browser

''McCoy [[#answer-1231318|said]]'' <blockquote> Hello Lexx76, Wouldn't you rather set the homepage to open a blank page ? https://support.mozilla.org/en-US/kb/how-to-set-the-home-page </blockquote> No, I just want uncheck all checkboxes in settings. But not myself. Because I have several profiles for testing and want uncheck all boxes for whole browser
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156049 izimpendulo
Kuphostiwe

You can check these prefs on the about:config page to see which are user set (bold).

browser.newtabpage.activity-stream.

Quote: usage statistics collection

Do you mean datareporting prefs? You can look at prefs like these:

datareporting.healthreport.service.enabled
datareporting.healthreport.uploadEnabled
datareporting.policy.dataSubmissionEnabled
You can check these prefs on the about:config page to see which are user set (bold). browser.newtabpage.activity-stream. Quote: ''usage statistics collection'' Do you mean datareporting prefs? You can look at prefs like these: datareporting.healthreport.service.enabled datareporting.healthreport.uploadEnabled datareporting.policy.dataSubmissionEnabled
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Yes, data collection, but also this ticks https://i.imgur.com/scM5byU.png

Yes, data collection, but also this ticks https://i.imgur.com/scM5byU.png
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156049 izimpendulo
Kuphostiwe

You can use the Inspector (Ctrl+Shift+C) to find what preferences is controlled by a checkbox.

You can use the Inspector (Ctrl+Shift+C) to find what preferences is controlled by a checkbox. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML

Okulungisiwe ngu cor-el

Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

cor-el said

You can use the Inspector (Ctrl+Shift+C) to find what preferences is controlled by a checkbox.

Thanks! But how do I can use these prefs in pref.js file? For completely disable this?

''cor-el [[#answer-1232066|said]]'' <blockquote> You can use the Inspector (Ctrl+Shift+C) to find what preferences is controlled by a checkbox. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/Examine_and_edit_HTML </blockquote> Thanks! But how do I can use these prefs in pref.js file? For completely disable this?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156049 izimpendulo
Kuphostiwe

You can use an autoconfig.cfg file in the Firefox program folder to disable this feature completely and have these checkboxes grayed. In autoconfig.cfg you can use the lockPref() function to lock a pref to a specific value. In user.js you can only set a startup value via user_pref() (replace lockPref by user_pref in the below posted code). The user can still modify prefs initialized via user.js via the about:config page or via Options/Preferences.


Content of autoconfig.cfg in Firefox program folder. This file need to start with a comment line, so paste all the text in this plain text file

// autoconfig.cfg in Firefox program folder

/*Web Search*/
lockPref("browser.newtabpage.activity-stream.showSearch", false);

/*Top Sites*/
lockPref("browser.newtabpage.activity-stream.feeds.topsites", false);

/*Highlights*/
lockPref("browser.newtabpage.activity-stream.feeds.section.highlights", false);
lockPref("browser.newtabpage.activity-stream.section.highlights.includeBookmarks", false);
lockPref("browser.newtabpage.activity-stream.section.highlights.includeDownloads", false);
lockPref("browser.newtabpage.activity-stream.section.highlights.includePocket", false);
lockPref("browser.newtabpage.activity-stream.section.highlights.includeVisited", false);

/*Snippets*/
lockPref("browser.newtabpage.activity-stream.feeds.snippets", false);

You can alternatively paste this base64 code in the location/address bar and save the file as autoconfig.cfg

data:application/octet-stream;base64,Ly8gYXV0b2NvbmZpZy5jZmcgaW4gRmlyZWZveCBwcm9ncmFtIGZvbGRlcgoKLypXZWIgU2VhcmNoKi8KbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uc2hvd1NlYXJjaCIsIGZhbHNlKTsKCi8qVG9wIFNpdGVzKi8KbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uZmVlZHMudG9wc2l0ZXMiLCBmYWxzZSk7CgovKkhpZ2hsaWdodHMqLwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5mZWVkcy5zZWN0aW9uLmhpZ2hsaWdodHMiLCBmYWxzZSk7CmxvY2tQcmVmKCJicm93c2VyLm5ld3RhYnBhZ2UuYWN0aXZpdHktc3RyZWFtLnNlY3Rpb24uaGlnaGxpZ2h0cy5pbmNsdWRlQm9va21hcmtzIiwgZmFsc2UpOwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5zZWN0aW9uLmhpZ2hsaWdodHMuaW5jbHVkZURvd25sb2FkcyIsIGZhbHNlKTsKbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uc2VjdGlvbi5oaWdobGlnaHRzLmluY2x1ZGVQb2NrZXQiLCBmYWxzZSk7CmxvY2tQcmVmKCJicm93c2VyLm5ld3RhYnBhZ2UuYWN0aXZpdHktc3RyZWFtLnNlY3Rpb24uaGlnaGxpZ2h0cy5pbmNsdWRlVmlzaXRlZCIsIGZhbHNlKTsKCi8qU25pcHBldHMqLwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5mZWVkcy5zbmlwcGV0cyIsIGZhbHNlKTs=

You can paste this base64 code in the Firefox location bar and save the file as autoconfig.js

data:application/octet-stream;base64,Ly8KcHJlZigiZ2VuZXJhbC5jb25maWcuZmlsZW5hbWUiLCAiYXV0b2NvbmZpZy5jZmciKTsKcHJlZigiZ2VuZXJhbC5jb25maWcub2JzY3VyZV92YWx1ZSIsIDApOwo=
You can use an autoconfig.cfg file in the Firefox program folder to disable this feature completely and have these checkboxes grayed. In autoconfig.cfg you can use the lockPref() function to lock a pref to a specific value. In user.js you can only set a startup value via user_pref() (replace lockPref by user_pref in the below posted code). The user can still modify prefs initialized via user.js via the <b>about:config</b> page or via Options/Preferences. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig ---- Content of autoconfig.cfg in Firefox program folder. This file need to start with a comment line, so paste all the text in this plain text file <pre><nowiki>// autoconfig.cfg in Firefox program folder /*Web Search*/ lockPref("browser.newtabpage.activity-stream.showSearch", false); /*Top Sites*/ lockPref("browser.newtabpage.activity-stream.feeds.topsites", false); /*Highlights*/ lockPref("browser.newtabpage.activity-stream.feeds.section.highlights", false); lockPref("browser.newtabpage.activity-stream.section.highlights.includeBookmarks", false); lockPref("browser.newtabpage.activity-stream.section.highlights.includeDownloads", false); lockPref("browser.newtabpage.activity-stream.section.highlights.includePocket", false); lockPref("browser.newtabpage.activity-stream.section.highlights.includeVisited", false); /*Snippets*/ lockPref("browser.newtabpage.activity-stream.feeds.snippets", false); </nowiki></pre> You can alternatively paste this base64 code in the location/address bar and save the file as autoconfig.cfg <pre><nowiki> data:application/octet-stream;base64,Ly8gYXV0b2NvbmZpZy5jZmcgaW4gRmlyZWZveCBwcm9ncmFtIGZvbGRlcgoKLypXZWIgU2VhcmNoKi8KbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uc2hvd1NlYXJjaCIsIGZhbHNlKTsKCi8qVG9wIFNpdGVzKi8KbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uZmVlZHMudG9wc2l0ZXMiLCBmYWxzZSk7CgovKkhpZ2hsaWdodHMqLwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5mZWVkcy5zZWN0aW9uLmhpZ2hsaWdodHMiLCBmYWxzZSk7CmxvY2tQcmVmKCJicm93c2VyLm5ld3RhYnBhZ2UuYWN0aXZpdHktc3RyZWFtLnNlY3Rpb24uaGlnaGxpZ2h0cy5pbmNsdWRlQm9va21hcmtzIiwgZmFsc2UpOwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5zZWN0aW9uLmhpZ2hsaWdodHMuaW5jbHVkZURvd25sb2FkcyIsIGZhbHNlKTsKbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uc2VjdGlvbi5oaWdobGlnaHRzLmluY2x1ZGVQb2NrZXQiLCBmYWxzZSk7CmxvY2tQcmVmKCJicm93c2VyLm5ld3RhYnBhZ2UuYWN0aXZpdHktc3RyZWFtLnNlY3Rpb24uaGlnaGxpZ2h0cy5pbmNsdWRlVmlzaXRlZCIsIGZhbHNlKTsKCi8qU25pcHBldHMqLwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5mZWVkcy5zbmlwcGV0cyIsIGZhbHNlKTs=</nowiki></pre> ---- You can paste this base64 code in the Firefox location bar and save the file as autoconfig.js <pre><nowiki>data:application/octet-stream;base64,Ly8KcHJlZigiZ2VuZXJhbC5jb25maWcuZmlsZW5hbWUiLCAiYXV0b2NvbmZpZy5jZmciKTsKcHJlZigiZ2VuZXJhbC5jb25maWcub2JzY3VyZV92YWx1ZSIsIDApOwo= </nowiki></pre>
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156049 izimpendulo
Kuphostiwe

These functions can be used in autoconfig.cfg:

defaultPref();	// set new default value, requires special data: format for localized prefs
pref();	// set pref, allow changes in current session
lockPref();	// lock pref, disallow changes
These functions can be used in autoconfig.cfg: defaultPref(); // set new default value, requires special data: format for localized prefs pref(); // set pref, allow changes in current session lockPref(); // lock pref, disallow changes
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el said

You can use an autoconfig.cfg file in the Firefox program folder to disable this feature completely and have these checkboxes grayed. In autoconfig.cfg you can use the lockPref() function to lock a pref to a specific value. In user.js you can only set a startup value via user_pref() (replace lockPref by user_pref in the below posted code). The user can still modify prefs initialized via user.js via the about:config page or via Options/Preferences.

Content of autoconfig.cfg in Firefox program folder. This file need to start with a comment line, so paste all the text in this plain text file

// autoconfig.cfg in Firefox program folder

/*Web Search*/
lockPref("browser.newtabpage.activity-stream.showSearch", false);

/*Top Sites*/
lockPref("browser.newtabpage.activity-stream.feeds.topsites", false);

/*Highlights*/
lockPref("browser.newtabpage.activity-stream.feeds.section.highlights", false);
lockPref("browser.newtabpage.activity-stream.section.highlights.includeBookmarks", false);
lockPref("browser.newtabpage.activity-stream.section.highlights.includeDownloads", false);
lockPref("browser.newtabpage.activity-stream.section.highlights.includePocket", false);
lockPref("browser.newtabpage.activity-stream.section.highlights.includeVisited", false);

/*Snippets*/
lockPref("browser.newtabpage.activity-stream.feeds.snippets", false);

You can alternatively paste this base64 code in the location/address bar and save the file as autoconfig.cfg

data:application/octet-stream;base64,Ly8gYXV0b2NvbmZpZy5jZmcgaW4gRmlyZWZveCBwcm9ncmFtIGZvbGRlcgoKLypXZWIgU2VhcmNoKi8KbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uc2hvd1NlYXJjaCIsIGZhbHNlKTsKCi8qVG9wIFNpdGVzKi8KbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uZmVlZHMudG9wc2l0ZXMiLCBmYWxzZSk7CgovKkhpZ2hsaWdodHMqLwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5mZWVkcy5zZWN0aW9uLmhpZ2hsaWdodHMiLCBmYWxzZSk7CmxvY2tQcmVmKCJicm93c2VyLm5ld3RhYnBhZ2UuYWN0aXZpdHktc3RyZWFtLnNlY3Rpb24uaGlnaGxpZ2h0cy5pbmNsdWRlQm9va21hcmtzIiwgZmFsc2UpOwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5zZWN0aW9uLmhpZ2hsaWdodHMuaW5jbHVkZURvd25sb2FkcyIsIGZhbHNlKTsKbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uc2VjdGlvbi5oaWdobGlnaHRzLmluY2x1ZGVQb2NrZXQiLCBmYWxzZSk7CmxvY2tQcmVmKCJicm93c2VyLm5ld3RhYnBhZ2UuYWN0aXZpdHktc3RyZWFtLnNlY3Rpb24uaGlnaGxpZ2h0cy5pbmNsdWRlVmlzaXRlZCIsIGZhbHNlKTsKCi8qU25pcHBldHMqLwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5mZWVkcy5zbmlwcGV0cyIsIGZhbHNlKTs=

You can paste this base64 code in the Firefox location bar and save the file as autoconfig.js

data:application/octet-stream;base64,Ly8KcHJlZigiZ2VuZXJhbC5jb25maWcuZmlsZW5hbWUiLCAiYXV0b2NvbmZpZy5jZmciKTsKcHJlZigiZ2VuZXJhbC5jb25maWcub2JzY3VyZV92YWx1ZSIsIDApOwo=

Thanks for help I place autoconfig.cfg in main folder (where is firefox.exe) but ticks stay the same about:preferences#home

I start Firefox with -p parameter and selet profile from the list. Maybe this cause the problem?

''cor-el [[#answer-1232083|said]]'' <blockquote> You can use an autoconfig.cfg file in the Firefox program folder to disable this feature completely and have these checkboxes grayed. In autoconfig.cfg you can use the lockPref() function to lock a pref to a specific value. In user.js you can only set a startup value via user_pref() (replace lockPref by user_pref in the below posted code). The user can still modify prefs initialized via user.js via the <b>about:config</b> page or via Options/Preferences. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig ---- Content of autoconfig.cfg in Firefox program folder. This file need to start with a comment line, so paste all the text in this plain text file <pre><nowiki>// autoconfig.cfg in Firefox program folder /*Web Search*/ lockPref("browser.newtabpage.activity-stream.showSearch", false); /*Top Sites*/ lockPref("browser.newtabpage.activity-stream.feeds.topsites", false); /*Highlights*/ lockPref("browser.newtabpage.activity-stream.feeds.section.highlights", false); lockPref("browser.newtabpage.activity-stream.section.highlights.includeBookmarks", false); lockPref("browser.newtabpage.activity-stream.section.highlights.includeDownloads", false); lockPref("browser.newtabpage.activity-stream.section.highlights.includePocket", false); lockPref("browser.newtabpage.activity-stream.section.highlights.includeVisited", false); /*Snippets*/ lockPref("browser.newtabpage.activity-stream.feeds.snippets", false); </nowiki></pre> You can alternatively paste this base64 code in the location/address bar and save the file as autoconfig.cfg <pre><nowiki> data:application/octet-stream;base64,Ly8gYXV0b2NvbmZpZy5jZmcgaW4gRmlyZWZveCBwcm9ncmFtIGZvbGRlcgoKLypXZWIgU2VhcmNoKi8KbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uc2hvd1NlYXJjaCIsIGZhbHNlKTsKCi8qVG9wIFNpdGVzKi8KbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uZmVlZHMudG9wc2l0ZXMiLCBmYWxzZSk7CgovKkhpZ2hsaWdodHMqLwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5mZWVkcy5zZWN0aW9uLmhpZ2hsaWdodHMiLCBmYWxzZSk7CmxvY2tQcmVmKCJicm93c2VyLm5ld3RhYnBhZ2UuYWN0aXZpdHktc3RyZWFtLnNlY3Rpb24uaGlnaGxpZ2h0cy5pbmNsdWRlQm9va21hcmtzIiwgZmFsc2UpOwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5zZWN0aW9uLmhpZ2hsaWdodHMuaW5jbHVkZURvd25sb2FkcyIsIGZhbHNlKTsKbG9ja1ByZWYoImJyb3dzZXIubmV3dGFicGFnZS5hY3Rpdml0eS1zdHJlYW0uc2VjdGlvbi5oaWdobGlnaHRzLmluY2x1ZGVQb2NrZXQiLCBmYWxzZSk7CmxvY2tQcmVmKCJicm93c2VyLm5ld3RhYnBhZ2UuYWN0aXZpdHktc3RyZWFtLnNlY3Rpb24uaGlnaGxpZ2h0cy5pbmNsdWRlVmlzaXRlZCIsIGZhbHNlKTsKCi8qU25pcHBldHMqLwpsb2NrUHJlZigiYnJvd3Nlci5uZXd0YWJwYWdlLmFjdGl2aXR5LXN0cmVhbS5mZWVkcy5zbmlwcGV0cyIsIGZhbHNlKTs=</nowiki></pre> ---- You can paste this base64 code in the Firefox location bar and save the file as autoconfig.js <pre><nowiki>data:application/octet-stream;base64,Ly8KcHJlZigiZ2VuZXJhbC5jb25maWcuZmlsZW5hbWUiLCAiYXV0b2NvbmZpZy5jZmciKTsKcHJlZigiZ2VuZXJhbC5jb25maWcub2JzY3VyZV92YWx1ZSIsIDApOwo= </nowiki></pre> </blockquote> Thanks for help I place autoconfig.cfg in main folder (where is firefox.exe) but ticks stay the same about:preferences#home I start Firefox with -p parameter and selet profile from the list. Maybe this cause the problem?

Okulungisiwe ngu Lexx76

Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156049 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Did you place autoconfig.js in the defaults\pref folder as well? without this file Firefox doesn't know what file to load.

This requires a autoconfig.js file in the "defaults\pref" folder where the channel-prefs.js file is located that specifies to use autoconfig.cfg.

//
pref("general.config.filename", "autoconfig.cfg");
pref("general.config.obscure_value", 0);
  • autoconfig.cfg and autoconfig.js need to start with a comment line (//)
  • autoconfig.js needs to use Unix line endings (LF instead of CR/LF).

From:

<<< NOTE: The autoconfig.js file must use Unix end-of-line (LF), even on Windows systems with Firefox 60 or higher. >>>
The data URI I posted above creates this autoconfig.js file with %0A line endings.

You can verify this in a Hex file viewing utility.

Did you place autoconfig.js in the defaults\pref folder as well? without this file Firefox doesn't know what file to load. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig This requires a <u>autoconfig.js</u> file in the "defaults\pref" folder where the channel-prefs.js file is located that specifies to use autoconfig.cfg. // pref("general.config.filename", "autoconfig.cfg"); pref("general.config.obscure_value", 0); * autoconfig.cfg and autoconfig.js need to start with a comment line (//) * autoconfig.js needs to use Unix line endings (LF instead of CR/LF). From: *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig <blockquote><<< NOTE: The autoconfig.js file must use Unix end-of-line (LF), even on Windows systems with Firefox 60 or higher. >>> </blockquote>The data URI I posted above creates this autoconfig.js file with %0A line endings. You can verify this in a Hex file viewing utility.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Thanks! It works fine.

Thanks! It works fine.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

cor-el said

Did you place autoconfig.js in the defaults\pref folder as well? without this file Firefox doesn't know what file to load. This requires a autoconfig.js file in the "defaults\pref" folder where the channel-prefs.js file is located that specifies to use autoconfig.cfg. // pref("general.config.filename", "autoconfig.cfg"); pref("general.config.obscure_value", 0);
  • autoconfig.cfg and autoconfig.js need to start with a comment line (//)
  • autoconfig.js needs to use Unix line endings (LF instead of CR/LF).
From:
<<< NOTE: The autoconfig.js file must use Unix end-of-line (LF), even on Windows systems with Firefox 60 or higher. >>>
The data URI I posted above creates this autoconfig.js file with %0A line endings.

You can verify this in a Hex file viewing utility.

Can you help me with this:

Firefox Data Collection and UseWe strive to provide you with choices and collect only what we need to provide and improve Firefox for everyone. We always ask permission before receiving personal information.

Because, then I create a new profile, Im always see notification about these settings

''cor-el [[#answer-1232203|said]]'' <blockquote> Did you place autoconfig.js in the defaults\pref folder as well? without this file Firefox doesn't know what file to load. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig This requires a <u>autoconfig.js</u> file in the "defaults\pref" folder where the channel-prefs.js file is located that specifies to use autoconfig.cfg. // pref("general.config.filename", "autoconfig.cfg"); pref("general.config.obscure_value", 0); * autoconfig.cfg and autoconfig.js need to start with a comment line (//) * autoconfig.js needs to use Unix line endings (LF instead of CR/LF). From: *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig <blockquote><<< NOTE: The autoconfig.js file must use Unix end-of-line (LF), even on Windows systems with Firefox 60 or higher. >>> </blockquote>The data URI I posted above creates this autoconfig.js file with %0A line endings. You can verify this in a Hex file viewing utility. </blockquote> Can you help me with this: Firefox Data Collection and UseWe strive to provide you with choices and collect only what we need to provide and improve Firefox for everyone. We always ask permission before receiving personal information. Because, then I create a new profile, Im always see notification about these settings
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Can I disable this notification?

Can I disable this notification?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156049 izimpendulo
Kuphostiwe

Did you check the settings in Options/Preferences ?

You can find the Firefox Data Collection settings here:

  • Options/Preferences -> Privacy & Security
    Firefox Data Collection and Use
Did you check the settings in Options/Preferences ? You can find the Firefox Data Collection settings here: *Options/Preferences -> Privacy & Security<br>Firefox Data Collection and Use
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

cor-el said

Did you check the settings in Options/Preferences ? You can find the Firefox Data Collection settings here:
  • Options/Preferences -> Privacy & Security
    Firefox Data Collection and Use

Sorry for unlean message, I added this pref lockPref("datareporting.healthreport.uploadEnabled", false); it works fine. I start new profile several time and never see this https://imgur.com/fn7zKcB again :-)

''cor-el [[#answer-1235033|said]]'' <blockquote> Did you check the settings in Options/Preferences ? You can find the Firefox Data Collection settings here: *Options/Preferences -> Privacy & Security<br>Firefox Data Collection and Use </blockquote> Sorry for unlean message, I added this pref lockPref("datareporting.healthreport.uploadEnabled", false); it works fine. I start new profile several time and never see this https://imgur.com/fn7zKcB again :-)
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.