Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why I can not save changes in about:config page?

  • 36 uphendule
  • 1 inale nkinga
  • 555 views
  • Igcine ukuphendulwa ngu DSD

more options

Like in the description I can not save the changes I made in the about:config page no matter what I do, I already do an re installation also use the refresh button and delete the preferences file and still the issue remains.

Like in the description I can not save the changes I made in the about:config page no matter what I do, I already do an re installation also use the refresh button and delete the preferences file and still the issue remains.

Isisombululo esikhethiwe

Maybe:

/* Blank "busy" tab throbber */
.tab-throbber[busy]::before {
  background-image: none !important;
  animation: unset !important;
}
/* Hide the blue swipe */
.tabbrowser-tab .tab-loading-burst {
  display: none !important;
}

Or if you want to see something there to know that the tab is at least trying to load:

/* Static globe for "busy" tab throbber */
.tab-throbber[busy]::before {
  background-image: url("chrome://mozapps/skin/places/defaultFavicon.svg") !important;
  opacity: 0.5 !important; /* Lighten to gray */
  animation: unset !important;
}
/* Hide the blue swipe */
.tabbrowser-tab .tab-loading-burst {
  display: none !important;
}
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (16)

more options

If you can modify, but still see the animation then this specific animation isn't covered by this pref.

What animations do you want to stop?

more options

The animations do not get disabled entirely, not even one, things are even worst neither other preferences apart of this no matter which get the right result.

more options

dsd7 said

The animations do not get disabled entirely, not even one, things are even worst neither other preferences apart of this no matter which get the right result.

What kind of animations are you trying to disable? The preference refers to some user interface animations, not website animations.

more options

jscher2000 said

dsd7 said
The animations do not get disabled entirely, not even one, things are even worst neither other preferences apart of this no matter which get the right result.

What kind of animations are you trying to disable? The preference refers to some user interface animations, not website animations.

I refer to that ones, the interface animations.

more options

dsd7 said

jscher2000 said
dsd7 said
The animations do not get disabled entirely, not even one, things are even worst neither other preferences apart of this no matter which get the right result.

What kind of animations are you trying to disable? The preference refers to some user interface animations, not website animations.

I refer to that ones, the interface animations.

Which interface animations? I guess I don't notice them very much.

more options

The one you can see most is that with two moving blue dots on the left side when the tabs are loading.

more options

dsd7 said

The one you can see most is that with two moving blue dots on the left side when the tabs are loading.

See :

https://www.reddit.com/r/firefox/comments/7cn1lp/ff_57_how_to_disable_blue_loading_animation_slide/

(but we've already established that it doesn't work)

more options

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

.tab-throbber[busy]::before {
  background-image: url("chrome://global/skin/icons/loading.png") !important;
  animation: unset !important;
}
.tab-throbber[busy]:not([progress])::before {
  /* Grays the blue during "Connecting" state */
  filter: grayscale(100%);
}
@media (min-resolution: 2dppx) {
  .tab-throbber[busy]::before {
    background-image: url("chrome://global/skin/icons/loading@2x.png") !important;
  }
}

more options

If you want a colored rotating throbber .tab-throbber[busy] stae then use this code instead of filter: grayscale(100%);.

.tab-throbber[busy]:not([progress])::before {filter: hue-rotate(150deg)}
.tab-throbber[busy][progress]::before {filter: hue-rotate(90deg)}
more options

Adding code to the userChrome.css file is also mentioned at the bottom of that Reddit thread (posted by jscher2000 ......).

more options

dsd7 said

The one you can see most is that with two moving blue dots on the left side when the tabs are loading.

Yes, that "tab throbber" design is annoying. I changed it on mine 21 months ago to return to the circling arrow: https://www.reddit.com/r/FirefoxCSS/comments/71vbds/revert_the_tab_throbber_in_firefox_57/

If you don't want to see any motion there, what would you prefer, just a static square or blank space?

more options

jscher2000 said

dsd7 said
The one you can see most is that with two moving blue dots on the left side when the tabs are loading.

Yes, that "tab throbber" design is annoying. I changed it on mine 21 months ago to return to the circling arrow: https://www.reddit.com/r/FirefoxCSS/comments/71vbds/revert_the_tab_throbber_in_firefox_57/

If you don't want to see any motion there, what would you prefer, just a static square or blank space?

Just a static square, also I can manage with the circling arrow.

Thank you!

more options

McCoy said

Adding code to the userChrome.css file is also mentioned at the bottom of that Reddit thread (posted by jscher2000 ......).

Thank you!

more options

cor-el said

If you want a colored rotating throbber .tab-throbber[busy] stae then use this code instead of filter: grayscale(100%);.
.tab-throbber[busy]:not([progress])::before {filter: hue-rotate(150deg)}
.tab-throbber[busy][progress]::before {filter: hue-rotate(90deg)}

Thank you!

more options

Isisombululo Esikhethiwe

Maybe:

/* Blank "busy" tab throbber */
.tab-throbber[busy]::before {
  background-image: none !important;
  animation: unset !important;
}
/* Hide the blue swipe */
.tabbrowser-tab .tab-loading-burst {
  display: none !important;
}

Or if you want to see something there to know that the tab is at least trying to load:

/* Static globe for "busy" tab throbber */
.tab-throbber[busy]::before {
  background-image: url("chrome://mozapps/skin/places/defaultFavicon.svg") !important;
  opacity: 0.5 !important; /* Lighten to gray */
  animation: unset !important;
}
/* Hide the blue swipe */
.tabbrowser-tab .tab-loading-burst {
  display: none !important;
}
more options

Thank you all for the help! I was not expected it.

Thank you!

  1. 1
  2. 2