X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

When I type "firefox --search 'sentence' in my terminal. Now ,if I dont have a firefox proc launched, the search is not done.

Kuphostiwe

For information, I use bash on linuxMint

Please help me to solve it, and to find a solution in order to launch firefox with a research. Thanks in advance for your help. BR Jonathan ANGUISE

For information, I use bash on linuxMint Please help me to solve it, and to find a solution in order to launch firefox with a research. Thanks in advance for your help. BR Jonathan ANGUISE
Isicaphuno
jscher2000
  • Top 10 Contributor
8634 izisombululo 70620 izimpendulo
Kuphostiwe

Impendulo Ewusizo

There is a bug in Firefox 67 related to clearing data at shutdown. If you use BOTH of the following features, some of the cleaning may carry over to the beginning of your next session, and that seems to preempt showing a custom home page or external link at startup. A fix should be in Firefox 68, and maybe in an interim update to Firefox 67.

Here is the problem combination:

(1) "Delete cookies and site data when Firefox is closed"

  • set in Preferences > Privacy & Security > Cookies section

  • about:config => network.cookie.lifetimePolicy => 2 (modified)

(2) "Clear history when Firefox closes"

  • set in Preferences > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options

  • about config => privacy.sanitize.sanitizeOnShutdown => true (modified)

If you set either of those red-boxed preference back to its default value (unchecked), the problem should not occur. If you do not want to change settings, you can keep Firefox running...

Does that seem to be the issue on your Firefox?

There is a bug in Firefox 67 related to clearing data at shutdown. If you use BOTH of the following features, some of the cleaning may carry over to the beginning of your next session, and that seems to preempt showing a custom home page or external link at startup. A fix should be in Firefox 68, and maybe in an interim update to Firefox 67. Here is the problem combination: (1) "Delete cookies and site data when Firefox is closed" * set in Preferences > Privacy & Security > Cookies section<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-28-15-03-50-21661b.png" width="400"> * '''about:config''' => network.cookie.lifetimePolicy => 2 (modified) (2) "Clear history when Firefox closes" * set in Preferences > Privacy & Security > History section, with "Firefox will: Use custom settings for history" selected to show detailed options<br><br><img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-28-15-03-56-8b9d89.png" width="400"> * '''about config''' => privacy.sanitize.sanitizeOnShutdown => true (modified) If you set ''either'' of those red-boxed preference back to its default value (unchecked), the problem should not occur. If you do not want to change settings, you can keep Firefox running... Does that seem to be the issue on your Firefox?
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Thanks a lot jscher2000 for your answer. your right I had these two box checked . I have unchecked these but the issue still occurs. (I use Firefox 67)

For my part I will use the other solution that you gave me : keep Firefox running and use terminal command after. I let the answer open because perhaps there is an other parameter to change in order to correct this problem.

BR- Jonathan

Thanks a lot jscher2000 for your answer. your right I had these two box checked . I have unchecked these but the issue still occurs. (I use Firefox 67) For my part I will use the other solution that you gave me : keep Firefox running and use terminal command after. I let the answer open because perhaps there is an other parameter to change in order to correct this problem. BR- Jonathan
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.