Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox no longer opens my home page automatically !! It will open if I manually enter the URL.

  • 1 baphendule
  • 1 inale nkinga
  • 7 views
  • Igcine ukuphendulwa ngu cor-el

more options

I've been using Firefox since it first appeared. It's been my default browser since. However, the recent updates have badly broken it, to the point that I may be forced to switch to something else, like (choke) Chrome. Namely, when I open Firefox, no homepage nor URL appears. I can click the 'home' icon, and get there fine. Also, since Firefox is myu default browser in Windows10, if I click on a hotlink from an email, the same thing happens...Firefox opens, but the passed URL does not happen. Just a blank screen in both cases.

I've looked through lots of online help, but NOTHING has helped at all.

Thoughts ?

All Replies (1)

more options

This is a bug in Firefox 67 and can occur with specific settings in "Options/Preferences -> Privacy & Security".

Are you possibly using "Delete cookies and site data when Firefox is closed" and also "Clear history when Firefox closes"?

  • Options/Preferences -> Privacy & Security:
    Cookies and Site Data:
    [ ] "Delete cookies and site data when Firefox is closed"
  • Options/Preferences -> Privacy & Security:
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

If you do then try to disable at least one of these.