Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why does my GWT application no longer work using version 67?

  • 5 uphendule
  • 1 inale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu jscher2000

more options

After upgrading to firefox 67, we sometimes have problems with our GWT based web applications. The error is listed below. The error prevents our application from starting.

The exact same application works fine on Chrome, it works fine in older versions of Firefox and it also works fine in the latest beta of Firefox 68 (b5).

The error is:

SEVERE: Uncaught Web UI exception java.lang.NullPointerException: TypeError: a.AE is not a function at Unknown.Rvw(webui-0.js) at Unknown._4c(webui-0.js) at Unknown.M8o(webui-0.js) at Unknown.J8o(webui-0.js) at Unknown.K8o(webui-0.js) at Unknown.z8o(webui-0.js) at Unknown.F8o(webui-0.js) at Unknown.O7o(webui-0.js) at Unknown.mig(webui-0.js) at Unknown.g(webui-0.js) at Unknown.xq(webui-0.js) at Unknown.Aq(webui-0.js) at Unknown.zq/<(webui-0.js) at Unknown.cig(webui-0.js) at Unknown.anonymous(webui-0.js) at Unknown.m( at Unknown.onScriptDownloaded/<( at Unknown.d( at Unknown.anonymous(Unknown)

All Replies (5)

more options

I don't know GWT. But I suggest you remove the program (without removing settings) and reinstall from the website.

more options

It's not an installed application. GWT is Google Web Toolkit, and it's a single page javascript application running in the browser.

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thanks for your suggestions. I had already tried in safe mode. Now I've also tried with disabled hardware acceleration, even though I cannote wrap my head around why that would give javascript errors. Anyway, it did not solve the problem. The problem is persistent on some configurations of our application using FF67. The problem does not appear in other versions of FF and not in Chrome. It suggests to me that it's a bug in FF67.

more options

If it is already fixed in Firefox 68, then it might not be possible to get any changes sooner. But if you can determine what configuration issues are relevant to the problem, perhaps that would assist in offering users as a workaround.