Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why can't I install firefox 52 onto Mac OS X 10.8?

  • 2 uphendule
  • 1 inale nkinga
  • 11 views
  • Igcine ukuphendulwa ngu cor-el

more options

It is known that if one gives a tweak to the info.plist file, Firefox 52 will run on Mac OSX 10.8. Why is the minimum version set to 10.9? Is there any serious issue running this verion on older systems?

All Replies (2)

more options

Firefox is not compiled to run on unsupported systems. Can you not update your MacOS? There's a pretty high chance you can at least install El Capitan, which is free, more secure and probably faster. https://support.apple.com/en-us/HT206886

Then you can run Firefox 67

more options

Okulungisiwe ngu cor-el