X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

.HTM files have blank icon

Kuphostiwe

HTM and HTML files don't have the Firefox icon, they just have a blank paper icon so it's difficult to distinguish them from other files in a folder. I tried reinstalling Firefox. In fact, I have upgraded to Firefox 64-bit from version 41 to version 47 (newer versions don't support ChatZilla). I don't even know if this is a Firefox or Windows problem because it started happening when I upgraded to Windows 7 64-bit. They are set to be automatically opened with Firefox, not IE or any other browser.

Thanks.

HTM and HTML files don't have the Firefox icon, they just have a blank paper icon so it's difficult to distinguish them from other files in a folder. I tried reinstalling Firefox. In fact, I have upgraded to Firefox 64-bit from version 41 to version 47 (newer versions don't support ChatZilla). I don't even know if this is a Firefox or Windows problem because it started happening when I upgraded to Windows 7 64-bit. They are set to be automatically opened with Firefox, not IE or any other browser. Thanks.
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 47.0.2
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/47.0.2/WINNT/en-US/

Izandiso

  • Firefox Hello 1.3.2 (loop@mozilla.org)
  • Flash Video Downloader - YouTube HD Download [4K] 15.0.19 (artur.dubovoy@gmail.com)
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0.2 (firefox@getpocket.com)
  • Websense Helper 1.0 (websensehelper@mozilla.org)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: NVIDIA GeForce GT 730
  • adapterDescription2:
  • adapterDeviceID: 0x1287
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 128710de
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 11-16-2016
  • driverDate2:
  • driverVersion: 21.21.13.7595
  • driverVersion2:
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 730 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
Wesley Branton
  • Top 10 Contributor
559 izisombululo 4810 izimpendulo
Kuphostiwe

This is a Windows issue.

Windows determines the icon of files that don't have specific icon programmed. In this case, it's likely that Firefox is not the default internet browser on your computer or you have not set HTM/HTML files to automatically open using Firefox. In this case, no program is associated with that type of file, so Windows displays the default file icon.

Try right clicking on the file and selecting Properties. Then, in the Opens With section, click Change. Select Firefox. The icon should change automatically to the Firefox file icon once you press Ok to save the changes. If not, try pressing F5 on your keyboard to reload the screen.

If that doesn't help, try to Make Firefox your default browser.

Hope this helps.

This is a Windows issue. Windows determines the icon of files that don't have specific icon programmed. In this case, it's likely that Firefox is not the default internet browser on your computer or you have not set HTM/HTML files to automatically open using Firefox. In this case, no program is associated with that type of file, so Windows displays the default file icon. Try right clicking on the file and selecting '''Properties'''. Then, in the '''Opens With''' section, click '''Change'''. Select Firefox. The icon should change automatically to the Firefox file icon once you press '''Ok''' to save the changes. If not, try pressing '''F5''' on your keyboard to reload the screen. If that doesn't help, try to [[Make Firefox your default browser]]. Hope this helps.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

The settings page says "Firefox is currently your default browser"

Wesley Branton said

Try right clicking on the file and selecting Properties. Then, in the Opens With section, click Change. Select Firefox.

Already did that.

The settings page says "Firefox is currently your default browser" ''Wesley Branton [[#answer-1225536|said]]'' <blockquote>Try right clicking on the file and selecting '''Properties'''. Then, in the '''Opens With''' section, click '''Change'''. Select Firefox. </blockquote> Already did that.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 25 Contributor
23 izisombululo 284 izimpendulo
Kuphostiwe

Hi HipD, Try: Control Panel -> Default Programs -> Associate a file type or protocol with a program.

Hi HipD, Try: Control Panel -> Default Programs -> Associate a file type or protocol with a program.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17278 izisombululo 156183 izimpendulo
Kuphostiwe

Hi HipD

Note that the Firefox 47 version you seem to be using according to the System Details list is seriously outdated.

Please update to the current Firefox 67.0 release.


Hi HipD Note that the Firefox 47 version you seem to be using according to the System Details list is seriously outdated. Please update to the current Firefox 67.0 release. *https://support.mozilla.org/en-US/kb/update-firefox-latest-version *Help -> About Firefox ---- *https://www.mibbit.com/

Okulungisiwe ngu cor-el

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

My_Cheese_Is_Slippin said

Hi HipD, Try: Control Panel -> Default Programs -> Associate a file type or protocol with a program.

I looked on there and Mozilla Firefox is already associated with HTM and HTML.

cor-el, I would but I can't abandon ChatZilla. It's the most convenient and only IRC app I use.

''My_Cheese_Is_Slippin [[#answer-1225635|said]]'' <blockquote> Hi HipD, Try: Control Panel -> Default Programs -> Associate a file type or protocol with a program. </blockquote> I looked on there and Mozilla Firefox is already associated with HTM and HTML. cor-el, I would but I can't abandon ChatZilla. It's the most convenient and only IRC app I use.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17278 izisombululo 156183 izimpendulo
Kuphostiwe

The link to mibbit is a web based IRC client that is a recommended solution to use IRC in current Firefox releases.

The link to mibbit is a web based IRC client that is a recommended solution to use IRC in current Firefox releases. *https://www.mibbit.com/ *[/questions/1197267] How do I do IRC now that ChatZilla is gone?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 25 Contributor
23 izisombululo 284 izimpendulo
Kuphostiwe

Hi HipD, If I understand you correctly, htm & html files are opening in Firefox. You just have an icon issue, right?

Have you tried re-building your thumbnail & icon cache? Run Disk Cleanup. Be sure to check the Thumbnails check box.

(This will also clear all of your photo thumbnails. If you have a lot of pictures you may have to wait awhile for the thumbs to rebuild when you go to view them.)

Hi HipD, If I understand you correctly, htm & html files ''are'' opening in Firefox. You just have an icon issue, right? Have you tried re-building your thumbnail & icon cache? Run Disk Cleanup. Be sure to check the Thumbnails check box. (This will also clear all of your photo thumbnails. If you have a lot of pictures you may have to wait awhile for the thumbs to rebuild when you go to view them.)
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Correct, it's just an icon issue.

I did Disk Cleanup as you instructed just now but the problem remains. I have not restarted the computer, however.

cor-el, I don't want a web-based IRC client. I can't customize mibbit like I can Chatzilla.

Correct, it's just an icon issue. I did Disk Cleanup as you instructed just now but the problem remains. I have not restarted the computer, however. cor-el, I don't want a web-based IRC client. I can't customize mibbit like I can Chatzilla.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
My_Cheese_Is_Slippin'
  • Top 25 Contributor
23 izisombululo 284 izimpendulo
Kuphostiwe

Hi HipD,

Sometimes, the IconCache.db file gets corrupted and Disk Cleanup doesn't always clear it out. It happens in Windows 10, also. For Windows 7: Open File Explorer -> Folder Options -> Views to Show Hidden System Files. (Not Protected Operating System files - you don't have to dig that deep for this.) Next, go to C:\Users\%username%\AppData\Local and delete the IconCache.db file. Reboot. This will purge and rebuild the icon cache and any corruption that Disk Cleanup didn't catch.

Or

You can get this Icon Cache Rebuilder tool for Windows 7 at:

https://www.thewindowsclub.com/rebuild-corrupt-icon-cache-with-icon-cache-rebuilder

Hi HipD, Sometimes, the IconCache.db file gets corrupted and Disk Cleanup doesn't always clear it out. It happens in Windows 10, also. For Windows 7: Open File Explorer -> Folder Options -> Views to Show Hidden System Files. (Not Protected Operating System files - you don't have to dig that deep for this.) Next, go to C:\Users\%username%\AppData\Local and delete the IconCache.db file. Reboot. This will purge and rebuild the icon cache and any corruption that Disk Cleanup didn't catch. Or You can get this Icon Cache Rebuilder tool for Windows 7 at: https://www.thewindowsclub.com/rebuild-corrupt-icon-cache-with-icon-cache-rebuilder
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

My_Cheese_Is_Slippin said

Hi HipD, Sometimes, the IconCache.db file gets corrupted and Disk Cleanup doesn't always clear it out. It happens in Windows 10, also. For Windows 7: Open File Explorer -> Folder Options -> Views to Show Hidden System Files. (Not Protected Operating System files - you don't have to dig that deep for this.) Next, go to C:\Users\%username%\AppData\Local and delete the IconCache.db file. Reboot. This will purge and rebuild the icon cache and any corruption that Disk Cleanup didn't catch. Or You can get this Icon Cache Rebuilder tool for Windows 7 at: https://www.thewindowsclub.com/rebuild-corrupt-icon-cache-with-icon-cache-rebuilder

That did not work either. The icon is still blank. I've rebooted and everything.

''My_Cheese_Is_Slippin [[#answer-1226450|said]]'' <blockquote> Hi HipD, Sometimes, the IconCache.db file gets corrupted and Disk Cleanup doesn't always clear it out. It happens in Windows 10, also. For Windows 7: Open File Explorer -> Folder Options -> Views to Show Hidden System Files. (Not Protected Operating System files - you don't have to dig that deep for this.) Next, go to C:\Users\%username%\AppData\Local and delete the IconCache.db file. Reboot. This will purge and rebuild the icon cache and any corruption that Disk Cleanup didn't catch. Or You can get this Icon Cache Rebuilder tool for Windows 7 at: https://www.thewindowsclub.com/rebuild-corrupt-icon-cache-with-icon-cache-rebuilder </blockquote> That did not work either. The icon is still blank. I've rebooted and everything.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.