Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why do my open tabs (pages) have to reload when changing between tabs in firefox?

  • 5 uphendule
  • 1 inale nkinga
  • 4017 views
  • Igcine ukuphendulwa ngu Papsy10

more options

At the moment I have 4 pages open in tabs.

But each of them except the current page have lost their content and if I switch back each tab has to reload the page.

This just started happening after the lastest update. 67.0

For example I am on support community page if I tab back to Youtube which was open, it is now blank, has the tab description but reloads the page.

It's the same for all the tabs.

Any ideas. It's very annoying and thinking perhaps time to switch to chrome.

Isisombululo esikhethiwe

Hello Papsy10,

This sounds like one of the new features that came with the update to Firefox 67.0 :

See under "New" - suspending unused tabs

And also : https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/

If you want to disable this feature :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.tabs.unloadOnLowMemory

and set its value to false

Then close and restart Firefox.

This should keep you from switching to Chrome .....

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

Isisombululo Esikhethiwe

Hello Papsy10,

This sounds like one of the new features that came with the update to Firefox 67.0 :

See under "New" - suspending unused tabs

And also : https://blog.mozilla.org/blog/2019/05/21/latest-firefox-release-is-faster-than-ever/

If you want to disable this feature :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.tabs.unloadOnLowMemory

and set its value to false

Then close and restart Firefox.

This should keep you from switching to Chrome .....

more options

Worked a charm, thank you

more options

Papsy10 said

Worked a charm, thank you

My pleasure  ! (I'm glad everything is back to normal for you)

more options

Since this is about a low memory case then you may want to check the Firefox memory usage.

Quote: Firefox will now detect if your computer’s memory is running low, which we define as lower than 400MB, and suspend unused tabs that you haven’t used or looked at in a while.

See also the Firefox Task Manager (about:performance) page.

more options

Firefox uses a lot of memory compared to Chrome. At the moment with 5 tabs and no extensions its using 608 to 620 meg. Chrome on the other hand with the same tabs open it is 166meg. Big difference also Chrome doesnt crash as often as firefox which crashes constantly when using facebook.