Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox starts without extensions when triggered from third-party application (Windows 10 64-bit). How come?

  • 9 uphendule
  • 1 inale nkinga
  • 17 views
  • Igcine ukuphendulwa ngu UglyStuff

more options

Hi,

First off, I must say that this behavior happens with both the installed and portable versions of the latest stable 32-bit Firefox: when I click on a link in, say, Thunderbird, and Firefox is not running yet, it opens a new window with no addons, as though from a new, clean profile, instead of resuming where I left off when I last closed it, as I set it to do.

I can't for the life of me understands why that happens. It seems as though I have two different versions of Firefox (I'm certain that's not the case...), one that I start manually when I need to browse the Web, and another one that would be triggered by third-party apps, the two not sharing the same profile, of which I'm sure I have created only one.

I thought it could have to do with the fact that Portable Firefox comes in a 32-bit/64-bit package, with the third-party app starting the launcher instead of the 32-bit executable, but I've now deleted the 64-bit folder in Portable Firefox altogether, so that can't be it.

Where does that strange behavior come from?!

All Replies (9)

more options

Firefox, when called, should open normally unless options are present. Also, when you use a link, the computer checks for the default browser and calls it.

https://support.mozilla.org/en-US/kb/firefox-is-stuck-in-safe-mode

more options

OK, first off, thanks for taking the time to help me solve this issue.

Secondly, alas, what you describe as a normal behavior with Firefox doesn't fit with what I notice every time Firefox opens from a link in a third-party.

I checked the shortcut for command line options or arguments that shouldn't be there, and found nothing.

Also, I seldom use Firefox in safe mode, because I usually don't have to, so it couldn't be stuck in this mode. I'm posting this reply from Firefox, and it opened just fine this morning, right where I'd left off.

Firefox IS the default browser on both my PCs, and in both cases, it behaves the same way.

more options

If it's any help, here's what Process Hacker tells me about this Firefox instance running when triggered from a third-party app:

more options

... And here's what it says in Process Hacker when Firefox is running in what I'd call "Normal Mode" (started manually by yours truly):

more options

Hi UglyStuff, I saw your post yesterday and I've been doing some investigation.

What I've learned is that when you install Firefox Portable on your computer there are registry entries made and there are additional instances of Firefox made to Windows Settings for Default Apps. These extra instances will not allow Firefox to be set as your default browser and creates conflicts. Basically, you do have two versions of Firefox on your computer.

Anyway, the solution should be simple enough.

Move the entire Firefox Portable folder to a thumb drive. This way you will save everything in your profile and settings.

Then clean up your computer registry. I like to use Norton Utilities but CCleaner should work.

When you're finished cleaning up, restart your computer.

After it boots up check Windows Setting Default Apps. For Web Browser it should say Firefox. Click on that and there should be only one instance of Firefox.

Close Windows Settings.

Now, you can Move or Copy your Firefox Portable folder back on to your computer and enjoy!

more options

The whole Firefox Portable folder is on a separate partition from the system partition on my laptop (D instead of C), and a quick look in both the AppData folder under my account and in the Registry shows no discrepancies other than the "-osint" argument as a suffix in the executable path, which, according to Moz litterature, indicates the app is launched via command line.

As a matter of fact, I have set a keyboard shortcut to launch Firefox via a freeware named Clavier+ (a gem, this one), so when I press the right keys, Firefox starts as though from a console, I suppose.

I'm going to try and copy Firefox Portable on a USB thingy to see if it clears the air.

I'll keep you posted! Thanks for your help!

more options

Are you using multiple profiles? Are you using a shortcut to start Firefox with a specific profile? When Firefox isn't running then Firefox will be started with the profile marked in profiles.ini as Default=1. If you have disabled the startup prompt to show the Password Manager then you won't be able to select the correct profile.

more options

I only use one profile.

Here's the total content of the profile.ini file in AppData:

[General] StartWithLastProfile=1

[Profile0] Name=default IsRelative=1 Path=Profiles/sc0s1gdi.default Default=1

more options

One thing I might want to add: I've created a RAM disk using IMDisk, and set all temp, tmp and TMP folders/directories to be located there, so that they are deleted on every Windows startup.

Could that be a factor? I've just noticed a temp folder in AppData\LocalLow that's empty (it was created at the time I started up Firefox this morning).