X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Firefox doesn't seem to be allowing websites to "remember <random thing>".

Kuphostiwe

Morning,

I've recently switched back to Firefox (for Mac) after being away from Ff for a long time, and have been tinkering with my settings and whatnot to try and get things the way I would like them. I suspect, like most things, that I'm just missing something. ;-)

Basically, I don't want Ff to remember any autofill//form information, and I've got that working, but I would like it to be able to respect when a website allows you to click a radio button for "Remember <Me//This//Etc>". It does not seem to be doing that at the moment.

Does Ff have a setting that will let websites that you specifically click "Remember Me" be remembered, or is it an all or nothing?

Thanks!

Morning, I've recently switched back to Firefox (for Mac) after being away from Ff for a long time, and have been tinkering with my settings and whatnot to try and get things the way I would like them. I suspect, like most things, that I'm just missing something. ;-) Basically, I don't want Ff to remember any autofill//form information, and I've got that working, but I would like it to be able to respect when a website allows you to click a radio button for "Remember <Me//This//Etc>". It does not seem to be doing that at the moment. Does Ff have a setting that will let websites that you specifically click "Remember Me" be remembered, or is it an all or nothing? Thanks!
Isicaphuno

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:66.0) Gecko/20100101 Firefox/66.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8432 izisombululo 68774 izimpendulo
Kuphostiwe

Impendulo Ewusizo

mattagc said

Basically, I don't want Ff to remember any autofill//form information, and I've got that working, but I would like it to be able to respect when a website allows you to click a radio button for "Remember <Me//This//Etc>". It does not seem to be doing that at the moment.

The "Remember me" checkbox is a signal used by the site to determine whether it requests Firefox to set a session cookie, automatically expiring when you quit Firefox, or a persistent cookie that expires in the distant future. (Every single time Firefox requests a file from the server, it will send that site its cookies with the request. That's how the site can connect requests to an account.)

By default, Firefox honors the cookie expiration dates set by sites, but there are many settings you could change and add-ons you could install and cleaners you could run that would flush persistent cookies so when you return to the site, you are not automatically logged back in.

So I suggest focusing your investigation on whether normal cookie operations have been modified. Here's a checklist to review:

Were persistent cookies set after you checked the box?

To check whether the site has even set a persistent cookie, while viewing a page on the site, open the Storage Inspector in the lower part of the tab using Shift+F9. Firefox should list cookies set by the site including a "Expires on" column. Do you see that, with a date far off in the future? (If it isn't included in the columns shown, right-click any column heading and click "Expires on" to add it.)

How can this go wrong?

(1) If you are visiting the site in a private window

Cookies are not written to disk in private windows, so whether they are session cookies or have an expiration date after we're all gone, they will evaporate when the last private window is closed in your session.

The two ways a site could open in a private window are:

(A) Creating a private window in a regular session (for example, Command+Shift+p or right-click > Open Link in New Private Window)

(B) Setting Firefox to use automatic private browsing on the Preferences page --

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security, then scroll down to the History section. Either of these will invoke automatic private browsing:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

(2) If Firefox is set to store ONLY session cookies, and you have not made an exception for the site.

You can check for this on the Preferences page, Privacy & Security panel, Cookies section. Make sure you do NOT have a checkmark for "Delete cookies and site data when Firefox is closed". If you do, you need to create "Allow" exceptions for sites where you want Firefox to accept persistent cookies.

(3) If Firefox is set to Clear History When it Closes and that includes Cookies

Most people do not have this setting, but you can double-check here: On the Preferences page, Privacy & Security panel, History section: make sure you do NOT have a checkmark for "Clear history when Firefox closes". If you want to use that feature with some types of data, use the Settings button to the right of it to confirm that Cookies are not being cleared.

(4) If you use an add-on that modifies how cookies work

There are extensions to manage cookie lifetimes and removal, including some that expire cookies for inactive tabs. There also are extensions that isolate pages in a container, which creates a separate cookie jar for the pages in that container which are invisible to pages outside that container.

(5) If you logged out of the site

The cookie identifies you to the site, but if your session ended, the site isn't going to start a new one automatically. So if you logged out on the site -- highly recommended for sites that have sensitive data or accounts you can't afford to have taken over -- then the site might pre-fill your user name on the login page, but you will need to sign in again.

(6) If external utility or privacy software cleans browser cookies

If you use CCleaner, Advanced SystemCare or other third party programs that touch browser data, set them not to touch Firefox data.

(7) If your IP address is unstable

Some sites link your identification to your IP address and require a new login if that changes. To minimize the potential for changes, you can check your Firefox connection settings on the Preferences page.

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your system settings (for example, Windows/IE "LAN" setting). "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Does any of that help?

''mattagc [[#question-1259114|said]]'' <blockquote> Basically, I don't want Ff to remember any autofill//form information, and I've got that working, but I would like it to be able to respect when a website allows you to click a radio button for "Remember <Me//This//Etc>". It does not seem to be doing that at the moment. </blockquote> The "Remember me" checkbox is a signal used by the site to determine whether it requests Firefox to set a session cookie, automatically expiring when you quit Firefox, or a persistent cookie that expires in the distant future. (Every single time Firefox requests a file from the server, it will send that site its cookies with the request. That's how the site can connect requests to an account.) By default, Firefox honors the cookie expiration dates set by sites, but there are many settings you could change and add-ons you could install and cleaners you could run that would flush persistent cookies so when you return to the site, you are not automatically logged back in. So I suggest focusing your investigation on whether normal cookie operations have been modified. Here's a checklist to review: ''Were persistent cookies set after you checked the box?'' To check whether the site has even set a persistent cookie, while viewing a page on the site, open the Storage Inspector in the lower part of the tab using Shift+F9. Firefox should list cookies set by the site including a "Expires on" column. Do you see that, with a date far off in the future? (If it isn't included in the columns shown, right-click any column heading and click "Expires on" to add it.) '''''How can this go wrong?''''' '''(1) If you are visiting the site in a private window''' Cookies are not written to disk in private windows, so whether they are session cookies or have an expiration date after we're all gone, they will evaporate when the last private window is closed in your session. The two ways a site could open in a private window are: (A) Creating a private window in a regular session (for example, Command+Shift+p or right-click > Open Link in New Private Window) (B) Setting Firefox to use automatic private browsing on the Preferences page -- * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the left column, click '''Privacy & Security''', then scroll down to the '''History''' section. Either of these will invoke automatic private browsing: * Firefox will: Never remember history * Firefox will: Use custom settings for history + "Always use private browsing mode" '''(2) If Firefox is set to store ONLY session cookies, and you have not made an exception for the site.''' You can check for this on the Preferences page, Privacy & Security panel, Cookies section. Make sure you do NOT have a checkmark for "Delete cookies and site data when Firefox is closed". If you do, you need to create "Allow" exceptions for sites where you want Firefox to accept persistent cookies. <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-01-08-10-39-73a6c7.png" width="500"> '''(3) If Firefox is set to Clear History When it Closes and that includes Cookies''' Most people do not have this setting, but you can double-check here: On the Preferences page, Privacy & Security panel, History section: make sure you do NOT have a checkmark for "Clear history when Firefox closes". If you want to use that feature with ''some'' types of data, use the Settings button to the right of it to confirm that Cookies are not being cleared. '''(4) If you use an add-on that modifies how cookies work''' There are extensions to manage cookie lifetimes and removal, including some that expire cookies for inactive tabs. There also are extensions that isolate pages in a container, which creates a separate cookie jar for the pages in that container which are invisible to pages outside that container. '''(5) If you logged out of the site''' The cookie identifies you to the site, but if your session ended, the site isn't going to start a new one automatically. So if you logged out on the site -- highly recommended for sites that have sensitive data or accounts you can't afford to have taken over -- then the site ''might'' pre-fill your user name on the login page, but you will need to sign in again. '''(6) If external utility or privacy software cleans browser cookies''' If you use CCleaner, Advanced SystemCare or other third party programs that touch browser data, set them not to touch Firefox data. '''(7) If your IP address is unstable''' Some sites link your identification to your IP address and require a new login if that changes. To minimize the potential for changes, you can check your Firefox connection settings on the Preferences page. In the search box at the top of the page, type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. The default of "Use system proxy settings" piggybacks on your system settings (for example, Windows/IE "LAN" setting). "Auto-detect" can lead to a flaky connection. You may want to try "No proxy". Does any of that help?
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Thanks for the detailed response!

I've gone through and confirmed that it does not appear to be (1), (2), (3), or (6). I do use Facebook Container, but my understanding is that is not setup to affect other tabs (4).

In regards to (5); I have logged out of the sites in question, and while it appears to initially retain the data (pre-filled login, no password), that data disappears however when I refresh the tab, or when I reload the website in another tab. This would not be the case when I would use Safari.

(7) got me thinking as I am behind a VPN, but like above, even just refreshing the page looses the data and unchecks the "remember me" radio button, when no external IP address occurred. This is counter, as well, to how it behaved under Safari, so I don't suspect the VPN as an issue, unless Ff handles something about it differently.

I experimented with the "No Proxy" option, but it does not seem to have had made any change.

Thanks again for the help, and I'm open to any more thoughts or suggestions you might have!

Thanks for the detailed response! I've gone through and confirmed that it does not appear to be (1), (2), (3), or (6). I do use Facebook Container, but my understanding is that is not setup to affect other tabs (4). In regards to (5); I have logged out of the sites in question, and while it appears to initially retain the data (pre-filled login, no password), that data disappears however when I refresh the tab, or when I reload the website in another tab. This would not be the case when I would use Safari. (7) got me thinking as I am behind a VPN, but like above, even just refreshing the page looses the data and unchecks the "remember me" radio button, when no external IP address occurred. This is counter, as well, to how it behaved under Safari, so I don't suspect the VPN as an issue, unless Ff handles something about it differently. I experimented with the "No Proxy" option, but it does not seem to have had made any change. Thanks again for the help, and I'm open to any more thoughts or suggestions you might have!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17183 izisombululo 155287 izimpendulo
Kuphostiwe

Are you possibly using containers or Private Browsing mode?

You shouldn't lose cookies when you refresh a page.

Do you otherwise have issues with keeping cookies?

What are your current cookie settings?

  • Options/Preferences -> Privacy & Security
Are you possibly using containers or Private Browsing mode? *https://support.mozilla.org/en-US/kb/containers *https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history You shouldn't lose cookies when you refresh a page. Do you otherwise have issues with keeping cookies? What are your current cookie settings? *Options/Preferences -> Privacy & Security
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Afternoon,

I am not in private browsing, or using containers//container tabs for the website(s) in question. I do use the Facebook Container extension to lock FB down, but that's it. Disabling it does not change the behaviour.

It no longer looses the remembered data on refresh, but once I close the tab and reopen it, or even if I browse away from it in the same tab, the data is gone.

I have no special permissions set for cookies, and they are not set to clear when closed, as shown in the image in jscher2000's post above. Deleting the cookies in relation to those sites and having the site reissue them also changes nothing.

Thanks.

Afternoon, I am not in private browsing, or using containers//container tabs for the website(s) in question. I do use the Facebook Container extension to lock FB down, but that's it. Disabling it does not change the behaviour. It no longer looses the remembered data on refresh, but once I close the tab and reopen it, or even if I browse away from it in the same tab, the data is gone. I have no special permissions set for cookies, and they are not set to clear when closed, as shown in the image in jscher2000's post above. Deleting the cookies in relation to those sites and having the site reissue them also changes nothing. Thanks.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8432 izisombululo 68774 izimpendulo
Kuphostiwe

mattagc said

In regards to (5); I have logged out of the sites in question, and while it appears to initially retain the data (pre-filled login, no password), that data disappears however when I refresh the tab, or when I reload the website in another tab. This would not be the case when I would use Safari.

Okay, once you log out, which invalidates the session on the server side, it's normal that you get the login form again. It sounds as though the server is pre-filling that form for you in case you want to log in again right away, but that it only does that immediately after exit; it's not a persistent feature of the form.

Is your goal to have Firefox save your login and fill the form? How much do you want to happen on that login page?

''mattagc [[#answer-1222044|said]]'' <blockquote> In regards to (5); I have logged out of the sites in question, and while it appears to initially retain the data (pre-filled login, no password), that data disappears however when I refresh the tab, or when I reload the website in another tab. This would not be the case when I would use Safari. </blockquote> Okay, once you log out, which invalidates the session on the server side, it's normal that you get the login form again. It sounds as though the server is pre-filling that form for you in case you want to log in again right away, but that it only does that immediately after exit; it's not a persistent feature of the form. Is your goal to have Firefox save your login and fill the form? How much do you want to happen on that login page?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17183 izisombululo 155287 izimpendulo
Kuphostiwe

Did you try Firefox Safe Mode?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

If clearing cookies didn't help then It is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Did you try Firefox Safe Mode? Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems ---- If clearing cookies didn't help then It is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted. *rename/remove <b>cookies.sqlite</b> (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

jscher2000 said

Okay, once you log out, which invalidates the session on the server side, it's normal that you get the login form again. It sounds as though the server is pre-filling that form for you in case you want to log in again right away, but that it only does that immediately after exit; it's not a persistent feature of the form. Is your goal to have Firefox save your login and fill the form? How much do you want to happen on that login page?

I am basically trying to get the page to function as designed; it appears to have been designed to remember user information and nickname (if assigned) between login//logoff. This functions correctly on all browsers I've tried (IE, Edge, Chrome, Chrome Canary, Safari) on my computer, and it even functions correctly on Firefox for iOS on my iPhone//iPad. I can leave the site and not return for a week, but the name and nickname are there still on other browsers.

cor-el said

Did you try Firefox Safe Mode?

I did, but the page continues to operate the same way.

cor-el said

If clearing cookies didn't help then It is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.
  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

This also had no effect.

Thanks for your help both of you!

''jscher2000 [[#answer-1222070|said]]'' <blockquote> Okay, once you log out, which invalidates the session on the server side, it's normal that you get the login form again. It sounds as though the server is pre-filling that form for you in case you want to log in again right away, but that it only does that immediately after exit; it's not a persistent feature of the form. Is your goal to have Firefox save your login and fill the form? How much do you want to happen on that login page? </blockquote> I am basically trying to get the page to function as designed; it appears to have been designed to remember user information and nickname (if assigned) between login//logoff. This functions correctly on all browsers I've tried (IE, Edge, Chrome, Chrome Canary, Safari) on my computer, and <b>it even functions correctly on Firefox for iOS on my iPhone//iPad</b>. I can leave the site and not return for a week, but the name and nickname are there still on other browsers. ''cor-el [[#answer-1222071|said]]'' <blockquote> Did you try Firefox Safe Mode? </blockquote> I did, but the page continues to operate the same way. ''cor-el [[#answer-1222071|said]]'' <blockquote> If clearing cookies didn't help then It is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted. *rename/remove <b>cookies.sqlite</b> (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted. </blockquote> This also had no effect. Thanks for your help both of you!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17183 izisombululo 155287 izimpendulo
Kuphostiwe

What changes did you make to disable auto-fill and what other changes did you make?

Where all these changes in Options/Preferences or did you make changes on about:config as well?


You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

What changes did you make to disable auto-fill and what other changes did you make? Where all these changes in Options/Preferences or did you make changes on about:config as well? ---- You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

The changes were made just in the Options//Preferences menu. Unchecking it's ability to save and remember passwords, as well as changing it's settings for history (remember browsing and download history, but not search and form history).

The issue seems to occur regardless of whether or not I have it set to remember search and form history by the way.

I've tried to create a new profile, but it also doesn't solve the issue.

I'm starting to think maybe it's just the way Firefox for macOS handles how they've coded the site, despite it working fine in Firefox for iOS. Haha.

Thanks again!

The changes were made just in the Options//Preferences menu. Unchecking it's ability to save and remember passwords, as well as changing it's settings for history (remember browsing and download history, but not search and form history). The issue seems to occur regardless of whether or not I have it set to remember search and form history by the way. I've tried to create a new profile, but it also doesn't solve the issue. I'm starting to think maybe it's just the way Firefox for macOS handles how they've coded the site, despite it working fine in Firefox for iOS. Haha. Thanks again!
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
17183 izisombululo 155287 izimpendulo
Kuphostiwe

If it is done via saved form data then you should get a drop-down list if you clear the field and start typing the first characters offering autocomplete. Otherwise this is done via cookies and possibly JavaScript on the page. So any action that removes cookies or blocks specific JavaScript can cause this feature not to work.

If it is done via saved form data then you should get a drop-down list if you clear the field and start typing the first characters offering autocomplete. Otherwise this is done via cookies and possibly JavaScript on the page. So any action that removes cookies or blocks specific JavaScript can cause this feature not to work.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks for the info. The website references javascipt at the bottom when I examine it with Inspect Element, so it could be done via JS.

Javascipt is enabled and functioning though. So it's just another head scratcher.

Thanks for the info. The website references javascipt at the bottom when I examine it with Inspect Element, so it could be done via JS. Javascipt is enabled and functioning though. So it's just another head scratcher.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

A small note on this, I discovered that the website seems to be remembering it after I log out...

I noticed the other day that when I log out of the site, it remembers my username and "nickname" and displays them on the logged out//relogin website, despite me not having entered the nickname in some time.

So it seems to just be an issue with that particular page of the website.

A small note on this, I discovered that the website seems to be remembering it after I log out... I noticed the other day that when I log out of the site, it remembers my username and "nickname" and displays them on the logged out//relogin website, despite me not having entered the nickname in some time. So it seems to just be an issue with that particular page of the website.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.