X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Isithangami Sabeseki

keybord shortcuts not working on Youtube

Kuphostiwe

keyboard shortcuts not working on Youtube in Firefox, but in Google Chrome - worked. What is problem?

keyboard shortcuts not working on Youtube in Firefox, but in Google Chrome - worked. What is problem?

Okulungisiwe ngu Faurazeko

Isisombululo esikhethiwe

The user agent issue might be caused by changing this setting in the about:config preferences editor:

privacy.resistFingerprinting => true

I don't know whether that would have any effect on keyboard shortcuts. That doesn't sound like a function that would need to be suppressed.

When I tested five keys in a private window (so, logged out), these worked for me: j, k, l, <, >

Since these are plain keys (no Ctrl, etc.), I don't think Firefox's keyboard shortcuts permission would be relevant. However, you could give YouTube specific permission to override keyboard shortcuts to see whether that makes any difference:

While you are on the site, you can call up the Permissions panel of the Page Info dialog using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions

Scroll down to "Override Keyboard Shortcuts" and uncheck the "Use default" box, and then select the "Allow" permission.

(Sorry, the parts in quotation marks are in a different language on yours!)

Funda le mpendulo ngokuhambisana nalesi sihloko 0
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Eminye Imininingwane

McCoy
  • Top 10 Contributor
398 izisombululo 3506 izimpendulo
Kuphostiwe

Hello Faurazeko,

Over the years on different forums many people have reported the same, but no bug report was filed.

If you want to you could file a bug report :

https://bugzilla.mozilla.org/enter_bug.cgi

https://developer.mozilla.org/docs/Mozilla/QA/Bug_writing_guidelines

However, I found this add-on :

https://addons.mozilla.org/en-US/firefox/addon/media-keys/

You could give it a try ....

If that add-on doesn't work for you, there is an alternative :

Install this Chrome extension :

https://chrome.google.com/webstore/detail/streamkeys/ekpipjofdicppbepocohdlgenahaneen?hl=en

But you would have to install this add-on first :

https://addons.mozilla.org/en-US/firefox/addon/chrome-store-foxified/

Hello Faurazeko, Over the years on different forums many people have reported the same, but no bug report was filed. If you want to you could file a bug report : https://bugzilla.mozilla.org/enter_bug.cgi https://developer.mozilla.org/docs/Mozilla/QA/Bug_writing_guidelines However, I found this add-on : https://addons.mozilla.org/en-US/firefox/addon/media-keys/ You could give it a try .... If that add-on doesn't work for you, there is an alternative : Install this Chrome extension : https://chrome.google.com/webstore/detail/streamkeys/ekpipjofdicppbepocohdlgenahaneen?hl=en But you would have to install this add-on first : https://addons.mozilla.org/en-US/firefox/addon/chrome-store-foxified/
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Thanks for the help, but this does not solve my problems. I need all the buttons provided by YouTube, but the extensions cannot provide them all.

Thanks for the help, but this does not solve my problems. I need all the buttons provided by YouTube, but the extensions cannot provide them all.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
398 izisombululo 3506 izimpendulo
Kuphostiwe

Faurazeko said

Thanks for the help, but this does not solve my problems. I need all the buttons provided by YouTube, but the extensions cannot provide them all.

Where problems with add-ons are concerned people will have to contact the author(s), as there is nothing we can do about it  :(

I'm sorry - I really don't know what else to advice you (other than to file a bug report).

''Faurazeko [[#answer-1221772|said]]'' <blockquote> Thanks for the help, but this does not solve my problems. I need all the buttons provided by YouTube, but the extensions cannot provide them all. </blockquote> Where problems with add-ons are concerned people will have to contact the author(s), as there is nothing we can do about it :( I'm sorry - I really don't know what else to advice you (other than to file a bug report).
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

don't apologize you did your best

don't apologize you did your best
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Pj
  • Top 25 Contributor
44 izisombululo 868 izimpendulo
Kuphostiwe

Faurazeko said

Keyboard shortcuts not working on YouTube in Firefox, but in Google Chrome - worked. What is problem?

It was working for me on an earlier FF version. It does now, but not clean. I hit K and the video stops but the Search Box at the bottom pop-up. It's popping-up no matter what letter key is used.

~Pj

''Faurazeko [[#question-1259029|said]]'' <blockquote> Keyboard shortcuts not working on YouTube in Firefox, but in Google Chrome - worked. What is problem? </blockquote> It was working for me on an earlier FF version. It does now, but not clean. I hit '''K''' and the video stops but the Search Box at the bottom pop-up. It's popping-up no matter what letter key is used. ~Pj
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
398 izisombululo 3506 izimpendulo
Kuphostiwe

Faurazeko said

don't apologize you did your best

That's very kind of you ....

I will let you in on a secret : Before you posted this question, I didn't even know those keyboard shortcuts for YouTube existed - I do now, and they work like a charm (using Firefox)  !

Here's an idea : Would you try Safe Mode and see if maybe then those keyboard shortcuts will work  ?

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

And : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Worth a try ......

''Faurazeko [[#answer-1221784|said]]'' <blockquote> don't apologize you did your best </blockquote> That's very kind of you .... I will let you in on a secret : Before you posted this question, I didn't even know those keyboard shortcuts for YouTube existed - I do now, and they work like a charm (using Firefox) ! Here's an idea : Would you try Safe Mode and see if maybe then those keyboard shortcuts will work ? If Firefox is not running : Hold down the Shift key when starting Firefox. If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !) See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode And : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Worth a try ......
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Pj
  • Top 25 Contributor
44 izisombululo 868 izimpendulo
Kuphostiwe

Faurazeko said

Keyboard shortcuts not working on YouTube in Firefox, but in Google Chrome - worked. What is problem?

Try this:

Go to Menu > Options and enter in the Options Search Box:

Block Web

UnCheck (remove the Check Mark) this Box:

Block websites from automatically playing sound.

This got the YouTube keyboard commands working again for me.

See this BugZilla Post - YouTube.

(Looks like it might be fixed in Version 67.)


~Pj

''Faurazeko [[#question-1259029|said]]'' <blockquote> Keyboard shortcuts not working on YouTube in Firefox, but in Google Chrome - worked. What is problem? </blockquote> Try this: Go to '''Menu > Options''' and enter in the Options Search Box: '''Block Web''' UnCheck (remove the Check Mark) this Box: ☑ '''Block websites from automatically playing sound'''. This got the YouTube keyboard commands working again for me. See this '''[https://bugzilla.mozilla.org/show_bug.cgi?id=1549224 BugZilla Post - YouTube]'''. (Looks like it might be fixed in Version '''67'''.) ~Pj

Okulungisiwe ngu Pj

Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

@McCoy , i try it but shortcuts still not working. Apparently, I am doomed to remain with broken keys: (

@McCoy , i try it but shortcuts still not working. Apparently, I am doomed to remain with broken keys: (
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

@Pj , still not woking :(

@Pj , still not woking :(
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
398 izisombululo 3506 izimpendulo
Kuphostiwe

Faurazeko said

@McCoy , i try it but shortcuts still not working. Apparently, I am doomed to remain with broken keys: (

Aww, don't give up hope yet - maybe someone else will come up with the perfect solution for you (fingers crossed .... )

''Faurazeko [[#answer-1221799|said]]'' <blockquote> @McCoy , i try it but shortcuts still not working. Apparently, I am doomed to remain with broken keys: ( </blockquote> Aww, don't give up hope yet - maybe someone else will come up with the perfect solution for you (fingers crossed .... )
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks! :) I hope someone will help me

Thanks! :) I hope someone will help me
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
398 izisombululo 3506 izimpendulo
Kuphostiwe

This may not be relevant in your case, but here it says :

"If you're using the new desktop experience, you must click the video player before using keyboard shortcuts. To return to the classic desktop experience, go to the account icon and click Restore classic YouTube. "

This may not be relevant in your case, but [https://support.google.com/youtube/answer/7631406?hl=en-GB here] it says : "If you're using the new desktop experience, you must click the video player before using keyboard shortcuts. To return to the classic desktop experience, go to the account icon and click Restore classic YouTube. "
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Pj
  • Top 25 Contributor
44 izisombululo 868 izimpendulo
Kuphostiwe

Faurazeko said

@Pj , still not working :(

Did you close then Restart FF after the change?

Is there a reason you're not on FF 66.0.5?

If you would, edit you're initial Question Post and click on Share Data.


~Pj

''Faurazeko [[#answer-1221800|said]]'' <blockquote> @Pj , still not working :( </blockquote> Did you close then Restart FF after the change? Is there a reason you're not on FF '''66.0.5'''? If you would, edit you're initial Question Post and click on '''Share Data'''. ~Pj
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Still. Not. Working. And i use last version of FF

Still. Not. Working. And i use last version of FF
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
398 izisombululo 3506 izimpendulo
Kuphostiwe

Faurazeko said

And i use last version of FF

According to your system details (to the right of your original post) you're on Firefox version 60.0 - could it be that you're using the ESR Firefox version  ?


Two more things I'd like you to try :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

And this :

When you're on YouTube (using Firefox), click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Any luck ?

''Faurazeko [[#answer-1221813|said]]'' <blockquote> And i use last version of FF </blockquote> According to your system details (to the right of your original post) you're on Firefox version 60.0 - could it be that you're using the ESR Firefox version ? ------------------------------------------------------------------------------------------- Two more things I'd like you to try : Clear the Firefox cache : https://support.mozilla.org/en-US/kb/how-clear-firefox-cache And this : When you're on YouTube (using Firefox), click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. Any luck ?
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

unsuccessfully... :(

unsuccessfully... :(
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

And i download deafult version of FF, not ESR

And i download deafult version of FF, not ESR
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
398 izisombululo 3506 izimpendulo
Kuphostiwe

Faurazeko said

unsuccessfully... :(

Aww, I'm so sorry to have put through all that trouble .....

''Faurazeko [[#answer-1221824|said]]'' <blockquote> unsuccessfully... :( </blockquote> Aww, I'm so sorry to have put through all that trouble .....
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
398 izisombululo 3506 izimpendulo
Kuphostiwe

Faurazeko said

And i download default version of FF, not ESR

That's strange, cause according to your system details you're on 60.0 :

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

Would you please take a look at this :

https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox

''Faurazeko [[#answer-1221825|said]]'' <blockquote> And i download default version of FF, not ESR </blockquote> That's strange, cause according to your system details you're on 60.0 : User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0 Would you please take a look at this : https://support.mozilla.org/en-US/kb/how-reset-default-user-agent-firefox
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Pj
  • Top 25 Contributor
44 izisombululo 868 izimpendulo
Kuphostiwe

Faurazeko said

Please, edit you're initial Question Post and click on Share Data.

''Faurazeko [[#question-1259029|said]]'' <blockquote> </blockquote> Please, edit you're initial Question Post and click on '''Share Data'''.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.