X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why is Firefox disabling uBlock? It is one of their recommended blockers?

Kuphostiwe

Firefox notified me that uBlock has been disabled, but when I go to look for a "replacement", uBlock is the second most widely used blocker that Firefox offers. Any suggestions would be most appreciated.

Firefox notified me that uBlock has been disabled, but when I go to look for a "replacement", uBlock is the second most widely used blocker that Firefox offers. Any suggestions would be most appreciated.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Eminye Imininingwane

mozfellow 1 izisombululo 36 izimpendulo
Kuphostiwe

Firefox just disabled ALL my addons, including the current uBlock Origin 1.18.6. In my post about this I pointed out it only happened in FF 66.0.3 on my Windows 7 PC. The copy of FF 66.0.3 on my Windows 10 PC has the same group of addons, and they're not disabled there. Tis a conundrum.

Firefox just disabled ALL my addons, including the current uBlock Origin 1.18.6. In my post about this I pointed out it only happened in FF 66.0.3 on my Windows 7 PC. The copy of FF 66.0.3 on my Windows 10 PC has the same group of addons, and they're not disabled there. Tis a conundrum.
jscher2000
  • Top 10 Contributor
8838 izisombululo 72234 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Sorry, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.)

I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

Sorry, the Add-ons team is working on a fix for this. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.
GeorgeGW 0 izisombululo 6 izimpendulo
Kuphostiwe

In addition to disabling uBlock, Avast Online Security has been disabled!

In addition to disabling uBlock, Avast Online Security has been disabled!

Okulungisiwe ngu GeorgeGW

cor-el
  • Top 10 Contributor
  • Moderator
17690 izisombululo 160039 izimpendulo
Kuphostiwe

See also:

  • Bug 1548973 - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

See also: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1548973 Bug 1548973] - (armagadd-on-2.0) All extensions disabled due to expiration of intermediate signing cert (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Chris Ilias
  • Moderator
362 izisombululo 1959 izimpendulo
Kuphostiwe

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
cor-el
  • Top 10 Contributor
  • Moderator
17690 izisombululo 160039 izimpendulo
Kuphostiwe
See also: *https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/