Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

can't use with messages for web; no qr code displayed for connection

  • 11 uphendule
  • 1 inale nkinga
  • 853 views
  • Igcine ukuphendulwa ngu jbenson

more options

For some reason, firefox will not display a qr code to connect my android phone to "messages for web." I have no problem with connecting using Chrome or Opera. It seems to be only a firefox problem. I use ff all the time so it would be really nice to fix this. Thanks for any help.

Isisombululo esikhethiwe

OK. I disable all of the addons one at a time and still that did not fix the problem. ??

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (11)

more options

Could you describe the steps leading up to the problem? I found this page, but I don't know whether it is the right one:

https://messages.google.com/web/authentication

There does seem to be a delay in generating the QR code in the blue frame, a couple seconds. Presumably the scripts in the site are retrieving or calculating something in the background; I'm not sure.

(I'm not logged in to a Google account; I don't know whether that makes any difference.)


If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

I tried everything in your post and it still does not work. There is a little "i" in a circle on the address bar, but when I click it it say content blocking. I changed all the content blocking settings I could find, including specifying that site specifically and it still does not work. ??

more options

It looks like the QR code might involve a canvas element that is converted to an image. Do you recall making any settings changes related to how a canvas works in Firefox, possibly for privacy or anti-fingerprinting reasons?

more options

I have no idea what a "canvas element" is so I don't think I changed anything related to it. I also tried clear the cache and cookies etc. I do appreciate your help. I would like to get this problem solved.

more options

Any difference in Firefox's Safe Mode? Or you could try:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like May2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do the problem site(s) work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile.

more options

That worked! So what can we learn from this?

more options

jbenson said

That worked! So what can we learn from this?

Well, most likely it is either a setting or an extension causing the problem. But we didn't learn exactly which one... Still, it helps me to know that the problem isn't an external filter (like security software or parental control) but instead something specific to your regular profile.

Do you have any extensions that filter content or isolate it to containers? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that might affect content on a Google site, or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

more options

Isisombululo Esikhethiwe

OK. I disable all of the addons one at a time and still that did not fix the problem. ??

more options

If you notice issues again then check the Web Console for message related to blocked content.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

more options

Cor-el, Thank you for the suggestion. I will keep this as a back up. I'm still in the process of finding out which add on was doing this. I disabled them all and still had the problem. But, then I restarted ff and it now seems to work. I'm adding the add ons back one at a time.

more options

OK. Somehow by disabling all the add ons and then restarting ff seems to have fixed this issue. I'm still not sure why since when I added the add ons back the problem no longer exists. ?? Anyway, thanks for all the help. I will let you know if I discover anything else related to this post.