X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Mac:- Open New Tab in the Background

Kuphostiwe

Similar to the question here https://support.mozilla.org/en-US/questions/1239720 I'm finding that on a Mac I'm getting inconsistent results. If I hold CMD while clicking on a link in Gmail then I will be taken away from the tab I'm currently looking at and straight to the new tab.

If I'm on other web pages holding CMD and clicking on a link means that the new tab will open in the background and I will stay on the current tab. This is the expected behaviour and is consistent with Safari, Chrome, and other browsers.

How can I stop FF from taking me away from the tab I'm currently viewing?

Similar to the question here https://support.mozilla.org/en-US/questions/1239720 I'm finding that on a Mac I'm getting inconsistent results. If I hold CMD while clicking on a link in Gmail then I will be taken away from the tab I'm currently looking at and straight to the new tab. If I'm on other web pages holding CMD and clicking on a link means that the new tab will open in the background and I will stay on the current tab. This is the expected behaviour and is consistent with Safari, Chrome, and other browsers. How can I stop FF from taking me away from the tab I'm currently viewing?

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 66.0.3
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:66.0) Gecko/20100101 Firefox/66.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/66.0.3/Darwin/en-US/

Izandiso

  • Bypass Paywalls 1.4.2 (iamadamdev@hotmail.com)
  • In My Pocket 0.10.5 ({cd7e22de-2e34-40f0-aeff-cec824cbccac})
  • Shorten me - URL Shortener 1.1.1 (shorten.me.mozilla@gmail.com)
  • uBlock Origin 1.18.6 (uBlock0@raymondhill.net)
  • Url Shortener 1.0.7 ({7aa87a02-77e4-44b0-8dc1-acd8f76703c2})

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription:
  • adapterDeviceID: 0x0861
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • lowEndMachine: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 1
  • targetFrameRate: 60
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shading_language_include GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_texture_compression_rgtc EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: NVIDIA Corporation -- NVIDIA GeForce 9400 OpenGL Engine
  • webgl1Version: 3.3 NVIDIA-10.0.52 310.90.10.05b46
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * WebGL 2 requires support for the following features: transform_feedback2
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
McCoy
  • Top 10 Contributor
545 izisombululo 5139 izimpendulo
Kuphostiwe

Hello GregMB,

Would you do this please :

Preferences => General => under 'Tabs' uncheck :

'When you open a link in a new tab, switch to it immediately'.

Now when you press the Cmd key and click a link, the link will be opened in a new tab, but you will still be on the same tab.

Hello GregMB, Would you do this please : Preferences => General => under 'Tabs' '''un'''check : 'When you open a link in a new tab, switch to it immediately'. Now when you press the Cmd key and click a link, the link will be opened in a new tab, but you will still be on the same tab.

Umnikazi wombuzo

Thanks McCoy. But that option was already unchecked and still is and the inconsistent behaviour still happens.

Any other suggestions?

Thanks McCoy. But that option was already unchecked and still is and the inconsistent behaviour still happens. Any other suggestions?
McCoy
  • Top 10 Contributor
545 izisombululo 5139 izimpendulo
Kuphostiwe

GregM8 said

Thanks McCoy. But that option was already unchecked and still is and the inconsistent behaviour still happens. Any other suggestions?

I just tried it and it works for me - do you press the Cmd key and then click a link  ?

''GregM8 [[#answer-1216655|said]]'' <blockquote> Thanks McCoy. But that option was already unchecked and still is and the inconsistent behaviour still happens. Any other suggestions? </blockquote> I just tried it and it works for me - do you press the Cmd key and then click a link ?

Umnikazi wombuzo

Yes, definitely holding down Cmd key and tried it multiple times. This only happens with links in Gmail. Outside of Gmail everything works as it should.

Yes, definitely holding down Cmd key and tried it multiple times. This only happens with links in Gmail. Outside of Gmail everything works as it should.
McCoy
  • Top 10 Contributor
545 izisombululo 5139 izimpendulo
Kuphostiwe

Impendulo Ewusizo

GregM8 said

This only happens with links in Gmail. Outside of Gmail everything works as it should.

I should have paid better attention to your original post - my apologies ......

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar browser.tabs.loadDiverted.

and look for the preference :

browser.tabs.loadDivertedInBackground

and set its value to true (default = false)

Then close and restart Firefox.

Does that work  ?

If this doesn't make a difference, then change the value back.

''GregM8 [[#answer-1216661|said]]'' <blockquote> This only happens with links in Gmail. Outside of Gmail everything works as it should. </blockquote> I should have paid better attention to your original post - my apologies ...... Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''browser.tabs.loadDiverted.''' and look for the preference : '''browser.tabs.loadDivertedInBackground''' and set its value to '''true''' (default = false) Then close and restart Firefox. Does that work ? If this doesn't make a difference, then change the value back.
McCoy
  • Top 10 Contributor
545 izisombululo 5139 izimpendulo
Kuphostiwe

Another thing to try is to go to :

www.google.com

Click on 'Settings' (bottom right) => Search settings

Scroll down to 'Where results open' and uncheck 'Open each selected result in a new browser window'

Then click the blue 'Save' button at the bottom.

Another thing to try is to go to : www.google.com Click on 'Settings' (bottom right) => Search settings Scroll down to 'Where results open' and uncheck 'Open each selected result in a new browser window' Then click the blue 'Save' button at the bottom.

Umnikazi wombuzo

Thanks McCoy

Adjusting browser.tabs.loadDivertedInBackground to true works.

Cheers

Thanks McCoy Adjusting browser.tabs.loadDivertedInBackground to true works. Cheers

Umnikazi wombuzo

Although now that I look closer it now opens all new tabs in the background even if I'm not holding the Cmd key.

Although now that I look closer it now opens all new tabs in the background even if I'm not holding the Cmd key.

Umnikazi wombuzo

"Scroll down to 'Where results open' and uncheck 'Open each selected result in a new browser window'"

Had a look here and it was already unchecked.

"Scroll down to 'Where results open' and uncheck 'Open each selected result in a new browser window'" Had a look here and it was already unchecked.
McCoy
  • Top 10 Contributor
545 izisombululo 5139 izimpendulo
Kuphostiwe

GregM8 said

Although now that I look closer it now opens all new tabs in the background even if I'm not holding the Cmd key.

If that is not what you want : change the value of that preference back to "false" .....

'Must admit that I haven't checked to see how this works (checked the setting in Preferences only), as I don't want those tabs to open in the background all the time.

''GregM8 [[#answer-1216823|said]]'' <blockquote> Although now that I look closer it now opens all new tabs in the background even if I'm not holding the Cmd key. </blockquote> If that is not what you want : change the value of that preference back to "false" ..... 'Must admit that I haven't checked to see how this works (checked the setting in Preferences only), as I don't want those tabs to open in the background all the time.

Umnikazi wombuzo

Yeah, I've changed the setting back. But I still have the fault. Is this something that should be reported as a bug?

Yeah, I've changed the setting back. But I still have the fault. Is this something that should be reported as a bug?
McCoy
  • Top 10 Contributor
545 izisombululo 5139 izimpendulo
Kuphostiwe

Impendulo Ewusizo

GregM8 said

Yeah, I've changed the setting back. But I still have the fault. Is this something that should be reported as a bug?

I went to see if maybe there already was a bug report about this issue and on this page I found this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=661801

Started 8 years ago, last updated 2 years ago, status : NEW, and apparantly not being worked on right now .....

''GregM8 [[#answer-1216827|said]]'' <blockquote> Yeah, I've changed the setting back. But I still have the fault. Is this something that should be reported as a bug? </blockquote> I went to see if maybe there already was a bug report about this issue and [https://bugzilla.mozilla.org/buglist.cgi?query_format=specific&order=relevance+desc&bug_status=__open__&product=&content=links+in+gmail+won't+open+new+tab+in+the+background&comments=0 on this page ] I found this bug report : https://bugzilla.mozilla.org/show_bug.cgi?id=661801 Started 8 years ago, last updated 2 years ago, status : NEW, and apparantly not being worked on right now .....

Umnikazi wombuzo

8 years huh? I guess it's not going to be addressed any time soon.

Thanks for all your help McCoy.

8 years huh? I guess it's not going to be addressed any time soon. Thanks for all your help McCoy.
McCoy
  • Top 10 Contributor
545 izisombululo 5139 izimpendulo
Kuphostiwe

GregM8 said

8 years huh? I guess it's not going to be addressed any time soon.

You could add a comment to that bug report and explain your problem (in a concise manner) and get the ball rolling again (hopefully .....)

''GregM8 [[#answer-1217063|said]]'' <blockquote> 8 years huh? I guess it's not going to be addressed any time soon. </blockquote> You could add a comment to that bug report and explain your problem (in a concise manner) and get the ball rolling again (hopefully .....)