X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Add-ons have disappeared from tool bar. How do I restore them?

Kuphostiwe

I am using Firefox Developer Edition 67.0b13 (64-bit). Recently I restarted with add-ons disabled and they disappeared from the tool bar which was to be expected. But the next time I opened Firefox they were enabled but still not visible in the toolbar or the add-ons page.

The problem here is that the add-ons are still working in the background but I cannot disable them, remove them or change parameters. Does anyone know what is going on here and how I can fix it?

I am using Firefox Developer Edition 67.0b13 (64-bit). Recently I restarted with add-ons disabled and they disappeared from the tool bar which was to be expected. But the next time I opened Firefox they were enabled but still not visible in the toolbar or the add-ons page. The problem here is that the add-ons are still working in the background but I cannot disable them, remove them or change parameters. Does anyone know what is going on here and how I can fix it?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8758 izisombululo 71662 izimpendulo
Kuphostiwe

Hi coolreflection, did the extension buttons end up on the overflow menu at the right end of the bar?

If not, does it help if you disable and re-enable each extension on the Add-ons page? Hopefully they will re-initialize and Firefox will restore the original button position.

If not, you could check for the buttons among the unused icons in the box on the Customize page: Customize Firefox controls, buttons and toolbars.

If they are nowhere to be found, I suggest trying the "Restore Defaults" button at the bottom of the Customize tab to clear the current toolbar customization and then disable/enable each extension.

Any improvement?

Hi coolreflection, did the extension buttons end up on the overflow menu at the right end of the bar? If not, does it help if you disable and re-enable each extension on the Add-ons page? Hopefully they will re-initialize and Firefox will restore the original button position. If not, you could check for the buttons among the unused icons in the box on the Customize page: [[Customize Firefox controls, buttons and toolbars]]. If they are nowhere to be found, I suggest trying the "Restore Defaults" button at the bottom of the Customize tab to clear the current toolbar customization and then disable/enable each extension. Any improvement?
jscher2000
  • Top 10 Contributor
8758 izisombululo 71662 izimpendulo
Kuphostiwe

On second read, if the extensions are not visible on the Add-ons page, Extensions panel, hmm, that shouldn't happen. You could try regenerating the extensions registry file:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then right-click > Rename extensions.json to something like extensionsOLD.json.

Start Firefox back up again, and it should rediscover your extensions and rebuild the file. For externally installed extensions, this may involve permission pages.

Any improvement?

On second read, if the extensions are not visible on the Add-ons page, Extensions panel, hmm, that shouldn't happen. You could try regenerating the extensions registry file: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in File Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > Exit * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then right-click > Rename '''extensions.json''' to something like '''extensionsOLD.json'''. Start Firefox back up again, and it should rediscover your extensions and rebuild the file. For externally installed extensions, this may involve permission pages. Any improvement?
cor-el
  • Top 10 Contributor
  • Moderator
17526 izisombululo 158458 izimpendulo
Kuphostiwe

You can also try to delete compatibility.ini to invalidate the caches and re-initialize the profile.

You can click Restore Defaults in the Customize palette or possibly check browser.uiCustomization.state on the about:config page if the toolbar button to not return.

You can also try to delete compatibility.ini to invalidate the caches and re-initialize the profile. You can click <u>Restore Defaults</u> in the Customize palette or possibly check browser.uiCustomization.state on the <b>about:config</b> page if the toolbar button to not return.