Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

revoke permissions of add on

  • 2 uphendule
  • 1 inale nkinga
  • 330 views
  • Igcine ukuphendulwa ngu bills.apalmer

more options

Hi team,

I want to reset/revoke/deny a permission I accidentally gave to an extension.

The extension is: https://addons.mozilla.org/en-US/firefox/addon/auto-reload-tab/

Once installed, on the options page of this extension > other options > reset timer when interacting with page prompts for access "Access your data for all websites". There is no way to reset this permission? Even after removing the extension I can't get the permission dialog to appear (which indicates the extension still has this permission).

Please help

Isisombululo esikhethiwe

Wow what a quick response. That fixed my exact problem.

Thanks!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

You know, unfortunately, I am not aware of an easy way to do this, but I can give you a slightly complicated method. You will be visiting some tools that most users will never discover.

One-Time Setup

In order to be able to open the console to inject commands into an extension, you need to enable add-on debugging. Here's how:

(1) Call up the Developer Tools panel, for example, by pressing Ctrl+Shift+i

(2) Click the ••• menu button toward the right side of the tools and then click Settings

(3) Scroll down to the Advanced Settings and check the last two boxes as shown in the first attached screenshot

Using the Browser Toolbox Debugger

(1) Open Firefox's Debugging page by typing or pasting the following internal address into Firefox's address bar and pressing Enter to load it

about:debugging

(2) Firefox should display a page showing all the active extensions. Find Auto Reload and click its Debug button as shown in the second attached screenshot

(3) A blank window will appear, and a small permission dialog. Often the permission dialog is behind the blank window, so you may need to use the Firefox button the Windows Taskbar to locate it and click OK as indicated in the third attached screenshot.

(4) Paste the following script into the command line at the bottom of the Console and press Enter to run it:

// Clean out optional "<all_urls>" permission
browser.permissions.getAll().then(resp => {
  if (resp.origins.length == 0){
    console.log('There are no host permissions for this extension');
  } else {
    if (resp.origins.includes('<all_urls>')){
      console.log('Attempting to remove "<all_urls>" permission --');
      browser.permissions.remove({origins: ["<all_urls>"]}).then(msg => {
        console.log('Removal successful (' + msg + ')');}).catch(err => {
        console.log('Problem: ' + err)});
    } else {
      console.log('Did not find the "<all_urls>" permission, but found these hosts: [' + resp.origins.join(',') + ']');
    }
  }
});

The fourth screenshot shows what the script should report if it successfully removed the "all_urls" permission.

You can close this window now.

(5) When you go back to the Auto Reload options page, the button to grant permission should be back since the extension detects that it does not have that permission any more.

Success?

This is a bit of a specialized script, and there may be a more general way to revoke "optional" permissions (optional meaning you can grant or decline after installation). I just didn't find one in a quick search.

more options

Isisombululo Esikhethiwe

Wow what a quick response. That fixed my exact problem.

Thanks!