Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox password tool does not autofill websites

  • 13 uphendule
  • 1 inale nkinga
  • 154 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Within the Login security option I composed 23 websites with my user ID and password. Whenever I navigate to a website whose URL is within the Login tool, to my surprise no autofill action occurs. I've used other password tools including Roboform that does autofill as its main function and expected the same from the Firefox password tool. Hence my query on whether there is some action I need to take to launch the autofill functionality. Thanks in advance for any advice.

Isisombululo esikhethiwe

Can you right-click name and password field on the web page and use "Fill Login" and "Fill Password" to fill the saved login credentials?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (13)

more options

Hi Davidhur, where is this setting exactly?

Within the Login security option I composed 23 websites with my user ID and password.

Normally the way you add logins to Firefox's built-in Password Manager is when Firefox asks you whether you want to save the login for a site. Is that what you did, or import data, or ??

more options

I added logins to the Password Manager when asked by Firefox.

My question is how to get Firefox to autofill the user ID and password into a website that I've navigated to after previously captured by Firefox.

Thanks!

more options

Isisombululo Esikhethiwe

Can you right-click name and password field on the web page and use "Fill Login" and "Fill Password" to fill the saved login credentials?

more options

Note that Firefox won't auto-fill login data if you are in a Private Browsing mode window.

more options

cor-el said

Can you right-click name and password field on the web page and use "Fill Login" and "Fill Password" to fill the saved login credentials?
more options

cor-el's proposed solution is successful most often with a few misfires. I consider the the problem solved. It's a bit surprising that Firefox doesn't prominently disclose this in its Help text.

Many thanks!

more options

Hi Davidhur, could you test something for me. I have a really basic page with a fake login form; use anything you like, but not a real password.

If you use the secure (HTTPS) version, does it require you to right-click or does it autofill on is own?

https://www.jeffersonscher.com/res/logintest.html

I'm attaching a compilation screenshot showing what I think is the default behavior under different conditions (regular window HTTPS, regular window HTTP, private window HTTPS).

Where is yours different?

more options

I use only https so I couldn't perform the test you requested. I'm pretty much a novice so you would do better finding a more skilled support source.

Davidhur

more options

Hi Davidhur, the idea was to test your Firefox to see whether it behaved the same as mine. The steps are:

(1) Open the page

https://www.jeffersonscher.com/res/logintest.html

(2) Log in using fake credentials

(3) Save the login

(4) Load the page again and see whether the login is autofilled, or appears in a drop-down below the user name field, or something else

more options

Hi jscher2000:

I attempted to follow your instructions. The below image shows the website listed in Firefox's Password Manager PM).

When I reopened the login, there was no action by Firefox.

I presume that proves that the PM did not function.

Davidhur

more options

Hi Davidhur, you don't even get the little drop-down to select your username from a list?

Could you double-check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste signon and pause while the list is filtered

(3) If the signon.autofillForms preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

(4) Are there any other bolded (customized) items on the list? If you have been running Firefox for a long time, you might have signon.importedFromSqlite=true; don't worry about that one.

more options

signon.autofillForms is marked "True". There is also the Sqlite item as true.

I'm runny Firefox 52.9 thats not currently supported.

Maybe you need to find a user with a currently viable version of Firefox.

I'm being called to supper.

David

more options

Hi David, I thought you were having this problem with Firefox 66. Never mind!