X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 66.0.2: left-mouse button selects don't work on www.jetblue.com webpage

Kuphostiwe

Everything works in IE and Explorer. In Firefox 66.0.2, when I LMB click to select "One-way" trip, it doesn't accept input. Same goes for any other webpage button. No error messages are reported. I've tried disabling all Add-ons and running in safe mode: nothing helps. www.jetblue.com webpage is now completely unusable in Firefox 66.0.2.

Everything works in IE and Explorer. In Firefox 66.0.2, when I LMB click to select "One-way" trip, it doesn't accept input. Same goes for any other webpage button. No error messages are reported. I've tried disabling all Add-ons and running in safe mode: nothing helps. www.jetblue.com webpage is now completely unusable in Firefox 66.0.2.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17472 izisombululo 157915 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Works here with the current Firefox release, so I assume that you have some content blocking extension(s) active that cause this issue. I have Content Blocking enabled and see the shield icon, but that doesn't seem to cause problems. The Web Console shows quite a few messages about blocked content.

Do you have any content blocking extensions?

I think that there is a lot of JavaScript involved with these input fields, so if you use any ch extensions then make sure they do not block essential content.

Works here with the current Firefox release, so I assume that you have some content blocking extension(s) active that cause this issue. I have Content Blocking enabled and see the shield icon, but that doesn't seem to cause problems. The Web Console shows quite a few messages about blocked content. Do you have any content blocking extensions? I think that there is a lot of JavaScript involved with these input fields, so if you use any ch extensions then make sure they do not block essential content.

Umnikazi wombuzo

I'm using a regular window (not Private), and I also have Content Blocking enabled (Standard setting) with no exceptions. I just tried the Web Console, and I, too, see quite a few messages about blocked content. I've tried disabling all extensions and running Firefox in safe mode, but that doesn't help. I don't believe I have any ch (Chrome?) extensions. IE and Explorer work for the same website, so it's not a network problem. Is it possible that my Firefox installation has been corrupted in some way or some cruft left behind from previously installed extensions?

I'm using a regular window (not Private), and I also have Content Blocking enabled (Standard setting) with no exceptions. I just tried the Web Console, and I, too, see quite a few messages about blocked content. I've tried disabling all extensions and running Firefox in safe mode, but that doesn't help. I don't believe I have any ch (Chrome?) extensions. IE and Explorer work for the same website, so it's not a network problem. Is it possible that my Firefox installation has been corrupted in some way or some cruft left behind from previously installed extensions?

Umnikazi wombuzo

Thanks for all your tips! :) I was not able to permanently fix the problem with the website. At first, I thought the problem was related to an extension, but then I found that a fresh install of Firefox with no Addons still shows this issue.

Thanks for all your tips! :) I was not able to permanently fix the problem with the website. At first, I thought the problem was related to an extension, but then I found that a fresh install of Firefox with no Addons still shows this issue.

Okulungisiwe ngu Ed_Ouellette

Umnikazi wombuzo

How to reproduce the issue with Firefox 66.0.2: 1. navigate to www.jetblue.com Everything works initially. Left-mouse button clicks work fine.

2. Refresh the page. Upon page reload, left-mouse button clicks no longer update buttons or select website tabs.

3. restarting Firefox, disabling Add-ons, and even a complete, clean reinstall of Firefox make no difference.

The problem appears to be with 1 saved cookie from www.jetblue.com. Deleting this cookie, then opening a new tab to www.jetblue.com repeats the process 1. above (i.e. everything works initially again until page reload).

What's up with this? It seems to be either a bug in Firefox in parsing cookies or a cookie that's somehow out-of-spec. Hopefully, this helps narrow down the problem. Please help!

How to reproduce the issue with Firefox 66.0.2: 1. navigate to www.jetblue.com Everything works initially. Left-mouse button clicks work fine. 2. Refresh the page. Upon page reload, left-mouse button clicks no longer update buttons or select website tabs. 3. restarting Firefox, disabling Add-ons, and even a complete, clean reinstall of Firefox make no difference. The problem appears to be with 1 saved cookie from www.jetblue.com. Deleting this cookie, then opening a new tab to www.jetblue.com repeats the process 1. above (i.e. everything works initially again until page reload). What's up with this? It seems to be either a bug in Firefox in parsing cookies or a cookie that's somehow out-of-spec. Hopefully, this helps narrow down the problem. Please help!
cor-el
  • Top 10 Contributor
  • Moderator
17472 izisombululo 157915 izimpendulo
Kuphostiwe

It is probably not the extension that cause it, but the fact that it modifies the behavior of Firefox and Firefox stores this as part of the Site Preferences or otherwise there might be data in the disk cache. Using "Forget About This Site" should fix such issues.

It is probably not the extension that cause it, but the fact that it modifies the behavior of Firefox and Firefox stores this as part of the Site Preferences or otherwise there might be data in the disk cache. Using "Forget About This Site" should fix such issues.

Umnikazi wombuzo

Thanks for the suggestion, but this is not an acceptable solution. "Forget About This Site" doesn't have any lasting effect, so if I revisit such a 'forgotten' website then data from that website will be saved once again, and the problem will reappear.

This is a cookie / Firefox bug, as deleting a single cookie from www.jetblue.com temporarily fixes the issue. I do not need to delete anything else (data cache, bookmarks, etc.). It is definitely not an extension problem since a fresh install of Firefox still has this issue.

Would someone please investigate the www.jetblue.com stored cookie for any syntax (or whitespace?) errors? It may also be a bug in Firefox as to how it handles this cookie. All other browsers I've tried (Chrome, IE, Explorer) do not have issues with this website.

Thanks for the suggestion, but this is not an acceptable solution. "Forget About This Site" doesn't have any lasting effect, so if I revisit such a 'forgotten' website then data from that website will be saved once again, and the problem will reappear. This is a cookie / Firefox bug, as deleting a single cookie from www.jetblue.com temporarily fixes the issue. I do not need to delete anything else (data cache, bookmarks, etc.). It is definitely not an extension problem since a fresh install of Firefox still has this issue. Would someone please investigate the www.jetblue.com stored cookie for any syntax (or whitespace?) errors? It may also be a bug in Firefox as to how it handles this cookie. All other browsers I've tried (Chrome, IE, Explorer) do not have issues with this website.