Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

FF help says 'click on the key icon at the left side of the address bar' to activate the Save PW function. The latest FF has no key icon. What do you do?

  • 7 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu FredMcD

more options

I am running Firefox 66.0.2 (64-bit) on a Windows 10 machine, up to date at 1 April 2019. (No this is not an April Fool's joke!)

Some time ago, Firefox (and Thunderbird) stopped saving logins and passwords and as I had better things to do, I just put up with it. Now I would like to sort the problem out, but can find nothing specific on this problem. The closest advice is at:

On this page the advice is all about clicking an a key icon. Problem is: the latest version of Firefox has no key icon.

When I check under Options-> Privacy & Security->Logins & Passwords the box to tick for "Ask to save logins and passwords for websites" is faded out and does not work.

I have tried to attach screen shots of the instructions described, but they will not load.

I have looked all over Firefox Help but all the answers direct you back to the about instruction about clicking the key icon which is simply not present on my screen.

Other thoughts:-

Could Avast Free Antivirus have given me a 'free trial' that has upset the system?

Could Duckduckgo be in conflict with Firefox about privacy, i.e. password management?

Any suggestions?


All Replies (7)

more options

The key icon will only appear at the left end of the location/address bar when the Password Manager notices a username and password field on the page and you have submitted this form. Not all forms are detected and in that case you do not see the key icon.

more options

I see you are using LastPass. Is it active?

more options

FredMcD asks: "I see you are using LastPass. Is it active?"

I made the mistake of buying it only to find that you have to log in continuously all day, for as many times as you leave you computer and it goes off because nothing is being done, which is in itself a very good security feature.

What this means is that you spend as much time logging in to LastPass as you do actually entering the username and PW of the app you intend to use. I have friends who work in offices who log off every time they leave their desk. I imagine how tedious the double-logging on would become for them. I have emailed LPass for a work around: if none, I am going to ditch it. It is not being used at present and the overall PW problem precedes it you many months.

more options

cor-el said

The key icon will only appear at the left end of the location/address bar when the Password Manager notices a username and password field on the page and you have submitted this form. Not all forms are detected and in that case you do not see the key icon.

Unfortunately, this is not so. Once upon a time when I went to say GMX's log-on page and put in my user name and PW, a dialogue box dropped down at left asking if you wanted to save this logon info. After saying yes, thereafter you only had to start typing your username and a suggestion appeared below which you could click on to fill in the box. Ditto the PW. Now nothing happens either way. I checked in Thunderbird's Saved PWs and all the log-on name and PW info was present and correct. The system just was not reaching it and so when you started filling in the username and PW nothing happened: and when you had finished there was no: "Do you want this log-on saved etc?" - just nothing!

I recently fell in a hole trying to install a Cannon printer for a friend. In the end I discovered from Cannon Help that Avast was known to bugger up such install programmes: answer was turn off Avast; install the printer (worked perfectly 1st time!): turn Avast back on again. No more problem!

What interests me is that as soon as I posted this question, Avast popped up a full-screen ad for, guess what: an Avast password manager. W what an amazingly timed coincidence!

more options

If you are not using LastPass, disable it. It could interfere with the Password Manager.

more options

Thanks for the LastPass tip. As it is a very new install and the password problem predates in my many many months, I do not think it is the problem.

I think I have nailed it though. I made the big mistake of clicking on Avast's "Privacy" button, the one that looks like a fingerprint, as from memory Avast had previously thrown a free password controller at me and I tried it on a few sites. This looked like the same beast.

What I have now discovered is that if you go into this "Privacy" section of Avast, it deletes all your passwords from Firefox and sucks them back into Avast and saves them there. So your Firefox password system is now sucked dry and does not work at all, which I only discovered later! So unaware of this I then clicked to go to the next step of Avast's password setup, but Firefox lit up with a big warning: there be dragons! So I did not complete the process. I now find all my passwords, formerly saved in Firefox are not working, for the simple reason that they have been deleted from Firefox by Avast and put in Avast's 'pending offer' of a password system. Previously only some passwords on some sites did not work. I suspect that those few were the ones I tried on Avast's free demo, some time ago.

I have also found in setting up a friend's computer that Avast has acquired a nasty habit of enticing you down a path with an offer of some extra service and not mentioning that it costs extra, on top of the basic price you have already paid for the pro-edition. Then when you get to the last stage of the set-up, it drops you into a payment screen.

The only way out of this which I can see is to copy manually one by one all the site names, usernames and passwords from Avast's pending file, to a safe place and then reinstall them one by one in Firefox. This will probably mean a fresh install of Firefox, as after the first Avast password offer, while previous untouched passwords continued to work, you could not set up any new ones, which is the problem upon which this discussion began! So it seems Avast raided the password file in Firefox, took out some which I chose for a demo and then also destroyed Firefox's ability to add any new ones too.

My thanks to all who have contributed to this discussion.

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.