Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After changing pw Firefox does NOT ask to save the new pw & does NOT autofill with new pw even after manually changing pw mgr & restarting my mac. Why?

  • 1 baphendule
  • 1 inale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu cor-el

more options

Firefox version: 66.0.2 Computer: Mac OS 10.13.6 I just changed my web mail password. The new password was accepted by the web mail site. The old password does NOT work. The new password DOES. I restarted the computer after making the change. When I signed back into my web mail site I had to input my new password. Firefox DID NOT ask to save the new password. (This feature IS turned on in the preferences.) When I signed out of Web mail and signed back in the NEW password was NOT automatically filled in. I went to the password manager and MANUALLY changed the password. I signed out of the web mail site and restarted the computer. When I signed back into the web mail site it STILL AUTOMATICALLY input the OLD password and I had to manually input the new one. I checked the password manager and the NEW password is there with today's date as the last time it was changed. I checked other sites with saved passwords and they still operate as the always have.

Why is this happening? What can I do to get it to ask & populate properly?

All Replies (1)

more options

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

See also: