Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I remove the "English (Philippines)" dictionary?

  • 4 uphendule
  • 1 inale nkinga
  • 78 views
  • Igcine ukuphendulwa ngu Malvineous

more options

Whenever I am typing in a text field, words are marked incorrect when they are not. Right-clicking on the text field and choosing "Language" shows the selected language is "English (Philippines)" instead of my preferred "English (Australia)". Once I change it to en-AU then the words are shown as being spelled correctly, however I am always having to change this as en-PH seems to have somehow become the default.

I would like to remove the en-PH dictionary entirely (seeing as there is apparently no way to make Firefox default to en-AU) but I cannot work out how to do this.

In my Firefox installation folder (/usr/lib/firefox) I can only find files for en-US and the en-GB language pack. In my own profile folder I have the en-AU add-on, but that is all. about:addons only shows the en-GB pack and en-AU dictionary, with en-PH nowhere to be seen. Searching my profile folder and the Firefox installation folder for *.dic or *.aff reveals no files at all.

Where is the en-PH dictionary coming from, and how can I remove it? I've attached screenshots of everything I can find that's language-based.

Many thanks for any help you can provide!

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Firefox scans other locations for dictionary files on Linux.

You can check these locations for globally installed dictionaries:

/usr/share/hunspell/
/usr/share/myspell/

I see some problematic info ("und" = undefined) reported in the troubleshooting information. So Firefox could have a problem with the default locale reported by the OS.

osPrefs:
regionalPrefsLocales:["en-AU"];
systemLocales:["en-AU"]; 
localeService: available:["en-GB","en-US"];
requested:["en-AU","en-US"];
regionalPrefs:["en-AU"];
supported:["en-US","en-GB","und"];
defaultLocale:"und";

See also these prefs:

  • intl.locale.requested = "en-AU,en-US"
    (you can try to create this String pref)
  • intl.regional_prefs.use_os_locales
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options

Isisombululo Esikhethiwe

Firefox scans other locations for dictionary files on Linux.

You can check these locations for globally installed dictionaries:

/usr/share/hunspell/
/usr/share/myspell/

I see some problematic info ("und" = undefined) reported in the troubleshooting information. So Firefox could have a problem with the default locale reported by the OS.

osPrefs:
regionalPrefsLocales:["en-AU"];
systemLocales:["en-AU"]; 
localeService: available:["en-GB","en-US"];
requested:["en-AU","en-US"];
regionalPrefs:["en-AU"];
supported:["en-US","en-GB","und"];
defaultLocale:"und";

See also these prefs:

  • intl.locale.requested = "en-AU,en-US"
    (you can try to create this String pref)
  • intl.regional_prefs.use_os_locales
more options

Malvineous said

In my Firefox installation folder (/usr/lib/firefox) I can only find files for en-US and the en-GB language pack. In my own profile folder I have the en-AU add-on, but that is all. about:addons only shows the en-GB pack and en-AU dictionary

So you know, the Language Packs are used to change the language of the user interface and has nothing to do with the inline spellchecker. https://support.mozilla.org/en-US/kb/use-firefox-another-language

Okulungisiwe ngu James

more options

The screenshot shows you have a en-GB language pack (3) and the en-AU dictionary (2).

What is the default Firefox locale you have installed? Is that the en-US Firefox version that includes the en-US dictionary?

If you do not need the en-US dictionary then you can possibly install the en-GB version that doesn't come with a dictionary.

more options

That was the problem! My Linux distro (Arch Linux) for some reason installs the en_PH dictionary when en_US is installed, in /usr/share/hunspell. Firefox was picking this up and somehow choosing it as the default.

I wasn't able to change the default - even setting those about:config settings to en_AU, however with en_PH now removed, it seems to default to en_AU now which is perfect.

Many thanks for your help!