Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Since upgrading to FF 66 Netflix videos don't play.

  • 3 uphendule
  • 1 inale nkinga
  • 31 views
  • Igcine ukuphendulwa ngu HLMSPL

more options

I had no problem playing Netflix videos before FF 66. I'm now on FF 66.0.1. I disabled all add-ons, restarted FF to no avail. This issue MIGHT be DRM related since preview vids play correctly in Netflix. They aren't DRM controlled. The full videos, which are DRM controlled, do not play. 'Play DRM-Controlled Content' is checked in my FF settings. I can play full videos as expected in Chrome. I prefer not to for obvious reasons. The NF error code is F7701-1003. The msg is 'There appears to be a problem with Firefox which is preventing Netflix from starting playback'. I've gone through the steps that NF suggest for this issue. Doing that doesn't resolve the issue.

Isisombululo esikhethiwe

Do you have history to be remembered?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

Do you have history to be remembered?

more options

TyDraniu said

Do you have history to be remembered?

I had History disabled. After reading your question I enabled it and restarted FF. NF videos are playing properly now. Thank you!

Okulungisiwe ngu HLMSPL

more options

p.s. it seems odd that Remember History has to be enabled for this. I seem to remember having it disabled in pre-66 releases. Maybe I'm wrong. :) Thanks again.

Okulungisiwe ngu HLMSPL