Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I keep the Gmail cookie?

  • 7 uphendule
  • 1 inale nkinga
  • 34 views
  • Igcine ukuphendulwa ngu jscher2000

more options

I use 'Delete cookies and site data when Firefox is closed' and 'Manage Permissions' to allow some cookies. 'Mail.google.com' doesn't work and there's no cookie specific to email in 'Manage Data'.

All Replies (7)

more options

Hello LSPIII,

Would you try this please :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

more options

This didn't help.

more options

As you recall, you log in on https://accounts.google.com/ and not on the Gmail domain. I think Google shares the login cookie across its domains. Therefore, I suspect you need to consider keeping all Google cookies using this exception:

https://google.com => Allow

However, if you find something more restrictive that works, by all means, feel free to use it.

more options

These are the cookies I have allowed:

accounts.google.com google.com lastpass.com

I had disabled all add-ons, cleared data, and cleared history. I still have the problem.

Okulungisiwe ngu LAPIII

more options

In your original post you say :

" Mail.google.com doesn't work "; could you be a bit more
specific  ? What exactly doesn't work  ? Page doesn't open  ? You can't
log in  ?
Something else  ?


(edit : typo ... )

Okulungisiwe ngu McCoy

more options

McCoy said

In your original post you say : " Mail.google.com doesn't work ";

I meant that I put it into Manage Permissions. When I open Firefox, Gmail is supposed to open. But it give me the sign in page.

Okulungisiwe ngu LAPIII

more options

Hi LAPIII, after logging in to your Google account, if you open the Storage Inspector and look at your Google cookies, do they all have future expiration dates, i.e., they are not session cookies?

You can open that by pressing Shift+F9 or through the menu.

https://developer.mozilla.org/docs/Tools/Storage_Inspector