X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable middle click tab bar

Kuphostiwe

Why is this a feature without the option to disable when none of the other browsers has this feature?

It's really annoying trying to close a tab only to open a new one again because you middle clicked on the empty portion of the tab bar.

Why is this a feature without the option to disable when none of the other browsers has this feature? It's really annoying trying to close a tab only to open a new one again because you middle clicked on the empty portion of the tab bar.

Isisombululo esikhethiwe

Try:

#tabbrowser-tabs .arrowscrollbox-scrollbox{pointer-events: none}
.tabbrowser-tab,.tabs-newtab-button{pointer-events: auto}

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Eminye Imininingwane

WestEnd
  • Top 25 Contributor
60 izisombululo 5376 izimpendulo
Kuphostiwe

Screenshot of the problems your referring to?

Screenshot of the problems your referring to?

Umnikazi wombuzo

Here's a GIF to show what I'm talking about.

Here's a GIF to show what I'm talking about.
cor-el
  • Top 10 Contributor
  • Moderator
17419 izisombululo 157376 izimpendulo
Kuphostiwe

That is how about middle-clicking on the Tab bar works. I'm not aware of a way to disable it or if there is an extension that adds this feature. You could keep that many tabs open that the entire Tab bar is filled with tabs.

That is how about middle-clicking on the Tab bar works. I'm not aware of a way to disable it or if there is an extension that adds this feature. You could keep that many tabs open that the entire Tab bar is filled with tabs.

Umnikazi wombuzo

The issue is that there should at least be an option to disable this feature seeing as other browsers such as Chrome, and Edge does not have this.

There was a CSS tweak to disable this, but the recent update caused the tweak to stop working.

The issue is that there should at least be an option to disable this feature seeing as other browsers such as Chrome, and Edge does not have this. There was a CSS tweak to disable this, but the recent update caused the tweak to stop working.
the-edmeister
  • Top 25 Contributor
  • Moderator
5395 izisombululo 40084 izimpendulo
Kuphostiwe

ZetiX said

... There was a CSS tweak to disable this, but the recent update caused the tweak to stop working.

If you would post that CSS tweak here we may learn something.

''ZetiX [[#answer-1207668|said]]'' <blockquote> ... There was a CSS tweak to disable this, but the recent update caused the tweak to stop working. </blockquote> If you would post that CSS tweak here we may learn something.

Umnikazi wombuzo

  1. tabbrowser-tabs .scrollbox-innerbox{pointer-events: none}

.tabbrowser-tab,.tabs-newtab-button{pointer-events: auto}

Here's the PasteBin link , the forum formats the text.

#tabbrowser-tabs .scrollbox-innerbox{pointer-events: none} .tabbrowser-tab,.tabs-newtab-button{pointer-events: auto} Here's the [https://pastebin.com/aFE85cPM PasteBin link] , the forum formats the text.

Okulungisiwe ngu ZetiX

cor-el
  • Top 10 Contributor
  • Moderator
17419 izisombululo 157376 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Try:

#tabbrowser-tabs .arrowscrollbox-scrollbox{pointer-events: none}
.tabbrowser-tab,.tabs-newtab-button{pointer-events: auto}

Try: <pre><nowiki>#tabbrowser-tabs .arrowscrollbox-scrollbox{pointer-events: none} .tabbrowser-tab,.tabs-newtab-button{pointer-events: auto}</nowiki></pre> ---- *https://www.userchrome.org/how-create-userchrome-css.html *https://www.userchrome.org/what-is-userchrome-css.html

Okulungisiwe ngu cor-el

Umnikazi wombuzo

cor-el said

Try:
#tabbrowser-tabs .arrowscrollbox-scrollbox{pointer-events: none}
.tabbrowser-tab,.tabs-newtab-button{pointer-events: auto}

This worked! Thanks so much!

''cor-el [[#answer-1207690|said]]'' <blockquote> Try: <pre><nowiki>#tabbrowser-tabs .arrowscrollbox-scrollbox{pointer-events: none} .tabbrowser-tab,.tabs-newtab-button{pointer-events: auto}</nowiki></pre> </blockquote> This worked! Thanks so much!
cor-el
  • Top 10 Contributor
  • Moderator
17419 izisombululo 157376 izimpendulo
Kuphostiwe

You're welcome

You're welcome
Red 0 izisombululo 2 izimpendulo
Kuphostiwe

cor-el said

Try:
#tabbrowser-tabs .arrowscrollbox-scrollbox{pointer-events: none}
.tabbrowser-tab,.tabs-newtab-button{pointer-events: auto}

How do I try this? I went into \AppData\Roaming\Mozilla\Firefox\Profiles\

Then I made a folder named 'chrome' and put a userChrome.css in it, with only those two lines in it but I still get a new tab if I MM click the tab bar's empty space.

''cor-el [[#answer-1207690|said]]'' <blockquote> Try: <pre><nowiki>#tabbrowser-tabs .arrowscrollbox-scrollbox{pointer-events: none} .tabbrowser-tab,.tabs-newtab-button{pointer-events: auto}</nowiki></pre> </blockquote> How do I try this? I went into \AppData\Roaming\Mozilla\Firefox\Profiles\ Then I made a folder named 'chrome' and put a userChrome.css in it, with only those two lines in it but I still get a new tab if I MM click the tab bar's empty space.

Impendulo Ewusizo

You have to create the chrome folder inside the xxxxx.default folder, then create the userChrome.css with those 2 lines.

You have to create the chrome folder inside the xxxxx.default folder, then create the userChrome.css with those 2 lines.
Red 0 izisombululo 2 izimpendulo
Kuphostiwe

Yep, that did it. Thanks kindly, ZetiX.

Yep, that did it. Thanks kindly, ZetiX.