Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox screenshots suddenly stopped downloading my shots

  • 9 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options


Suddenly, when using the screenshots tool, it doesn't save save my shot when I screenshot it and click on the "Download" button anymore.

Nothing happens and I can't see anymore that blue down arrow beside the URL bar.

Isisombululo esikhethiwe

Could be an issue with this extension: that shows in the System Details list.

  • Awesome Screenshot - Capture, Annotate & More
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (9)

more options

The downloading feature to upload the screenshot to internet has been suspended and is no longer available. You can only save the screenshot to your hard drive if that is what you are referring to.

more options

Hello cor-el,

Thank you for being concrened about my issue, much appreciated.

Yes, I was referring to local hard-drive saving and not cloud uploading.

Sorry if this wasn't clear.

Thank you :)

Okulungisiwe ngu Hesham_3del

more options

You should still be able to save the screenshot to your local hard drive. This hasn't changed and won't change, only uploading is no longer possible.

Does this problem also happen if you use the screenshot feature offered by the developer tools?

more options

Here is what happens.

When I right click and choose "Take a screenshot", a cursor appears to highlight the area I want to shot.

After highlighting that area, I press the "arrow pointed downwards' button.

I knew if my capture was successful or not by keeping an eye on the downloads button beside the URL bar where it animates in blue.

Now when I do the same scenario, that downloads button never animates and the screenshot is not captured, in other words, the "arrow pointed downwards' button is broken.

Everything was working perfect till today, before and after the update.

I even in a new FF window, maybe it was OneTab issue or something although I've been using OneTab for sometime now, still the problem persists unfortunately.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

I started Firefox in Safe Mode and tried taking screenshots 3 times simultaneously and it worked flawlessly.

But I can assure you that since yesterday nothing changed on my PC or Firefox specifically, just the upgrade to v66 no more, if the reason behind this is one of the extensions or the add-ons.

more options

Isisombululo Esikhethiwe

Could be an issue with this extension: that shows in the System Details list.

  • Awesome Screenshot - Capture, Annotate & More
more options

I've removed it.

And guess what, back to basics again after that Safe Mode move, everything is working flawlessly before removing that extension but I've removed anyway as I don't need it anymore.

I guess the problem is solved now.

Thank you so much for helping me out cor-el, insanely appreciated really.

Thank you again and have a great day ! :)

more options

You're welcome and glad that it is working again. A fine day for you as well!

Okulungisiwe ngu cor-el