Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox keeps blocking websites when surfing in the company network

  • 1 baphendule
  • 1 inale nkinga
  • 2 views
  • Igcine ukuphendulwa ngu cor-el

more options

Using the latest Firefox 64bit on Windows 10. At the company I work for firefox is not the default browser but IT-Administration tolerates the use, though does not give any support on occuring issues. Up to know this was fine, but recently more and more websites are not displayed in firefox since it tells some certificate is not up to date. While in Chrome and Edge browser those sites work. I found some mozilla support page telling some things IT administration could do about this, but since the other two browsers work I don't get help there. Leaves me in switching away from my favorite to use chrome in future. So I hope you can iprove this and maybe get me back. This problem is not only with some fancy websites but with such common ones as google or company internal pages. There seems to be no way to create an exception list or some workaround. So I'm forced to use another browser which is increasingly annoying.

All Replies (1)

more options

Try to set this pref to true on the about:config page in case other software adds its root certificate to the Windows certificate store.

  • security.enterprise_roots.enabled = true

See also: