X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

How can I turn off the annoying blue drop down "search with" box in FF65?

Kuphostiwe

Since installing Firefox 65 on my mac, an annoying blue dropdown box appears every time I search using the URL bar (Awesome Bar?). I can't tun it off. Please see attached screen shot. Prefs/Search/Provide Search Options box is unchecked. about:config/browser.urlbar.autocomplete.enabled is set to False. I would really like to turn it off. Any ideas? Thanks in advance.

Since installing Firefox 65 on my mac, an annoying blue dropdown box appears every time I search using the URL bar (Awesome Bar?). I can't tun it off. Please see attached screen shot. Prefs/Search/Provide Search Options box is unchecked. about:config/browser.urlbar.autocomplete.enabled is set to False. I would really like to turn it off. Any ideas? Thanks in advance.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Hello strewth101,

There are wto different 'blue bars' that can appear under the address bar : there's the blue 'Visit' bar (which I use instead of pressing the Enter key) and there's the blue 'Search with' bar that you are talking about.

To get rid of the latter, all you have to do is :

On the 'about:config' page set the value of the preference keyword.enabled to false (and then close and restart Firefox).


In case you don't want anything to appear under the address bar :

Type in the search bar browser.urlbar.

Look for the preference :

browser.urlbar.maxRichResults

And set its value to 0 (= zero)

(then close and restart Firefox)

Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:65.0) Gecko/20100101 Firefox/65.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4185 izisombululo 58417 izimpendulo
Kuphostiwe

Don't worry about it. Finish entering what you want and press Enter.

Don't worry about it. Finish entering what you want and press Enter.
Ingabe lokhu kube usizo kuwena? 0
Isicaphuno

Umnikazi wombuzo

Yeah, that's what my wife said. I'm aware there are more pressing problems in the world. But I find it annoying. Like someone trying to finish my sentences for me. Does anyone else have a solution?

Yeah, that's what my wife said. I'm aware there are more pressing problems in the world. But I find it annoying. Like someone trying to finish my sentences for me. Does anyone else have a solution?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
philipp
  • Top 25 Contributor
  • Moderator
5280 izisombululo 23327 izimpendulo
Kuphostiwe

hi, support for the browser.urlbar.autocomplete.enabled preference got removed in firefox 65 unfortunately.

as a workaround you could try creating a userChrome.css file with the following content in order to hide the addressbar dropdown-menu:

#PopupAutoCompleteRichResult {

  display: none!important;

}

https://www.userchrome.org/how-create-userchrome-css.html

hi, support for the browser.urlbar.autocomplete.enabled preference got removed in firefox 65 unfortunately. as a workaround you could try creating a userChrome.css file with the following content in order to hide the addressbar dropdown-menu: <code>#PopupAutoCompleteRichResult { display: none!important; }</code> https://www.userchrome.org/how-create-userchrome-css.html
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Thanks philipp. userChrome.css files are new to me. I'll give it a go when I have more time.

Thanks philipp. userChrome.css files are new to me. I'll give it a go when I have more time.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
488 izisombululo 4493 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Hello strewth101,

There are wto different 'blue bars' that can appear under the address bar : there's the blue 'Visit' bar (which I use instead of pressing the Enter key) and there's the blue 'Search with' bar that you are talking about.

To get rid of the latter, all you have to do is :

On the 'about:config' page set the value of the preference keyword.enabled to false (and then close and restart Firefox).


In case you don't want anything to appear under the address bar :

Type in the search bar browser.urlbar.

Look for the preference :

browser.urlbar.maxRichResults

And set its value to 0 (= zero)

(then close and restart Firefox)

Hello strewth101, There are wto different 'blue bars' that can appear under the address bar : there's the blue 'Visit' bar (which I use instead of pressing the Enter key) and there's the blue 'Search with' bar that you are talking about. To get rid of the latter, all you have to do is : On the 'about:config' page set the value of the preference '''keyword.enabled''' to '''false''' (and then close and restart Firefox). ---------------------------------------------------------------------------------------------- In case you don't want ''anything'' to appear under the address bar : Type in the search bar '''browser.urlbar.''' Look for the preference : '''browser.urlbar.maxRichResults''' And set its value to '''0''' (= zero) (then close and restart Firefox)
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Thanks McCoy. The blue box's reign of terror is over. Thanks again to philipp. I'm sure your workaround would've worked too.

Thanks McCoy. The blue box's reign of terror is over. Thanks again to philipp. I'm sure your workaround would've worked too.
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Btw, it was setting the browser.urlbar.maxRichResults to 0 that did the trick. Setting keyword.enabled to False prevented use of the URL bar as a search engine, which wasn't my plan. Thanks again.

Btw, it was setting the '''browser.urlbar.maxRichResults''' to 0 that did the trick. Setting '''keyword.enabled''' to False prevented use of the URL bar as a search engine, which wasn't my plan. Thanks again.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
bugamode433T 0 izisombululo 1 izimpendulo
Kuphostiwe

Here is what worked for me FF 65.0.2 Win64

in about:config

Set the following

browser.urlbar.maxRichResults > 0 browser.urlbar.OneOffSearches > false

Others have said to set services.sync.prefs.sync.browser.urlbar.maxRichResults >False

but I found no affect. In other words, the first two items worked and the 3rd one (services.sync.prefs.sync.browser.urlbar.maxRichResults) does not matter

Thanks to all for the help in piecing this together. Note to FF developers: KISS Keep it simple is a better policy. The Bluebar is a distraction that the old blinking text that was removed in CSS

Here is what worked for me FF 65.0.2 Win64 in about:config Set the following browser.urlbar.maxRichResults > 0 browser.urlbar.OneOffSearches > false Others have said to set services.sync.prefs.sync.browser.urlbar.maxRichResults >False but I found no affect. In other words, the first two items worked and the 3rd one (services.sync.prefs.sync.browser.urlbar.maxRichResults) does not matter Thanks to all for the help in piecing this together. Note to FF developers: KISS Keep it simple is a better policy. The Bluebar is a distraction that the old blinking text that was removed in CSS

Okulungisiwe ngu bugamode433T

Ingabe lokhu kube usizo kuwena?
Isicaphuno
McCoy
  • Top 10 Contributor
488 izisombululo 4493 izimpendulo
Kuphostiwe

@ bugamode433T :

"browser.urlbar.OneOffSearches" applies to the bar that lists a number of search engines - you set its value to "false" to disable it.

"services.sync.prefs.sync.browser.urlbar.maxRichResults " applies to a Sync account .....

@ bugamode433T : "browser.urlbar.OneOffSearches" applies to the bar that lists a number of search engines - you set its value to "false" to disable it. "services.sync.prefs.sync.browser.urlbar.maxRichResults " applies to a Sync account .....
Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8568 izisombululo 70052 izimpendulo
Kuphostiwe

bugamode433T said

Note to FF developers: KISS Keep it simple is a better policy. The Bluebar is a distraction that the old blinking text that was removed in CSS

FYI, the blue bar was introduced in Firefox 43 (Dec. 2015) when search was more strongly integrated into the address bar. It informs you of the action that will occur if you press Enter or click the arrow button in the address bar. I am not aware of any plans to get rid of this old feature now.

''bugamode433T [[#answer-1202222|said]]'' <blockquote> Note to FF developers: KISS Keep it simple is a better policy. The Bluebar is a distraction that the old blinking text that was removed in CSS </blockquote> FYI, the blue bar was introduced in Firefox 43 (Dec. 2015) when search was more strongly integrated into the address bar. It informs you of the action that will occur if you press Enter or click the arrow button in the address bar. I am not aware of any plans to get rid of this old feature now.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
support2 0 izisombululo 4 izimpendulo
Kuphostiwe

The suggestion provided work about 99% well. When applied, the blue bar does indeed go away, however there is still an empty white box about ¼ the height of what the blue bar was. What is this white box and how do I get rid of it. Basically I want NOTHING to drop down, spin, flash, whistle, fart, or kick me in the nuts when I type in the address bar. I am a big boy. I know what i am typing and where I want to go. That feature is so AOLish that it is not funny!

The suggestion provided work about 99% well. When applied, the blue bar does indeed go away, however there is still an empty white box about ¼ the height of what the blue bar was. What is this white box and how do I get rid of it. Basically I want NOTHING to drop down, spin, flash, whistle, fart, or kick me in the nuts when I type in the address bar. I am a big boy. I know what i am typing and where I want to go. That feature is so AOLish that it is not funny!

Okulungisiwe ngu support2

Ingabe lokhu kube usizo kuwena?
Isicaphuno
jscher2000
  • Top 10 Contributor
8568 izisombululo 70052 izimpendulo
Kuphostiwe

support2 said

The suggestion provided work about 99% well. When applied, the blue bar does indeed go away, however there is still an empty white box about ¼ the height of what the blue bar was.

Hi support2, did this just appear in Firefox 68? I don't recall seeing an empty frame when testing this preference change before. Unless someone comes up with another workaround:

Most likely you will need to use a custom style rule in a userChrome.css file to hide the empty drop-down.

/* Suppress URL bar drop-down in Firefox 68 */
panel#urlbar-results {
  display: none !important;
}

You can find more info on creating an optional userChrome.css file over here: https://www.userchrome.org/how-create-userchrome-css.html

''support2 [[#answer-1235956|said]]'' <blockquote> The suggestion provided work about 99% well. When applied, the blue bar does indeed go away, however there is still an empty white box about ¼ the height of what the blue bar was. </blockquote> Hi support2, did this just appear in Firefox 68? I don't recall seeing an empty frame when testing this preference change before. Unless someone comes up with another workaround: Most likely you will need to use a custom style rule in a userChrome.css file to hide the empty drop-down. <pre>/* Suppress URL bar drop-down in Firefox 68 */ panel#urlbar-results { display: none !important; } </pre> You can find more info on creating an optional userChrome.css file over here: https://www.userchrome.org/how-create-userchrome-css.html
Ingabe lokhu kube usizo kuwena?
Isicaphuno
support2 0 izisombululo 4 izimpendulo
Kuphostiwe

Thanks jscher that was the setting I was looking for. I wish I could find a master list of parameters that are configurable with the userchrome file...

Anyway that did the trick!

BTW yes 68.0 64 bit.

Thanks jscher that was the setting I was looking for. I wish I could find a master list of parameters that are configurable with the userchrome file... Anyway that did the trick! BTW yes 68.0 64 bit.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
kswartz 1 izisombululo 4 izimpendulo
Kuphostiwe

THANK YOU! And also for showing how to hide the empty drop-down. It seems like it's just one thing after another. If I want to search, I will search, I don't need/want all their nagging 'suggestions'. I just want my simple little browser back. How about making all these new 'features' opt-in only/ Please?

THANK YOU! And also for showing how to hide the empty drop-down. It seems like it's just one thing after another. If I want to search, I will search, I don't need/want all their nagging 'suggestions'. I just want my simple little browser back. How about making all these new 'features' opt-in only/ Please?
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.