X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After changing the size of the paging file, the browser began to absorb all the available memory and crash itself and other applications

Kuphostiwe

win 7 x64, 65.0.1 I changed the paging file from a dynamic value to a fixed one (twice as much RAM), after which firefox spontaneously began to absorb all the RAM, which subsequently led to the crash of firefox itself, and other applications (such as discord, gog galaxy, etc.). This does not happen all the time, I can use the browser for an hour, then the memory will start to disappear, or I can only launch the browser and it will immediately begin to absorb memory. After restarting browser, everything returns to normal and no problems are observed until the computer is restarted. How to fix it all?

win 7 x64, 65.0.1 I changed the paging file from a dynamic value to a fixed one (twice as much RAM), after which firefox spontaneously began to absorb all the RAM, which subsequently led to the crash of firefox itself, and other applications (such as discord, gog galaxy, etc.). This does not happen all the time, I can use the browser for an hour, then the memory will start to disappear, or I can only launch the browser and it will immediately begin to absorb memory. After restarting browser, everything returns to normal and no problems are observed until the computer is restarted. How to fix it all?

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Eminye Imininingwane

Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

Qixin said

Win 7 x64, 65.0.1

I changed the Windows-7 Paging File from a dynamic value to a fixed one (twice as much RAM), after which firefox spontaneously began to absorb all the RAM, which subsequently led to the crash of firefox itself, and other applications (such as discord, gog galaxy, etc.)...

If you changed your Paging File to fixed value, due to what I posted in the past, blame that on me. (Sigh) While it worked for a bit when I tried it, 'Low Memory' would pop-up later. You should change the Paging File back to 'dynamic'.

What I see in Task Manager, Physical Memory Usage over time creeps up the graph, eventually nearing my 8GB my computer has. So, depending how many Tabs/Sites I visit, when the Graph Line nears the top, I hear my disk drive go into 'crunch' mode. This must be FF Caching Data and/or The 'large' Paging File crunching my hard drive. This can happen within several days or 4 or 5 days later, depending on my FF use.

However, once it reaches this point, the browser performance takes a nasty hit. The only way to regain better performance for me, is to Exit (Quit) FF and restart it.

Recommended Hardware for FF 65:

  • Pentium 4 or newer processor that supports SSE2
  • 512MB of RAM / 2GB of RAM for the 64-bit version
  • 200MB of hard drive space


Please do the following:

Click on the Windows icon 'Start' (bottom-left) and in the right column, bottom, click on Run. Enter in:

DxDiag /64bit

...Wait until the green bar loads and disappears, then click "Save All Information".
Post back here in the Forum, just these information parts, under these three Headers:


System Information



Display Devices



Disk & DVD/CD-ROM Drives

Make sure your computer is not too 'LOW' on disk-remaining space. This will be a major performance problem if your remaining disk space is TOO LOW!
If you're way under 25%, then you're probably running into performance / Memory issues.
Windows-7 and Programs like to have plenty of free-disk 'breathing' room.
If you have lots of Browser Windows and Tabs going and your FireFox Browser is set to Restore Session when you start-up FF, the following will help with conserving some Memory:

Go to Options. Edit or Insert in the Address/URL Box About:Config and go there. Set the following Values:

browser.newtabpage.enabled; false

browser.newtabpage.enhanced; false

browser.sessionstore.restore_pinned_tabs_on_demand; true


Upon the next start of FireFox, this will preload only the last Tab you were parked on per browser window. The other Tabs from your Previous Session will load only when you click on them.

If you open a lot of browser windows, you can set the maximum 'remembered' browser windows higher than the default for your Restored Session. Example: My max is set for 25:

browser.sessionstore.max_windows_undo; 25

Additionally, you could try this also. Have FF reset how much Disk Cache it will use for your system by changing the following to true:

browser.cache.disk.smart_size.first_run - false

It will change back to false after FF is Exited and runs next time, setting-up your Disk Cache value. Maybe this doesn't need to run again, but I did it a while back and 'appeared' to help me.

Finally, I did the following FireFox adjustments for my old 2010 computer with the Performance settings in Options as shown in the image attachment:


~Pj

''Qixin [[#question-1250267|said]]'' <blockquote> Win 7 x64, 65.0.1<Br><Br> I changed the Windows-7 Paging File from a dynamic value to a fixed one (twice as much RAM), after which firefox spontaneously began to absorb all the RAM, which subsequently led to the crash of firefox itself, and other applications (such as discord, gog galaxy, etc.)... </blockquote> If you changed your Paging File to fixed value, due to what I posted in the past, blame that on me. (Sigh) While it worked for a bit when I tried it, 'Low Memory' would pop-up later. You should change the Paging File back to 'dynamic'. What I see in Task Manager, '''Physical Memory Usage''' over time creeps up the graph, eventually nearing my 8GB my computer has. So, depending how many Tabs/Sites I visit, when the Graph Line nears the top, I hear my disk drive go into 'crunch' mode. This must be FF Caching Data and/or The 'large' Paging File crunching my hard drive. This can happen within several days or 4 or 5 days later, depending on my FF use. <Br> However, once it reaches this point, the browser performance takes a nasty hit. The only way to regain better performance for me, is to Exit (Quit) FF and restart it. <Br> Recommended Hardware for FF 65: *Pentium 4 or newer processor that supports SSE2 *512MB of RAM / 2GB of RAM for the 64-bit version *200MB of hard drive space<Br> Please do the following: <Br> Click on the Windows icon ''''Start'''' (bottom-left) and in the right column, bottom, click on '''Run'''. Enter in: <Center>'''DxDiag /64bit'''</Center><Br> ...Wait until the green bar loads and disappears, then click "'''Save All Information'''". <Br> Post back here in the Forum, just these information parts, under these three Headers:<Br> <Hr>'''System Information'''<Hr> <Br> <Hr>'''Display Devices'''<Hr> <Br> <Hr>'''Disk & DVD/CD-ROM Drives'''<Hr> Make sure your computer is not too 'LOW' on disk-remaining space. This will be a major performance problem if your remaining disk space is '''TOO LOW!'''<Br> If you're way under 25%, then you're probably running into performance / Memory issues.<Br> Windows-7 and Programs like to have plenty of free-disk 'breathing' room.<Br> If you have lots of Browser Windows and Tabs going and your FireFox Browser is set to '''Restore Session''' when you start-up FF, the following will help with conserving some Memory:<Br><Br> Go to '''Options'''. Edit or Insert in the Address/URL Box '''About:Config''' and go there. Set the following Values:<Br> <Center> '''browser.newtabpage.enabled; false'''<Br><Br> '''browser.newtabpage.enhanced; false'''<Br><Br> '''browser.sessionstore.restore_pinned_tabs_on_demand; true''' </Center><Br> Upon the next start of FireFox, this will preload only the last Tab you were parked on per browser window. The other Tabs from your Previous Session will load only when you click on them.<Br><Br> If you open a lot of browser windows, you can set the maximum 'remembered' browser windows higher than the default for your Restored Session. Example: My max is set for 25:<Br><Br> <Center>'''browser.sessionstore.max_windows_undo; 25'''</Center><Br> Additionally, you could try this also. Have FF reset how much Disk Cache it will use for your system by changing the following to '''true''':<Br> '''browser.cache.disk.smart_size.first_run''' - false<Br> It will change back to '''false''' after FF is Exited and runs next time, setting-up your Disk Cache value. Maybe this doesn't need to run again, but I did it a while back and 'appeared' to help me. <Br><Br> Finally, I did the following FireFox adjustments for my old 2010 computer with the '''Performance''' settings in '''Options''' as shown in the image attachment: <Br><Br><Br> ~Pj