X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do you get Firefox set permanently to play Flash Player videos?

Kuphostiwe

I was suddenly getting prompts to update Flash Player. This hadn't happened in months, so I hadn't updated Flash Player in a good while. The first time, I ignored the warning prompt and activated Flash anyway and played the video. This was from tcm.com (Turner Classic Movies). The second time, I decided I'd better update Flash Player, and did so. But now the video wouldn't play at all. There was a locked box icon. I searched on various fixes, looked at a few Mozilla support pages, did a plug-in change starting from the sandwich icon at upper right, same thing. Found another fix idea. Went into the C drive, navigated eventually in Windows to the Macromed and Flash folders, and deleted NPSWF32_9_0_0_169.dll. The red locked box went away. A video played. Next time out, though, back to nothing. In IE, the link will play.

I was suddenly getting prompts to update Flash Player. This hadn't happened in months, so I hadn't updated Flash Player in a good while. The first time, I ignored the warning prompt and activated Flash anyway and played the video. This was from tcm.com (Turner Classic Movies). The second time, I decided I'd better update Flash Player, and did so. But now the video wouldn't play at all. There was a locked box icon. I searched on various fixes, looked at a few Mozilla support pages, did a plug-in change starting from the sandwich icon at upper right, same thing. Found another fix idea. Went into the C drive, navigated eventually in Windows to the Macromed and Flash folders, and deleted NPSWF32_9_0_0_169.dll. The red locked box went away. A video played. Next time out, though, back to nothing. In IE, the link will play.

Isisombululo esikhethiwe

leopold49 said

I'm not on a Mac.

That was a reference to the MAC's default setting with the Sandbox. This notice applies to MACs and Windows Flash!

You'll need to DISABLE the Sandbox in FF, also.


~Pj

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 32.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4267 izisombululo 59839 izimpendulo
Kuphostiwe

Did you update Flash from its website, or a pop-up? Fake update pop-ups show up all the time. Never use a pop-up for updating

Windows IE and Firefox use different plugins for flash.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows {web link} Uninstall Flash Player | Mac {web link}


Then reinstall the latest version.

Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version 32.0.0.114

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only>


See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Did you update Flash from its website, or a pop-up? Fake update pop-ups show up all the time. Never use a pop-up for updating Windows IE and Firefox use different plugins for flash. Flash: Grab the uninstaller from here: [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows] {web link} [http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac] {web link} Then reinstall the latest version. '''Note: Windows users''' should download the '''active_x''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the '''plugin only.''' Not the '''active_x.''' Flash Player '''Version 32.0.0.114''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> ------------- See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Umnikazi wombuzo

A semi-solution. I'd installed the most updated Flash from the flashplayer/ link, and wasn't aware of flashplayer/otherversions/. So then, using that, eventually I had both .../Flash/Active X... and .../Flash/Plugin... Now, FF after Run Adobe Flash + Allow works only intermittently, and usually that's only after a refresh of the link. There have been occasions where a refresh does nothing. The odds of nothing/refresh/yes versus nothing/refresh/no are, at best, shy of equal. There's been only maybe one occasion where the video opened without a refresh. So generally FF isn't dependably consistent on Flash anymore. IE, the video opens all the time. I'll just use that browser for such videos. Or Chrome, which probably opens always also.

A semi-solution. I'd installed the most updated Flash from the flashplayer/ link, and wasn't aware of flashplayer/otherversions/. So then, using that, eventually I had both .../Flash/Active X... and .../Flash/Plugin... Now, FF after Run Adobe Flash + Allow works only intermittently, and usually that's only after a refresh of the link. There have been occasions where a refresh does nothing. The odds of nothing/refresh/yes versus nothing/refresh/no are, at best, shy of equal. There's been only maybe one occasion where the video opened without a refresh. So generally FF isn't dependably consistent on Flash anymore. IE, the video opens all the time. I'll just use that browser for such videos. Or Chrome, which probably opens always also.

Umnikazi wombuzo

More experimentation. Despite the Flash Player update installations, videos at tcm.com are not opening over 80 or 90 percent of the time, refreshes or otherwise. I'm getting that it's not a secure connection, and tinkering with what possibly to do about that and still not having any luck, really. So IE and/or Chrome. This was not a problem on FF, for tcm.com even without Flash Player updates, as recently as a week ago.

More experimentation. Despite the Flash Player update installations, videos at tcm.com are not opening over 80 or 90 percent of the time, refreshes or otherwise. I'm getting that it's not a secure connection, and tinkering with what possibly to do about that and still not having any luck, really. So IE and/or Chrome. This was not a problem on FF, for tcm.com even without Flash Player updates, as recently as a week ago.
FredMcD
  • Top 10 Contributor
4267 izisombululo 59839 izimpendulo
Kuphostiwe

Adobe Support https://forums.adobe.com/community/flashplayer

<removed shockwave player links>

https://support.mozilla.org/en-US/kb/adobe-flash-plugin-has-crashed

https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems


edited out Shockwave Player troubleshoot links reduce confusion as it and Flash Player are two different Plugins from Adobe.

Adobe Support https://forums.adobe.com/community/flashplayer <removed shockwave player links> https://support.mozilla.org/en-US/kb/adobe-flash-plugin-has-crashed https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems edited out Shockwave Player troubleshoot links reduce confusion as it and Flash Player are two different Plugins from Adobe.

Okulungisiwe ngu James

Umnikazi wombuzo

A bunch of websites, each with a bunch of links, is of no help whatsoever. On the next to last one, I'm not getting a crashed adobe flash plugin message such a crashed message, and have never said I did, so that link is irrelevant. Anyway, what I should have mentioned I have is an HP, Windows 7. And then Firefox updated itself just the other day.

A bunch of websites, each with a bunch of links, is of no help whatsoever. On the next to last one, I'm not getting a crashed adobe flash plugin message such a crashed message, and have never said I did, so that link is irrelevant. Anyway, what I should have mentioned I have is an HP, Windows 7. And then Firefox updated itself just the other day.
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

leopold49 said

I was suddenly getting prompts to update Flash Player.

Go to Add-ons (Control+SHIFT+A) and select Plug-ins. Select Options for Shockwave Flash and see if it is set to "Always Activate".


~Pj

''leopold49 [[#question-1249452|said]]'' <blockquote> I was suddenly getting prompts to update Flash Player. </blockquote> Go to '''Add-ons''' (Control+SHIFT+A) and select '''Plug-ins'''. Select '''Options''' for '''Shockwave Flash''' and see if it is set to "'''Always Activate'''". ~Pj

Umnikazi wombuzo

Yes, but the video won't open. And I've also previously gotten rid of the check mark in the Block Dangerous and Intrusive Flash Content box.

Yes, but the video won't open. And I've also previously gotten rid of the check mark in the Block Dangerous and Intrusive Flash Content box.
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

From Adobe, Feb 12th, 2019...

New Flash Update (32.0.0.142): https://get.adobe.com/flashplayer

Announcements:
Mac NPAPI Sandbox - Mozilla Firefox
The Mac NPAPI Flash sandbox is enabled by default on Firefox 62 and later.

Disabling the sandbox requires using about:config to set...

dom.ipc.plugins.sandbox-level.flash to 0

...and then restarting the browser. The sandbox is known to prevent the following features from working:

  • Print to PDF from the Flash print dialog
  • Print to “Open in Preview” from the Flash print dialog
  • Quicklook in the File->Open dialog
  • Saving files to the filesystem from a Flash applet
  • Flash applets downloading and running the Adobe Air installer
  • Flash triggering Adobe Air applications to run


~Pj

From Adobe, Feb 12th, 2019...<Br> New Flash Update (32.0.0.'''142'''): https://get.adobe.com/flashplayer<Br> Announcements: <Br> Mac NPAPI Sandbox - Mozilla Firefox<Br> The Mac NPAPI Flash sandbox is enabled by default on Firefox 62 and later.<Br><Br> Disabling the sandbox requires using '''about:config''' to set... <Br> '''dom.ipc.plugins.sandbox-level.flash''' to 0 <Br> ...and then restarting the browser. The sandbox is known to prevent the following features from working:<Br> * Print to PDF from the Flash print dialog * Print to “Open in Preview” from the Flash print dialog * Quicklook in the File->Open dialog * '''<u>Saving files to the filesystem from a Flash applet</u>''' * Flash applets downloading and running the Adobe Air installer * Flash triggering Adobe Air applications to run<Br><Br> ~Pj

Umnikazi wombuzo

I'm not on a Mac.

I'm not on a Mac.
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

leopold49 said

I'm not on a Mac.

That was a reference to the MAC's default setting with the Sandbox. This notice applies to MACs and Windows Flash!

You'll need to DISABLE the Sandbox in FF, also.


~Pj

''leopold49 [[#answer-1196416|said]]'' <blockquote> I'm not on a Mac. </blockquote> That was a reference to the MAC's default setting with the Sandbox. This notice applies to MACs and Windows Flash! You'll need to DISABLE the Sandbox in FF, also. ~Pj

Umnikazi wombuzo

By going where and doing what?

By going where and doing what?
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

leopold49 said

By going where and doing what?

In the Address/URL box, type in About:Config. Once there, enter in the Config Search Box:

dom.ipc.plugins.sandbox-level.flash

and set it to 0.


~Pj

''leopold49 [[#answer-1196429|said]]'' <blockquote> By going where and doing what? </blockquote> In the Address/URL box, type in '''About:Config'''. Once there, enter in the Config Search Box: <Br> '''dom.ipc.plugins.sandbox-level.flash'''<Br> and set it to 0. ~Pj

Umnikazi wombuzo

Okay. Pj, thank you very much! I set aside my frustration, read your about:config solution, set dom.ipc.plugins.sandbox-level.flash from 3 to 0, failed to follow the additional instruction to restart my browser, went back and did that, got a Firefox update when I did so and figured that would mess up things, but it didn't. The video finally played at tcm.com. I'll cross my fingers for the future.

Okay. Pj, thank you very much! I set aside my frustration, read your about:config solution, set dom.ipc.plugins.sandbox-level.flash from 3 to 0, failed to follow the additional instruction to restart my browser, went back and did that, got a Firefox update when I did so and figured that would mess up things, but it didn't. The video finally played at tcm.com. I'll cross my fingers for the future.
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

leopold49 said

Okay. Pj, thank you very much! I set aside my frustration, read your about:config solution, set dom.ipc.plugins.sandbox-level.flash from 3 to 0, failed to follow the additional instruction to restart my browser, went back and did that, got a Firefox update when I did so and figured that would mess up things, but it didn't. The video finally played at tcm.com. I'll cross my fingers for the future.

Cool. I'll hit this 'Golden Buzzer'! Confetti flying! You move onto the Live Rounds! (LoL)

~Pj

''leopold49 [[#answer-1196433|said]]'' <blockquote> Okay. Pj, thank you very much! I set aside my frustration, read your about:config solution, set dom.ipc.plugins.sandbox-level.flash from 3 to 0, failed to follow the additional instruction to restart my browser, went back and did that, got a Firefox update when I did so and figured that would mess up things, but it didn't. The video finally played at tcm.com. I'll cross my fingers for the future. </blockquote> Cool. I'll hit this 'Golden Buzzer'! Confetti flying! You move onto the Live Rounds! (LoL) ~Pj
Pj 42 izisombululo 869 izimpendulo
Kuphostiwe

FireFox Version 65.0.1, first offered to
Release channel users on February 12, 2019
.


Fixed:

Fixed accidental requests to addons.mozilla.org when an addon recommendation doorhanger is shown. (bug 1526387)

Improved playback of interactive Netflix videos. (bug 1524500)

Fixed incorrect sizing of the "Clear Recent History" window in some situations. (bug 1523696)

Fixed audio & video delays while making WebRTC calls. (bug 1521577 & bug 1523817)

Fixed video sizing problems during some WebRTC calls. (bug 1520200)

Fixed looping CONNECT requests when using WebSockets over HTTP/2 from behind a proxy server. (bug 1523427)


Various stability and Security Fixes.

~Pj

'''FireFox Version 65.0.1, first offered to<Br>Release channel users on February 12, 2019'''. ---- Fixed: <Br> Fixed accidental requests to addons.mozilla.org when an addon recommendation doorhanger is shown. (bug [https://bugzilla.mozilla.org/show_bug.cgi?id=1526387 1526387])<Br> Improved playback of interactive Netflix videos. (bug [https://bugzilla.mozilla.org/show_bug.cgi?id=1524500 1524500])<Br> Fixed incorrect sizing of the "Clear Recent History" window in some situations. (bug [https://bugzilla.mozilla.org/show_bug.cgi?id=1523696 1523696])<Br> Fixed audio & video delays while making WebRTC calls. (bug [https://bugzilla.mozilla.org/show_bug.cgi?id=1521577 1521577] & bug [https://bugzilla.mozilla.org/show_bug.cgi?id=1523817 1523817])<Br> Fixed video sizing problems during some WebRTC calls. (bug [https://bugzilla.mozilla.org/show_bug.cgi?id=1520200 1520200])<Br> Fixed looping CONNECT requests when using WebSockets over HTTP/2 from behind a proxy server. (bug [https://bugzilla.mozilla.org/show_bug.cgi?id=1523427 1523427])<Br> Various stability and [https://www.mozilla.org/security/advisories/mfsa2019-04/ Security Fixes].<Br><Br> ~Pj