X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

remote images

Kuphostiwe

I know we have discussed this over and over and i have researched a little but cant find the solution to why, my remote images aren't showing up in my emails. please help. maybe im losing my mind with the settings. i have started and restarted. Using the 64.0b3 (32-bit) version.

my settings are to allow all images, see the attached image.

I know we have discussed this over and over and i have researched a little but cant find the solution to why, my remote images aren't showing up in my emails. please help. maybe im losing my mind with the settings. i have started and restarted. Using the 64.0b3 (32-bit) version. my settings are to allow all images, see the attached image.
Ama-screenshot ananyekiwe

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Eminye Imininingwane

Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11630 izimpendulo
Kuphostiwe

re :why, my remote images aren't showing up in my emails......my settings are to allow all images, see the attached image.

  • mailnews.message_display.disable_remote_image; true

This line relates to allowing display of all remote content in all emails. This is shown as 'Status' = 'default' and set as 'True'. The font is not bold and Status not set as User Set. This means it is set to disable remote image. Hence you do not have setting to 'allow all images' and cannot see remote content.

Read info on displaying remote content from a specific email address. Note: the remote content can vary even from one email address.

When you open email, there will be an 'Options' button located in the header area. Click on 'Options' button to see all the various remote content contained in that email. You can choose to allow all of it just in that email - top option - or from all the different origins or from that email address for future emails from same source.

This info is then stored here: Menu icon > Options > Privacy

To set to allow all remote content in all emails no matter who they are from - I do not recommend you do this... select checkbox: 'allow remote content in messages'

To see list of exceptions of specific websites which you allow or specific email address of sender... click on 'Exceptions..' button

Remember to click on all 'OK's when finished.

re :''why, my remote images aren't showing up in my emails......my settings are to allow all images, see the attached image. '' * mailnews.message_display.disable_remote_image; true This line relates to allowing display of all remote content in all emails. This is shown as 'Status' = 'default' and set as 'True'. The font is not bold and Status not set as User Set. This means it is set to disable remote image. Hence you do not have setting to 'allow all images' and cannot see remote content. Read info on displaying remote content from a specific email address. Note: the remote content can vary even from one email address. * https://support.mozilla.org/en-US/kb/remote-content-in-messages When you open email, there will be an 'Options' button located in the header area. Click on 'Options' button to see all the various remote content contained in that email. You can choose to allow all of it just in that email - top option - or from all the different origins or from that email address for future emails from same source. This info is then stored here: Menu icon > Options > Privacy To set to allow all remote content in all emails no matter who they are from - I do not recommend you do this... select checkbox: 'allow remote content in messages' To see list of exceptions of specific websites which you allow or specific email address of sender... click on 'Exceptions..' button Remember to click on all 'OK's when finished.

Umnikazi wombuzo

the 'Options' button does not appear on my emails. -view the attached image of my settings. how do i set the "disable_remote_image; true" and in bold, User Set?

Thanks.

the 'Options' button does not appear on my emails. -view the attached image of my settings. how do i set the "disable_remote_image; true" and in bold, User Set? Thanks.
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11630 izimpendulo
Kuphostiwe

Before you do anything please check to see if you are viewing using 'Original HTML' option. 'View' > 'Message Body As' set to "Original HTML". "Simple HTML" and "Plain Text" do not show remote images.

re :how do i set the "disable_remote_image; true" and in bold, User Set

After clicking on the 'Config Editor' button to get the about:config window open. Double click on the line:

  • mailnews.message_display.disable_remote_image;

This will toggle the 'True' to a 'False' Close window click on 'OK' to save and close 'Options' window.


re : 'the 'Options' button does not appear on my emails.' If email is in the 'Junk' or 'Spam' folder then the 'options' button will not appear. You would need to mark email as 'Not Junk' to move it back to the 'Inbox' to get it to appear.

Before you do anything please check to see if you are viewing using 'Original HTML' option. 'View' > 'Message Body As' set to "Original HTML". "Simple HTML" and "Plain Text" do not show remote images. re :how do i set the "disable_remote_image; true" and in bold, User Set After clicking on the 'Config Editor' button to get the about:config window open. Double click on the line: * mailnews.message_display.disable_remote_image; This will toggle the 'True' to a 'False' Close window click on 'OK' to save and close 'Options' window. re : 'the 'Options' button does not appear on my emails.' If email is in the 'Junk' or 'Spam' folder then the 'options' button will not appear. You would need to mark email as 'Not Junk' to move it back to the 'Inbox' to get it to appear.

Umnikazi wombuzo

Is there a restore to original state for the settings?

maybe the prog is just confused and needs a start-over. heck i do at this point. hehe

see image. None of the emails are in the "Junk" folder. even after setting the "disable_remote_image:false" its still not loading images.

Am i missing something?

Is there a restore to original state for the settings? maybe the prog is just confused and needs a start-over. heck i do at this point. hehe see image. None of the emails are in the "Junk" folder. even after setting the "disable_remote_image:false" its still not loading images. Am i missing something?

Umnikazi wombuzo

I'm still having issues, was there any more help you can provide?

I'm still having issues, was there any more help you can provide?
Ken Spencer 0 izisombululo 4 izimpendulo
Kuphostiwe

I have the same problem. I don't yet have a solution. Remote images do not appear in any email. Currently, the Options button that used to appear to deal with remote images no longer appears in any email (old or new).

OS Windows_NT 6.3 (a.k.a. Windows 8.1) → Thunderbird 60.6.1 → Build 20190325011617

View → Message Body As → Original HTML

Tools → Options → Privacy → Mail Content I have SELECTED the checkbox "Allow remote content in messages", and restarted Thunderbird. The problem remains the same. I have UNSELECTED the checkbox "Allow remote content in messages", and restarted Thunderbird. The problem remains the same. The Exceptions list is completely empty.

I have used my ISP's webmail client; the remote images all DO appear in the emails there.

I am at the end of my patience, and after MANY years of using Thunderbird I am considering abandoning it altogether.

I have the same problem. I don't yet have a solution. Remote images do not appear in any email. Currently, the Options button that used to appear to deal with remote images no longer appears in any email (old or new). OS Windows_NT 6.3 (a.k.a. Windows 8.1) → Thunderbird 60.6.1 → Build 20190325011617 View → Message Body As → Original HTML Tools → Options → Privacy → Mail Content I have SELECTED the checkbox "Allow remote content in messages", and restarted Thunderbird. The problem remains the same. I have UNSELECTED the checkbox "Allow remote content in messages", and restarted Thunderbird. The problem remains the same. The Exceptions list is completely empty. I have used my ISP's webmail client; the remote images all DO appear in the emails there. I am at the end of my patience, and after MANY years of using Thunderbird I am considering abandoning it altogether.
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11630 izimpendulo
Kuphostiwe

If the message that usually appears above the email is not showing: 'To protect your privacy, Thunderbird has blocked remote content in this message'.

Do you get the same issue if you restart Thunderbird with addons disabled? In Thunderbird 'Help' > 'Restart with addons disabled.'

I have found bug reports that mention 'Conversations' addon causes a conflict, maybe other addon extensions can also cause an issue and it would be worth knowing about them.

If the message that usually appears above the email is not showing: 'To protect your privacy, Thunderbird has blocked remote content in this message'. Do you get the same issue if you restart Thunderbird with addons disabled? In Thunderbird 'Help' > 'Restart with addons disabled.' I have found bug reports that mention 'Conversations' addon causes a conflict, maybe other addon extensions can also cause an issue and it would be worth knowing about them.
Ken Spencer 0 izisombululo 4 izimpendulo
Kuphostiwe

Toad-Hall said

If the message that usually appears above the email is not showing: 'To protect your privacy, Thunderbird has blocked remote content in this message'.

My question is: How do I get that message to start appearing again, AND how do I get Thunderbird to STOP blocking remote content?

Toad-Hall said

Do you get the same issue if you restart Thunderbird with add-ons disabled? In Thunderbird 'Help' > 'Restart with add-ons disabled.'

Yes, I get the same issue if I start Thunderbird "with add-ons disabled" or "in safe mode". No remote images in any email, new or old; no warning or Options message.

Toad-Hall said

I have found bug reports that mention 'Conversations' addon causes a conflict, maybe other addon extensions can also cause an issue and it would be worth knowing about them.

I have disabled, and then deleted ALL add-ons. This has no effect. The problem remains.

''Toad-Hall [[#answer-1222708|said]]'' <blockquote> If the message that usually appears above the email is not showing: 'To protect your privacy, Thunderbird has blocked remote content in this message'. </blockquote> My question is: How do I get that message to start appearing again, AND how do I get Thunderbird to STOP blocking remote content? ''Toad-Hall [[#answer-1222708|said]]'' <blockquote> Do you get the same issue if you restart Thunderbird with add-ons disabled? In Thunderbird 'Help' > 'Restart with add-ons disabled.' </blockquote> Yes, I get the same issue if I start Thunderbird "with add-ons disabled" or "in safe mode". No remote images in any email, new or old; no warning or Options message. ''Toad-Hall [[#answer-1222708|said]]'' <blockquote> I have found bug reports that mention 'Conversations' addon causes a conflict, maybe other addon extensions can also cause an issue and it would be worth knowing about them. </blockquote> I have disabled, and then deleted ALL add-ons. This has no effect. The problem remains.

Umnikazi wombuzo

agree with above, still getting the issue with add-ons disabled.

agree with above, still getting the issue with add-ons disabled.

Umnikazi wombuzo

please see image file, i have the box checked for testing. Still having no images, show up. remote_image = true Image

please see image file, i have the box checked for testing. Still having no images, show up. remote_image = true [https://i.postimg.cc/s2YCXm5K/Thunderbird-B.jpg Image]
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11630 izimpendulo
Kuphostiwe

Please start your computer in 'Safe Mode with Networking' mode. Start Thunderbird. Do you now see the images that contain additional remote content? Or see the message To protect your privacy, Thunderbird has blocked remote content in this message'?

Please report back on results.

Please start your computer in 'Safe Mode with Networking' mode. Start Thunderbird. Do you now see the images that contain additional remote content? Or see the message ''To protect your privacy, Thunderbird has blocked remote content in this message'? Please report back on results.
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11630 izimpendulo
Kuphostiwe

This sounds like remote is enabled but something is conflicting...Maybe a proxy is hiding those images. 'Menu icon' > 'Options' > 'Advanced' > 'Network & Disc Space' tab 'Connection' section click on 'Settings' button

A 'Connection Settings' window opens. Configure Proxies to Access Internet... Q: What option is currently selected?

Additional info:

This sounds like remote is enabled but something is conflicting...Maybe a proxy is hiding those images. 'Menu icon' > 'Options' > 'Advanced' > 'Network & Disc Space' tab 'Connection' section click on 'Settings' button A 'Connection Settings' window opens. Configure Proxies to Access Internet... '''Q:''' What option is currently selected? Additional info: * https://support.mozilla.org/en-US/kb/advanced-panel-settings-in-thunderbird#w_connection

Umnikazi wombuzo

Even after i click the "show remote content in this image" the images still don't load.

There are no proxy settings set.

trying, safe mode......

Even after i click the "show remote content in this image" the images still don't load. There are no proxy settings set. trying, safe mode......
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11630 izimpendulo
Kuphostiwe

re :There are no proxy settings set. Try using 'Use system proxy settings'

re :There are no proxy settings set. Try using 'Use system proxy settings'

Umnikazi wombuzo

WE are getting closer, some images are showing but some are not. This was in safe mode with networking on and system proxy settings on......is there anyway to reset everything to dummy version no protection on. hehe, to get everything working and then turn stuff off?

WE are getting closer, some images are showing but some are not. This was in safe mode with networking on and system proxy settings on......is there anyway to reset everything to dummy version no protection on. hehe, to get everything working and then turn stuff off?
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11630 izimpendulo
Kuphostiwe

What would be ideal is to get the whole lot back to default so you can see the message 'To protect your privacy etc with 'Options' button' on each email. This in effect is blocking everything, but should allow you to reset specific content as visible.

Please work through the following in the order stated.

Start computer as normal Stop Anti-Virus Product from scanning any Thunderbird file or folder. You may need to make them as exceptions. Profile folders by default are located here: C:\Users\<Windows user name>\AppData\Roaming\Thunderbird\Profiles\<Profile name>\ The 'Mail' folder contains the pop accounts and Local Folders. The 'ImapMail' folder contains the imap accounts. mbox files contain emails - these text files do not have any extention, but have same name as folder.


Start Thunderbird.

Check all the following is set - please double check everything:

  • View > Message Body As > Original HTML
  • View > Folders > All
  • Menu icon > Options > Privacy

Mail Content

  • Uncheck the checkbox "Allow remote content in messages
  • click on 'Exceptions'
  • Click on 'Remove all sites' if it is enabled.
  • click on 'Save Changes'

Whilst in 'Options'

  • Select 'Advanced' > 'Network & Disc Space' tab
  • 'Connection' section click on 'Settings' button
  • Select 'Use System proxy settings'
  • click on 'OK'

Whilst in 'Options'

  • Select 'Advanced' > 'General' tab
  • click on 'Config Editor' button
  • Check and set Value as listed below if required:
  • mailnews.message_display.disable_remote_image. Value = true
  • Closewindow - top right x
  • Click on 'OK'


  • Menu icon > Tools > select 'Clear recent history'
  • select all and click on 'Clear Now'

In Thunderbird

  • Help > Troubleshooting Information
  • Click on 'Open Folder' button

A new window opens showing you the contents of your profile name folder.

  • Exit Thunderbird now - this is important.

Allow a little time for all background processes to complete.

Please make a copy of these two files and put copy on desktop as a temporary backup (you can delete them later if not required) and then delete these files:

  • content-prefs.sqlite
  • permissions.sqlite

Please locate and delete all of the following files:

  • global-messages-db.sqlite
  • panacea.dat
  • session.json
  • xulstore.json

Start Thunderbird. All those deleted files will be recreated, so allow TB sometime to ensure all is up and running.

Select email which you know has remote content so it is visible in 'Message Pane'. Do you see the message under the header that says 'To protect your privacy, Thunderbird has blocked remote content in this message' 'Options'  ?

What would be ideal is to get the whole lot back to default so you can see the message 'To protect your privacy etc with 'Options' button' on each email. This in effect is blocking everything, but should allow you to reset specific content as visible. Please work through the following in the order stated. Start computer as normal Stop Anti-Virus Product from scanning any Thunderbird file or folder. You may need to make them as exceptions. Profile folders by default are located here: C:\Users\<Windows user name>\AppData\Roaming\Thunderbird\Profiles\<Profile name>\ The 'Mail' folder contains the pop accounts and Local Folders. The 'ImapMail' folder contains the imap accounts. mbox files contain emails - these text files do not have any extention, but have same name as folder. Start Thunderbird. Check all the following is set - please double check everything: * View > Message Body As > Original HTML * View > Folders > All * Menu icon > Options > Privacy Mail Content * Uncheck the checkbox "Allow remote content in messages * click on 'Exceptions' * Click on 'Remove all sites' if it is enabled. * click on 'Save Changes' Whilst in 'Options' * Select 'Advanced' > 'Network & Disc Space' tab * 'Connection' section click on 'Settings' button * Select 'Use System proxy settings' * click on 'OK' Whilst in 'Options' * Select 'Advanced' > 'General' tab * click on 'Config Editor' button * Check and set Value as listed below if required: * mailnews.message_display.disable_remote_image. Value = true * Closewindow - top right x * Click on 'OK' * Menu icon > Tools > select 'Clear recent history' * select all and click on 'Clear Now' In Thunderbird * Help > Troubleshooting Information * Click on 'Open Folder' button A new window opens showing you the contents of your profile name folder. * Exit Thunderbird now - this is important. Allow a little time for all background processes to complete. Please make a copy of these two files and put copy on desktop as a temporary backup (you can delete them later if not required) and then delete these files: * content-prefs.sqlite * permissions.sqlite Please locate and delete all of the following files: * global-messages-db.sqlite * panacea.dat * session.json * xulstore.json Start Thunderbird. All those deleted files will be recreated, so allow TB sometime to ensure all is up and running. Select email which you know has remote content so it is visible in 'Message Pane'. Do you see the message under the header that says 'To protect your privacy, Thunderbird has blocked remote content in this message' 'Options' ?

Umnikazi wombuzo

Followed the directions, still some images are showing and some are not. i do have the 'To protect your privacy, Thunderbird has blocked remote content in this message' with very email i open now. Thanks for that. Getting closer? i hope so....

Followed the directions, still some images are showing and some are not. i do have the 'To protect your privacy, Thunderbird has blocked remote content in this message' with very email i open now. Thanks for that. Getting closer? i hope so....
Toad-Hall
  • Top 10 Contributor
1739 izisombululo 11630 izimpendulo
Kuphostiwe

re : i do have the 'To protect your privacy, Thunderbird has blocked remote content in this message' with very email i open now.

That's good. It means all is reset back to the default when you see that message. By clicking on 'Options' you would now see a list of all the remote content in that email. This link gives full explanation of what the selection offers. The first one only allows that email to show remote content. The last one in list will create an exception for the email address. Everything in between is a list of the remote content. Please note that you could get different remote content from the same email address. https://support.mozilla.org/en-US/kb/remote-content-in-messages#w_display-remote-content-for-a-particular-message-sender-or-website


Images that do not have remote content would not be blocked by default.

re : ''i do have the 'To protect your privacy, Thunderbird has blocked remote content in this message' with very email i open now''. That's good. It means all is reset back to the default when you see that message. By clicking on 'Options' you would now see a list of all the remote content in that email. This link gives full explanation of what the selection offers. The first one only allows that email to show remote content. The last one in list will create an exception for the email address. Everything in between is a list of the remote content. Please note that you could get different remote content from the same email address. https://support.mozilla.org/en-US/kb/remote-content-in-messages#w_display-remote-content-for-a-particular-message-sender-or-website Images that do not have remote content would not be blocked by default.
Ken Spencer 0 izisombululo 4 izimpendulo
Kuphostiwe

Toad-Hall said

What would be ideal is to get the whole lot back to default so you can see the message 'To protect your privacy etc with 'Options' button' on each email. This in effect is blocking everything, but should allow you to reset specific content as visible. Please work through the following in the order stated. Start computer as normal [snip] Do you see the message under the header that says 'To protect your privacy, Thunderbird has blocked remote content in this message' 'Options'  ?

I restarted my PC. Once restarted I opened no apps except for TB. I performed all of the steps you listed; carefully and meticulously. Twice.

The result (both times) was: a few messages did pop-up the message To protect your privacy, Thunderbird has blocked remote content in this message; [Options] but MANY messages still do not show any remote images at all (as was happening before I performed any actions, above).

Not being able to see remote images in my emails in TB is super frustrating and super annoying, BUT not being able to fix this stupid problem is BEYOND super frustrating and super annoying.

I am seriously investigating alternatives to TB. I don't need this aggravation.

''Toad-Hall [[#answer-1223914|said]]'' <blockquote> What would be ideal is to get the whole lot back to default so you can see the message 'To protect your privacy etc with 'Options' button' on each email. This in effect is blocking everything, but should allow you to reset specific content as visible. Please work through the following in the order stated. Start computer as normal [snip] Do you see the message under the header that says 'To protect your privacy, Thunderbird has blocked remote content in this message' 'Options' ? </blockquote> I restarted my PC. Once restarted I opened no apps except for TB. I performed all of the steps you listed; carefully and meticulously. Twice. The result (both times) was: '''a few messages''' did pop-up the message ''To protect your privacy, Thunderbird has blocked remote content in this message; [Options]'' but MANY messages still do not show any remote images at all (as was happening before I performed any actions, above). Not being able to see remote images in my emails in TB is super frustrating and super annoying, BUT not being able to fix this stupid problem is BEYOND super frustrating and super annoying. I am seriously investigating alternatives to TB. I don't need this aggravation.