Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox keeps logging me out of Facebook

  • 6 uphendule
  • 1 inale nkinga
  • 26 views
  • Igcine ukuphendulwa ngu boong

more options

Ok. Another problem with Firefox. For some reason, when I'm on Facebook, then close it, the next time I open Firefox, the Facebook page opens at the log-in page and I have to re-login. Happens every time. It just started this two days ago and it's getting very tiresome. No problems before, When I closed Facebook and then sometime later clicked on Firefox icon on the task bar, Facebook would always open to my Newsfeed/Time line. Why is it doing this?

All Replies (6)

more options

Is this just with Facebook? What about other websites?

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

Only Facebook. I cleared everything in Cache. Just now, I clicked on the Firefox icon in the task bar. When FB came up it was the log-in page. At the top for the id/pw, I noticed an icon to the right of the id block. Clicked on it and it asked me to open my security software vault (it has all my log-in info). Logged-in to it and it said it was not synced. So, I'm going to close FB and see if I have to log-in again or if it takes me right to my Timeline/Newsfeed. Will update this in a couple of minutes.

more options

Well, no change. When I logged-in to my vault, on the bottom right I had a notice saying it was now synced. However, all it did was show my ID below the sign-in space. When I click on the ID it opens Facebook timeline. Still have to log-in. For what it's worth, I don't have this problem when I use IE. All I do with IE is click on the IE icon on my desktop and it automatically opens FB to my Timeline.

Okulungisiwe ngu boong

more options

I followed your suggestions. Still no change. Here's something else interesting. When I log-in to FB it opens my Newsfeed. At the top is a notice shows in the image. When I click on OK and then close FB and reopen, still have to log-in. I'm about to uninstall/re-install Firefox. And, if that doesn't work, I might restore my computer to an earlier time where I didn't have all these problems.

more options

I don't know Facebook.

Log into Facebook. Then close the browser.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

If so, log in again. then restart Firefox.

more options

No difference. Still have to log-in. Will try uninstalling/re-installing Firefox to see if that will solve it. Thanks for your response