Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cookies Management , Manage permissions not working

  • 5 uphendule
  • 1 inale nkinga
  • 24 views
  • Igcine ukuphendulwa ngu cor-el

more options

Good day guys ,

Basically what I want is to make facebook.com logout when I close firefox and enter again. This should be possible by just going to >Cookies and site data >Manage permissions and blocking cookies for facebook.com but the problem is this option for firefox is completely useless , doesn't do absolutely anything as I'm still getting cookies saved from facebook.com , therefore every time I open firefox again my facebook is already logged in.

Is there any alternative solutions to this besides checking the box "Delete cookies and site data when Firefox is closed" ???

Because I don't want that either...cause that means I have to log into every site separately every time I open again firefox...I only want to do that for Firefox.

Thank you

All Replies (5)

more options

I only want to do that for Facebook ***

more options

Hi,

I think it is possible to create the functionality in a web extension (addon). To my knowledge, this does not exist, but all the necessary APIs are available

thank's

more options

Sharkyz said

I only want to do that for Facebook ***

Hello Sharkyz,

Would you do this please :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Block".

Then close and restart Firefox.

I hope that will work for you .....

more options

McCoy said

Sharkyz said
I only want to do that for Facebook ***

Hello Sharkyz,

Would you do this please :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Block".

Then close and restart Firefox.

I hope that will work for you .....

I tried that , but apparently facebook doesn't let me log in if I have cookies disabled :))) it says something like "it seems like your browser have cookies disabled...you need to enable it to log in" or something similar , can't remember exactely. :(

more options

You can make the Facebook cookies session cookies that expire automatically, but you need to make sure to close all Facebook tabs before you close Firefox because otherwise sessionstore will save the cookies.