Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox stopped remembering new logins passwords but remember logins box is ticked

  • 16 uphendule
  • 1 inale nkinga
  • 55 views
  • Igcine ukuphendulwa ngu johndunne139

more options

Firefox has stopped asking to remember, or remembering, new passwords or logins recently. This is on a windows 7 pc. The "ask to remember passwords and logins" box is ticked and does not become un-ticked. Firefox still remembers older logins and passwords, and, if changes are made to those passwords, Firefox will ask to remember them. Firefox has stopped remembering new logins. The Trend Micro password manager, which caused a problem in the past, is turned off. Another windows 7 pc I use has the same problem. The two pcs are linked by sync. All advice gratefully appreciated

Okulungisiwe ngu NoahSUMO

All Replies (16)

more options

If you have sync, and there is a problem anywhere, Shut Down Sync Immediately On All Devices to prevent the problem from spreading. Once the problem is fixed, perform the same repair on all computers/profiles before using sync again.


Do the other systems on the sync have the same problem?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

Hello johndunne139,

Just in case the above doesn't solve the problem; you could try to uninstall and the reinstall Adobe Flash - it worked for two users in this thread :

https://support.mozilla.org/en-US/questions/1213229

Uninstaller :

https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

Then, to reinstall :

https://get.adobe.com/flashplayer/

(ignore the optional McAfee offer)

more options

I have tried disconnected sync and restarted in safe mode, I have uninstalled and reinstalled adobe flash but the problem remains

more options

johndunne139 said

I have tried disconnected sync and restarted in safe mode, I have uninstalled and reinstalled adobe flash but the problem remains

We can rule out private browsing mode, as the box "Ask to remember passwords and logins" is not greyed out.

Stab in the dark (and a bit far-fetched), but it could be that the sites where new logins are not remembered because the login page on those websites may be containing a piece of code that is used as a standard to tell the web browser not to prompt the user to save the password for security reasons. (added source code to the password input box that has an autocomplete=”off”)

Just to make sure, you could check this on the "about:config" page :

signon.storeWhenAutocompleteOff = true (which is the default value)

more options

I looked at autoconfig for one of the sites and it seems to be correct default value. Also the failure to remember logons happens on a wide range of sites,

more options

In your original post you say that Trend Micro is turned off, but according to your system details it's enabled .....

more options

Trend micro is on but the trend micro password manager is off. Some months ago when the trend micro password manager was on, it interfered with Firefox remembering logons. Trend password manager did this by un-ticking the firefox remember logons option. The trend password manager is not installed and the firefox option to remember logons remains ticked

more options

Not giving up just yet .....

Would you check your cookies settings, please  ?

See :

https://support.mozilla.org/en-US/kb/where-are-my-logins-stored

more options

I was unable to check cookies setting on the link provided. I looked under options and "accept cookies and site data is ticked" and "block cookies and site data" is un-ticked. Hopefully I was looking in the right place. It also says cookies are to be kept till they expire

more options

johndunne139 said

I was unable to check cookies setting on the link provided. I looked under options and "accept cookies and site data is ticked" and "block cookies and site data" is un-ticked. Hopefully I was looking in the right place. It also says cookies are to be kept till they expire

I should have mentioned that I provided the link to that article,
only to explain why I asked you to check your cookies settings
(sorry ..... )

Yes, you looked in the right place and your settings are okay.

I'm running out of ideas and I can only hope that somebody else
will come to your rescue .....

The only thing I can think of now is to ask you to go over this article and see if maybe there's something there that we have overlooked :

https://support.mozilla.org/en-US/kb/usernames-and-passwords-are-not-saved

more options

Try to set signon.debug pref to true on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Then you can check the Browser Console for possible error messages.

more options

I went to "about:config " and ticked "I accept the risk" This opened a long list but I could not see anything called Browser Console

more options

johndunne139 said

I went to "about:config " and ticked "I accept the risk" This opened a long list but I could not see anything called Browser Console

What cor-el wanted you to do on the "about:config" page :

Type in the search bar : signon.debug

and when you find that preference, change its value to true

Then close and restart Firefox.

After you've done that cor-el suggests to check the Browser Console for possible error messages.

more options

The Browser Console is part of the developer tools.

  • "3-bar" menu button or Tools -> Web Developer
more options

Thank you. There are 4 error messages in the Browser Console and a lot of other messages.

Three of the Error Messages seem to be similar

"Error: Error retrieving geoip data common-min.4b219b53323f.js:10:27787 <anonymous> https://static-media-prod-cdn.sumo.mozilla.net/static/build/common-min.4b219b53323f.js:10:27787 c https://static-media-prod-cdn.sumo.mozilla.net/static/build/common-min.4b219b53323f.js:4:2991 fireWith https://static-media-prod-cdn.sumo.mozilla.net/static/build/common-min.4b219b53323f.js:4:3801 k https://static-media-prod-cdn.sumo.mozilla.net/static/build/common-min.4b219b53323f.js:5:23258 r https://static-media-prod-cdn.sumo.mozilla.net/static/build/common-min.4b219b53323f.js:5:27623"

The other error message reads "TypeError: b is undefined products-min.75d406edb591.js:1:62 compareVersions https://static-media-prod-cdn.sumo.mozilla.net/static/build/products-min.75d406edb591.js:1:62 <anonymous> https://static-media-prod-cdn.sumo.mozilla.net/static/build/products-min.75d406edb591.js:1:578 listener https://static-media-prod-cdn.sumo.mozilla.net/static/build/common-min.4b219b53323f.js:9:29720 sendPageEvent resource:///modules/UITourChild.jsm:104:5 receiveMessage resource:///modules/UITourChild.jsm:85:9"


Some of the other messages are unreachable code after return statement js:87:1788 unreachable code after return statement js:147:462 unreachable code after return statement js:147:506 unreachable code after return statement js:147:462 unreachable code after return statement js:87:1788 unreachable code after return statement js:147:506 Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://location.services.mozilla.com/v1/country?key=fa6d7fc9-e091-4be1-b6c1-5ada5815ae9d. (Reason: missing token ‘x-csrftoken’ in CORS header ‘Access-Control-Allow-Headers’ from CORS preflight channel).[Learn More] Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://location.services.mozilla.com/v1/country?key=fa6d7fc9-e091-4be1-b6c1-5ada5815ae9d. (Reason: CORS request did not succeed).[Learn More]

But there are even more messages

more options

In case it helps, I tried to get Chrome to remember new logins on the same pc and it did. I tried the same login again with Firefox and it still failed even though the ask to remember logins box is still ticked