Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I REMOVE the updates after they're installed?

  • 5 uphendule
  • 1 inale nkinga
  • 1889 views
  • Igcine ukuphendulwa ngu cor-el

more options

Firefox has been opening multiple processes and is slowing down my computer.

I have read that this is because of an update. So, I want to completely remove all of my updates back to the one which caused the problem, and prevent Firefox from harassing me to install the new ones.

How do I do this?

Thanks for any help.

Isisombululo esikhethiwe

benmillan said

Firefox has been opening multiple processes and is slowing down my computer.

Hello benmillan,

In case you have multi process (e10s) enabled, you could try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.tabs.remote.autostart

and set its value to false

Then close and restart Firefox.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

With the changes to updates it not possible to revert back unless you install older version over the current version. If you want to get firefox back it's best to backup your bookmark and uninstall all firefox and deleting the mozilla folder and reinstalled a the latest version that way it's a clean install and avoids any update pitfalls.

https://ftp.mozilla.org/pub/firefox/releases/

more options

You can check the performance settings and set a lower count for content processes.

You can find the current multi-process state on the Troubleshooting Information (about:support) page.

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Web Content Processes
more options

Isisombululo Esikhethiwe

benmillan said

Firefox has been opening multiple processes and is slowing down my computer.

Hello benmillan,

In case you have multi process (e10s) enabled, you could try this :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

browser.tabs.remote.autostart

and set its value to false

Then close and restart Firefox.

more options

Looks like that worked! Thanks! : D

more options

Did you try how it works for you with only one content process?

This is meant as a feature to protect against cases where a tab crashes. With multi-process completely disabled like you did with setting browser.tabs.remote.autostart to false then Firefox will crash when one tab crashes.