X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Stop Firefox from assuming search terms are websites

Kuphostiwe

Is there a way to stop Firefox from assuming that anything with a "." in it, without spaces, is a website? If I search for "string.replace" in the search bar, it attempts to take me to http://www.string.replace/ - instead of searching for "string.replace" on my default search engine.

I've previously had problems with one-word searches taking me to http://www.{one-word}.com

in other words, thinking that by "one-word" I meant "one-word.com", instead of a search for "one-word". I've just instinctively started adding spaces after those; but I actually can't seem to replicate this behaviour anymore. Either it's already been fixed, or I'm not entirely sure under what conditions it happens. Is there a setting to more aggressively go for searches? And ideally only assume something that's an actual toplevel domain, should count as a URL indicator?

Is there a way to stop Firefox from assuming that anything with a "." in it, without spaces, is a website? If I search for "string.replace" in the search bar, it attempts to take me to http://www.string.replace/ - instead of searching for "string.replace" on my default search engine. I've previously had problems with one-word searches taking me to http://www.{one-word}.com in other words, thinking that by "one-word" I meant "one-word.com", instead of a search for "one-word". I've just instinctively started adding spaces after those; but I actually can't seem to replicate this behaviour anymore. Either it's already been fixed, or I'm not entirely sure under what conditions it happens. Is there a setting to more aggressively go for searches? And ideally only assume something that's an actual toplevel domain, should count as a URL indicator?

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4195 izisombululo 58556 izimpendulo
Kuphostiwe

If you are doing this in the address bar, then it will continue. I don't know if this can be turned off. If you use the search bar, there should be no problem.

You could also go to a search engine page directly first.

If you are doing this in the address bar, then it will continue. I don't know if this can be turned off. If you use the search bar, there should be no problem. You could also go to a search engine page directly first.

Umnikazi wombuzo

FredMcD said

If you are doing this in the address bar, then it will continue. I don't know if this can be turned off. If you use the search bar, there should be no problem. You could also go to a search engine page directly first.

Yeah I specifically just want Firefox' address bar search feature to work about as good as Chrome's did in 2008. Having to activate a dedicated search box, that's just giving up trying.

''FredMcD [[#answer-1183313|said]]'' <blockquote> If you are doing this in the address bar, then it will continue. I don't know if this can be turned off. If you use the search bar, there should be no problem. You could also go to a search engine page directly first. </blockquote> Yeah I specifically just want Firefox' address bar search feature to work about as good as Chrome's did in 2008. Having to activate a dedicated search box, that's just giving up trying.

Umnikazi wombuzo

I figured out why I'm sometimes opening a website instead of searching for one-word queries. If I'm pasting something and hit [enter] while still holding [ctrl], then it adds www. and .com. Unless there's a space in the search. From what I can tell browser.fixup.alternate.enabled == false Should disable this feature. It doens't however. Similarly, setting: browser.fixup.alternate.prefix and browser.fixup.alternate.suffix to nothing, doesn't fix it either. Since it's still adding "http://".

I figured out why I'm sometimes opening a website instead of searching for one-word queries. If I'm pasting something and hit [enter] while still holding [ctrl], then it adds www. and .com. Unless there's a space in the search. From what I can tell browser.fixup.alternate.enabled == false Should disable this feature. It doens't however. Similarly, setting: browser.fixup.alternate.prefix and browser.fixup.alternate.suffix to nothing, doesn't fix it either. Since it's still adding "http://".
Franz_von_Suppe 2 izisombululo 30 izimpendulo
Kuphostiwe

nar00w said

Is there a way to stop Firefox from assuming that anything with a "." in it, without spaces, is a website? If I search for "string.replace" in the search bar, it attempts to take me to http://www.string.replace/ - instead of searching for "string.replace" on my default search engine.

You could use search keywords. I use "g" for Google. So I only have to type "g string.replace". You can assign keywords to search engines in the Options by double-clicking on the search engine.

''nar00w [[#question-1244617|said]]'' <blockquote> Is there a way to stop Firefox from assuming that anything with a "." in it, without spaces, is a website? If I search for "string.replace" in the search bar, it attempts to take me to http://www.string.replace/ - instead of searching for "string.replace" on my default search engine. </blockquote> You could use search keywords. I use "g" for Google. So I only have to type "g string.replace". You can assign keywords to search engines in the Options by double-clicking on the search engine.

Umnikazi wombuzo

Franz_von_Suppe said

nar00w said
Is there a way to stop Firefox from assuming that anything with a "." in it, without spaces, is a website? If I search for "string.replace" in the search bar, it attempts to take me to http://www.string.replace/ - instead of searching for "string.replace" on my default search engine.

You could use search keywords. I use "g" for Google. So I only have to type "g string.replace". You can assign keywords to search engines in the Options by double-clicking on the search engine.

That's cool! But just adding a space also solves the problem (for my default search engine). I'd just like the problem not the be there, since there's no good reason for it. I'd even accept false negatives (much more readily than false positives).

''Franz_von_Suppe [[#answer-1183332|said]]'' <blockquote> ''nar00w [[#question-1244617|said]]'' <blockquote> Is there a way to stop Firefox from assuming that anything with a "." in it, without spaces, is a website? If I search for "string.replace" in the search bar, it attempts to take me to http://www.string.replace/ - instead of searching for "string.replace" on my default search engine. </blockquote> You could use search keywords. I use "g" for Google. So I only have to type "g string.replace". You can assign keywords to search engines in the Options by double-clicking on the search engine. </blockquote> That's cool! But just adding a space also solves the problem (for my default search engine). I'd just like the problem not the be there, since there's no good reason for it. I'd even accept false negatives (much more readily than false positives).
Franz_von_Suppe 2 izisombululo 30 izimpendulo
Kuphostiwe
But just adding a space also solves the problem (for my default search engine).

Does not work for me. But another solution is to press arrow down before pressing Enter.

<blockquote> But just adding a space also solves the problem (for my default search engine). </blockquote> Does not work for me. But another solution is to press arrow down before pressing Enter.