Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Address bar autocomplete does not work

  • 1 baphendule
  • 2 zinale nkinga
  • 479 views
  • Igcine ukuphendulwa ngu aspis

more options

This is not a new phenomenon, neither is the thread. But I have not found in here a real solution. I mean they all suggest to delete all the "places" files from FF profile, restart in Safe mode etc. I have enough of this. I have done it in the past and I do it again and it doesn't solve the problem. That's why I am here with the same issue, actually **UNSOLVED**

I give you an example proving that the problem is idependent of "places":

1) I type 'ishow.gr' in the Address bar 2) I enter the site 3) I go back to the previous page 4) I start typing 'is..." 5) No autocomplete

It's as simple as that. And this did not happen in the past (before Firefox Quantum).

Isisombululo esikhethiwe

Finally, I had to manually patch places.sqlite, using Python sqlite3 (for lack of a decent SQLITE editor), to make autocomplete work. The first thing I observed when I was able to read the DB, was that the column "typed" in "moz_hosts" table carried '0' for all records! And I have been typing a lot of them regularly every day! So, I changed the "typed" flag of my regular "hosts" to '1' in places.sqlite and on the next run, what do you know? Problem fixed! Everyone of them was autocompleted by typing just the 1-2 letters, i.e. as expected.

Now that I could control places.sqlite, I did a test by typing a couple of URLs at the address bar and then examining the updated places.sqlite: the new URLs were recorded alright, but the value of "type" column for them was always '0' !!! How could then autocompletion work?

So, the "no-autocompletion bug" becomes more specific:

       * Firefox does not record typed URLs as such *

I wish FF developers pass from here to read this (although I doubt ...)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (1)

more options

Isisombululo Esikhethiwe

Finally, I had to manually patch places.sqlite, using Python sqlite3 (for lack of a decent SQLITE editor), to make autocomplete work. The first thing I observed when I was able to read the DB, was that the column "typed" in "moz_hosts" table carried '0' for all records! And I have been typing a lot of them regularly every day! So, I changed the "typed" flag of my regular "hosts" to '1' in places.sqlite and on the next run, what do you know? Problem fixed! Everyone of them was autocompleted by typing just the 1-2 letters, i.e. as expected.

Now that I could control places.sqlite, I did a test by typing a couple of URLs at the address bar and then examining the updated places.sqlite: the new URLs were recorded alright, but the value of "type" column for them was always '0' !!! How could then autocompletion work?

So, the "no-autocompletion bug" becomes more specific:

       * Firefox does not record typed URLs as such *

I wish FF developers pass from here to read this (although I doubt ...)