Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

when clicking on custom protocol link, how to prevent firefox from prepending the path with Program Files /Mozilla Firefox?

more options

When clicking on a link like this in firefox: phpstorm://open?url=file://C:\wamp\www\myproject\src\AppBundle\Controller\AppController.php&line=17

I am asked which .exe I would like to associate with this protocol, I choose phpstorm.exe.

But the app supposed to open the file (phpstorm) gives me the following error:

Cannot find file 'C:\Program Files\Mozilla Firefox\phpstorm:\open?url=file:\C:\wamp\www\myproject\src\AppBundle\Controller\AppController.php&line=17'

The problem seems to be that the path is prepended with "C:\Program Files\Mozilla Firefox" How do I change this behaviour ? Thanks.

All Replies (1)

more options

Hi pfleu

I guess you are using the Jet Brains IDE to write PHP webapplication of some sort?

This is a Firefox user support forum, we don't have the expertise to answer developer questions. Please ask on stack overflow and tag it firefox and I would also give jet brains support a try too.

https://support.mozilla.org/en-US/kb/where-go-developer-support Cheers!

..Roland