Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Default CSS breaks websites that dont explicitly declare Body colors - in latest Firefox release for Windows 10 Pro

  • 12 uphendule
  • 1 inale nkinga
  • 73 views
  • Igcine ukuphendulwa ngu Macronomicus

more options

I saw the other couple reports, but could not comment since there's no way to create an account here.

The other reports mostly noticed the Title bar and theme issues, but being a web developer I also notice that half the internet is unreadable. No matter what theme Windows is set to, Light or Dark, no matter what theme Firefox is set to, Default, Light, or Dark, the same problem happens in any websites that do not explicitly declare the Body background-color and text color. So instead they become Grey and Grey, rather than White bg, and Black text.

Attached is one example, this only happens in Firefox, not other browsers.

Isisombululo esikhethiwe

Hmm, also, sanity check these preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste disp*color and pause while the list is filtered

(3) If any color preferences are bolded and "modified", you can restore default values using right-click > Reset or you can double-click and set your preferred value

The browser.display.document_color_use preference has these possible values:

  • 0 - use page colors EXCEPT when using a High Contrast theme, and then adapt to the theme
  • 1 - always follow page colors if specified (if not specified, use fallback colors for text and background)
  • 2 - always disregard page colors and use fallback colors for text and background

Edit: Adding screenshot showing mapping of key preferences between the Options page and about:config.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (12)

more options

Hi Macronomicus, feel free to re-attach the image files or provide links.

Have you ever created a userChrome.css file, a userContent.css file, or applied custom rules to websites using add-ons (such as Stylus or Stylish)? To rule those out as possible factors:

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, userChrome.css, userContent.css, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Okulungisiwe ngu jscher2000

more options

Isisombululo Esikhethiwe

Hmm, also, sanity check these preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste disp*color and pause while the list is filtered

(3) If any color preferences are bolded and "modified", you can restore default values using right-click > Reset or you can double-click and set your preferred value

The browser.display.document_color_use preference has these possible values:

  • 0 - use page colors EXCEPT when using a High Contrast theme, and then adapt to the theme
  • 1 - always follow page colors if specified (if not specified, use fallback colors for text and background)
  • 2 - always disregard page colors and use fallback colors for text and background

Edit: Adding screenshot showing mapping of key preferences between the Options page and about:config.

Okulungisiwe ngu jscher2000

more options

I assume that you have checked default colors in Options/Preferences?

  • Options/Preferences -> General: Fonts & Colors -> Colors
more options

Wow, thanks everyone, I will check those and get back to you. :)

more options

cor-el said

I assume that you have checked default colors in Options/Preferences?
  • Options/Preferences -> General: Fonts & Colors -> Colors

I can see on those settings indeed the background and text are set to odd dark colors.

more options

Here are the color settings as they are, I have never changed these settings, so they're as FF wants them for whatever reason. I did have an app that can darken websites at one point in the past, but its not an active plugin anymore. I basically use almost no addons or plugins, except just a few.

Okulungisiwe ngu Macronomicus

more options

I guess my screenshot in the OP did not upload with it for some reason, so here is that. First one shows the body bg and text grey, second is what it should show, and yes on that website, there are no color declarations for body bg or txt color. So any sites that rely on those defaults are grey now.

My OS is set to Light theme, and Firefox is on default, but i tested all themes, both OS and Browser.

Okulungisiwe ngu Macronomicus

more options

jscher2000 said

Hmm, also, sanity check these preferences: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste disp*color and pause while the list is filtered (3) If any color preferences are bolded and "modified", you can restore default values using right-click > Reset or you can double-click and set your preferred value The browser.display.document_color_use preference has these possible values:
  • 0 - use page colors EXCEPT when using a High Contrast theme, and then adapt to the theme
  • 1 - always follow page colors if specified (if not specified, use fallback colors for text and background)
  • 2 - always disregard page colors and use fallback colors for text and background

Edit: Adding screenshot showing mapping of key preferences between the Options page and about:config.

Thanks, here is a snapshot of that so you can see, I was right, the defaults are altered, but I cant imagine why? I've never changed them, or given permissions for that change. Maybe the latest Win update is just a bit buggy still? hehee ive seen some of the other issues folks are having, but this is quite an odd one since it only effects the latest Firefox, and no other browser.

This is still definitely a bug, you can see in my Color settings image in the post above, its set to only alter when in OS 'High Contrast theme' mode, which i do not and have never used on Windows because its hideous lol.

Reverting those settings to default the sites all look fine, thanks for the suggestion, I have market it as solved, however like I said its surely a bug of some sort.

Okulungisiwe ngu Macronomicus

more options

Ok I can confirm its easy to trigger the bug repeatedly. Simply change the text and background colors in Options> Colors, but leave the "Only with High Contrast themes" setting to active. You will see any websites that do no explicitly declare body background color and text color, will be overridden by the firefox color settings, even though you're not using a High Contrast Theme.

I am still puzzeled as to how my colors got altered, but I can see the bug is clearly there now, so who knows what could be off? Perhaps Windows changed the bits around High Contrast Theme's FF was relying on for the Color functionality and now its fubar after the latest win update.

more options

The default text and background colors are only (always) used when a website doesn't specify either or both colors. This is not a bug, but expected behavior. Override means that the website colors aren't used and this can happen if you use a High Contrast theme in the operating system or explicitly disable website colors (i.e. you always override them). The only weird thing in your case are the non default color values. Only Legacy extensions (Firefox 56 and older) could have done this if you've never changed them yourself (a user.js file could have done this), so you should have experienced this behavior for quite some time.

more options

cor-el said

The default text and background colors are only (always) used when a website doesn't specify either or both colors. This is not a bug, but expected behavior. Override means that the website colors aren't used and this can happen if you use a High Contrast theme in the operating system or explicitly disable website colors (i.e. you always override them). The only weird thing in your case are the non default color values. Only Legacy extensions (Firefox 56 and older) could have done this if you've never changed them yourself (a user.js file could have done this), so you should have experienced this behavior for quite some time.

So its expected? Maybe the text has a typo on the settings page? It says Override the colors specified by the page with your selections above - Only with High Contrast Themes

I assumed that meant it would not override things unless I was using a High Contrast Windows theme, which I have never used.

Most people wont notice this bug unless somehow those colors get changed from defaults, even now that I have reset the, things could easily break again, if those colors are changed, as of now theres no way to restrict it only to high contrast themes, which seemed the whole point of that setting anyway right? Not to be argumentitive but I think this is either a bug, or just text/settings that did not get updated with the change of how that setting functions.

Okulungisiwe ngu Macronomicus

more options

Ok I see what you mean, I do know it always uses the defaults when not specified, thats why so many sites broke for me, but that setting still seems it could use a better label to be more clear lol