X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Coloured line appears on scrolling, it's thin but stretches the whole width of the screen

Kuphostiwe

In the past couple of weeks a rainbow coloured line appears when I scroll in firefox on my laptop (see image attached). It only happens in firefox, I have tested other browsers and applications and they are fine. I logged into my old laptop yesterday, wihch I haven't logged into for about a month and the same thing is happening in there upon scrolling.....and again....only in firefox. Please can someone help, it's really distracting! Thank you in advance.

In the past couple of weeks a rainbow coloured line appears when I scroll in firefox on my laptop (see image attached). It only happens in firefox, I have tested other browsers and applications and they are fine. I logged into my old laptop yesterday, wihch I haven't logged into for about a month and the same thing is happening in there upon scrolling.....and again....only in firefox. Please can someone help, it's really distracting! Thank you in advance.

Isisombululo esikhethiwe

Firefox Safe Mode disables hardware acceleration and extensions.

Are you sure that you previously disabled hardware acceleration and restarted Firefox?


If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Funda le mpendulo ngokuhambisana nalesi sihloko 1
Isicaphuno

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
16724 izisombululo 151242 izimpendulo

Impendulo Ewusizo

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting for changes to take effect. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
FredMcD
  • Top 10 Contributor
3824 izisombululo 53098 izimpendulo

Impendulo Ewusizo

KDR9 said

(see image attached)

Your image did not get thru.

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

''KDR9 [[#question-1240953|said]]'' <blockquote> (see image attached) </blockquote> Your image did not get thru. In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Hi, thank you both for such speedy replies! I'm sorry, I should have said that I did already try to disable the hardware acceleration option, I closed all browser windows but it still appeared when I opened back up again (do you think having tabs open within the 'onetab' addon is the reason for this?)

I checked for updated drivers but they are up to date.

The image file I originally tried to upload was too big, hopefully this one should make it through. It's a photo of my screen, rather than a screenshot because it only appears for a split second, it's rather hard to catch using the keyboard whilst scrolling.

Hi, thank you both for such speedy replies! I'm sorry, I should have said that I did already try to disable the hardware acceleration option, I closed all browser windows but it still appeared when I opened back up again (do you think having tabs open within the 'onetab' addon is the reason for this?) I checked for updated drivers but they are up to date. The image file I originally tried to upload was too big, hopefully this one should make it through. It's a photo of my screen, rather than a screenshot because it only appears for a split second, it's rather hard to catch using the keyboard whilst scrolling.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
3824 izisombululo 53098 izimpendulo

KDR9 said

(do you think having tabs open within the 'onetab' addon is the reason for this?)

There is one way to find out;

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

''KDR9 [[#answer-1173986|said]]'' <blockquote> (do you think having tabs open within the 'onetab' addon is the reason for this?) </blockquote> There is one way to find out; [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno
FredMcD
  • Top 10 Contributor
3824 izisombululo 53098 izimpendulo

KDR9 said

It's a photo of my screen, rather than a screenshot because it only appears for a split second, it's rather hard to catch using the keyboard whilst scrolling.

There are screen recorders available. Some of them are free/free to use.

Once you have a clip, run it thru a player, stop at the right place, and take a screenshot.

''KDR9 [[#answer-1173986|said]]'' <blockquote> It's a photo of my screen, rather than a screenshot because it only appears for a split second, it's rather hard to catch using the keyboard whilst scrolling. </blockquote> There are screen recorders available. Some of them are free/free to use. Once you have a clip, run it thru a player, stop at the right place, and take a screenshot.
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

Hi FredMcD, I have just done as you suggested, started in safe mode and the problem does not exist in this mode!

I will have a look at the screen recorder suggestion now and try to get a good shot of the issue. Many thanks

Hi FredMcD, I have just done as you suggested, started in safe mode and the problem does not exist in this mode! I will have a look at the screen recorder suggestion now and try to get a good shot of the issue. Many thanks
Ingabe lokhu kube usizo kuwena?
Isicaphuno

Umnikazi wombuzo

Hopefully you will be able to see the line on this image, captured using the screen recorder software.

Hopefully you will be able to see the line on this image, captured using the screen recorder software.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
cor-el
  • Top 10 Contributor
  • Moderator
16724 izisombululo 151242 izimpendulo

Isisombululo Esikhethiwe

Firefox Safe Mode disables hardware acceleration and extensions.

Are you sure that you previously disabled hardware acceleration and restarted Firefox?


If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Firefox Safe Mode disables hardware acceleration and extensions. Are you sure that you previously disabled hardware acceleration and restarted Firefox? ---- If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via one of these: *"3-bar" menu button -> Exit (Power button) *Windows: File -> Exit *Mac: Firefox -> Quit Firefox *Linux: File -> Quit
Ingabe lokhu kube usizo kuwena? 1
Isicaphuno

Umnikazi wombuzo

I feel really embarrassed, you'll see why. I deactivated all plugins and one by one I switched them back on, I now realise I had a plugin called 'Scroll position highlight', this is what creates the coloured line to mark your previous scroll position. I'm so sorry to have wasted all of your time, thank you so much for your help. Next time I will do some more troubleshooting myself before bothering you good people. This is my first ever experience of posting on a forum of any kind and I just want to say you have all been amazing. Thank you.

I feel really embarrassed, you'll see why. I deactivated all plugins and one by one I switched them back on, I now realise I had a plugin called 'Scroll position highlight', this is what creates the coloured line to mark your previous scroll position. I'm so sorry to have wasted all of your time, thank you so much for your help. Next time I will do some more troubleshooting myself before bothering you good people. This is my first ever experience of posting on a forum of any kind and I just want to say you have all been amazing. Thank you.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
FredMcD
  • Top 10 Contributor
3824 izisombululo 53098 izimpendulo

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Ingabe lokhu kube usizo kuwena?
Isicaphuno
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.