Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Video from one site starts playing, then stops with error "Secure Connection Failed, ... authenticity of the received data could not be verified" after a few mi

  • 3 uphendule
  • 1 inale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu cor-el

more options

I am trying to play videos from an internal web site that uses Sharepoint. Firefox (63.0.3 (64-bit) under Windows 10) starts playing each video, but after a couple of minutes stops with the message

       Secure Connection Failed
        An error occurred during a connection to [site name redacted by me] 
        The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.

I find it puzzling that Firefox has enough confidence in the connection to start playing the videos, but then seems to change its mind and blocks them. The videos play all the way through with IE-11 and Chrome.

I am trying to play videos from an internal web site that uses Sharepoint. Firefox (63.0.3 (64-bit) under Windows 10) starts playing each video, but after a couple of minutes stops with the message Secure Connection Failed An error occurred during a connection to [site name redacted by me] The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. I find it puzzling that Firefox has enough confidence in the connection to start playing the videos, but then seems to change its mind and blocks them. The videos play all the way through with IE-11 and Chrome.

All Replies (3)

more options
more options

Thank you, Fred, for your quick response. Perhaps you can point me to something that addresses my problem more specifically. All these articles address the question of not being able to access a web page at all. I do get a connection initially. Firefox starts playing the video, then in the middle of the video it stops with the security complaint. It's an MP4 file. Following the download progress bar, we can see the download advancing ahead of what is showing on the screen. Then both stop and the message fills the window. This is not just my computer. When I called our in-house desktop support, they replicated the problem with the videos stopping in the same place under Firefox.

more options

Did you check for issues caused by your Norton (Symantec) security software?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.