X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox tab hangs when opening maps.google.com and certain other sites

Kuphostiwe

Lately (possibly since updating MacOS to Mojave, not sure), certain websites such as maps.google.com reliably cause a tab to hang indefinitely (with the grey rotating circle). This then causes other tabs to hang or not load properly until I restart Firefox, and I'm unable to quit Firefox normally, I have to force quit. I have no issues in Safe Mode, but I've tried refreshing Firefox, removing all add-ons and themes, disabling hardware acceleration, and the problem still occurs when not in safe mode. I'd really appreciate any help I can get with this, it's not only frustrating but is impairing my ability to do my job.

Lately (possibly since updating MacOS to Mojave, not sure), certain websites such as maps.google.com reliably cause a tab to hang indefinitely (with the grey rotating circle). This then causes other tabs to hang or not load properly until I restart Firefox, and I'm unable to quit Firefox normally, I have to force quit. I have no issues in Safe Mode, but I've tried refreshing Firefox, removing all add-ons and themes, disabling hardware acceleration, and the problem still occurs when not in safe mode. I'd really appreciate any help I can get with this, it's not only frustrating but is impairing my ability to do my job.

Isisombululo esikhethiwe

I seem to have figured out the solution. After a lot of searching, it turns out the MacOS Mojave deprecated WebGL. I had to follow these instructions to disable it in Firefox, which fixed my issues: https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_disabling-webgl

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 63.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:63.0) Gecko/20100101 Firefox/63.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/63.0.1/Darwin/en-US/

Izandiso

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription:
  • adapterDeviceID: 0x0001
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0xffff
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: True
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha

Isisombululo Esikhethiwe

I seem to have figured out the solution. After a lot of searching, it turns out the MacOS Mojave deprecated WebGL. I had to follow these instructions to disable it in Firefox, which fixed my issues: https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_disabling-webgl

I seem to have figured out the solution. After a lot of searching, it turns out the MacOS Mojave deprecated WebGL. I had to follow these instructions to disable it in Firefox, which fixed my issues: https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_disabling-webgl