Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

PDF Files don't open in firefox now

  • 3 uphendule
  • 2 zinale nkinga
  • 21 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Hi, I'm currently running version 63.0.1 , something has changed with my browser, previously when I clicked on a pdf file it would automatically open within the firefox browser. It's rather frustrating to me as a user of this great browser when a pdf file attempts to open using something other than firefox. I feel sure there MUST be some method to correct this issue. Thanks, David

All Replies (3)

more options

Hi David, could you first check the setting described in the following article. If it already says "Preview in Firefox", try choosing something different and then change back to Preview in Firefox.

View PDF files in Firefox or choose another viewer

Any improvement?

Does this affect all PDF files, or only PDFs from certain sites? Firefox only applies that setting to PDF files if the server sends the application/pdf Content-Type header. Some sites send a more generic header and in that case, you're stuck.

(I created an add-on for stubborn sites, if it turns out to be a site-specific problem: Content-Type Fixer.)

Sites also have the option to instruct Firefox to download a file instead of opening it in a tab. Most sites don't do that but there may be an add-on solution for that, too. (For example, Display Inline.)

more options

Hi jscher2000, Thanks so much for your reply, yesterday I re-installed firefox, hoping that would correct the issue. As I remember, somewhere in the about:configure area a user has the ability to toggle an item that deals with 'pdf' files. all I know is that while using a different browser..say chrome or edge, the built-in pdf viewer still functions properly. David

more options

Hi David, fortunately or unfortunately, reinstalling Firefox doesn't blow out and replace your existing settings. If you want to do that, you can try the Refresh* feature. However, if you don't want to do that, you could try:

Reset PDF preferences in about:config

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste pdfjs and pause while the list is filtered

(3) You can reset any modified preferences using right-click > Reset

Reset "download handlers" file

It sounds as though my suggestion on switching among the PDF handler settings on the Options page didn't help. If Firefox ignores those settings, it can indicate that the settings file that stores download handling preferences has become corrupted. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit/Quit
  • (menu bar) File > Exit (or Firefox > Quit)

Pause while Firefox finishes its cleanup, then rename handlers.json to something like handlersOLD.json. If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf.

Start Firefox back up again. Any improvement?

* This article describes the Refresh feature: Refresh Firefox - reset add-ons and settings