X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Printing does not work: I always get one or more "Printer Error: An error occurred while printing" popup alert

Kuphostiwe

This is on OSX 10.12.6. I am an 'admin' user on the Mac.

This problem happens only on my own OSX login account: printing works fine from other login accounts (who are also admin-level users) on the same computer.

If I try to print a regular page I get the following results: 1) I see the "print" dialog (select the printer, single-sided or duplex, etc.). When I press "Print" I see: 2) Print Preview Error: an error occurred while printing. When I press "OK" I see: 3) Print Error: An error occurred while printing.


I tried to fix this in three ways and in the following order: (a) starting in safe mode; (b) stoping and restarting using the Refresh Firefox option; and (c) creating a brand new profile. None of these fixed the problem. I still am unable to print, and I get the result described above.

Does anyone have any other options to consider? I really don't want to lose my history, bookmarks or stored passwords!

This is on OSX 10.12.6. I am an 'admin' user on the Mac. This problem happens only on my own OSX login account: printing works fine from other login accounts (who are also admin-level users) on the same computer. If I try to print a regular page I get the following results: 1) I see the "print" dialog (select the printer, single-sided or duplex, etc.). When I press "Print" I see: 2) Print Preview Error: an error occurred while printing. When I press "OK" I see: 3) Print Error: An error occurred while printing. I tried to fix this in three ways and in the following order: (a) starting in safe mode; (b) stoping and restarting using the Refresh Firefox option; and (c) creating a brand new profile. None of these fixed the problem. I still am unable to print, and I get the result described above. Does anyone have any other options to consider? I really don't want to lose my history, bookmarks or stored passwords!

Eminye Imininingwane Yohlelo

Fakela amapulagi

OpenH264 Video Codec provided by Cisco Systems Widevine Content Decryption Module provided by Google Inc. Shockwave Flash 31.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36

Eminye Imininingwane

Roland Tanglao
  • Administrator
71 izisombululo 781 izimpendulo
Kuphostiwe

Hi nai.maharg:

I have many computers including Windows and Mac. I have two Mac one with Mac OS X 10.11 and one with Mac OS X 10.13. both with Firefox 63.0.1. Both can print the web pages I tried printing no problem. Perhaps it's the webpages you are trying to print?

Could you please share the url of the webpages you are trying to print?

Cheers!

...Roland

Hi nai.maharg: I have many computers including Windows and Mac. I have two Mac one with Mac OS X 10.11 and one with Mac OS X 10.13. both with Firefox 63.0.1. Both can print the web pages I tried printing no problem. Perhaps it's the webpages you are trying to print? Could you please share the url of the webpages you are trying to print? Cheers! ...Roland
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156036 izimpendulo
Kuphostiwe

Any more specific messages in the Browser Console about printing?

This could be a security or sandbox issue.

Any more specific messages in the Browser Console about printing? *https://developer.mozilla.org/en/Tools/Browser_Console This could be a security or sandbox issue. *https://wiki.mozilla.org/Security/Sandbox *https://wiki.mozilla.org/Security/Sandbox#Content_Levels

Umnikazi wombuzo

Roland Tanglao said

Hi nai.maharg: I have many computers including Windows and Mac. I have two Mac one with Mac OS X 10.11 and one with Mac OS X 10.13. both with Firefox 63.0.1. Both can print the web pages I tried printing no problem. Perhaps it's the webpages you are trying to print? Could you please share the url of the webpages you are trying to print? Cheers! ...Roland

I can't print any web pages. Every URL yields the same problem.

''Roland Tanglao [[#answer-1170172|said]]'' <blockquote> Hi nai.maharg: I have many computers including Windows and Mac. I have two Mac one with Mac OS X 10.11 and one with Mac OS X 10.13. both with Firefox 63.0.1. Both can print the web pages I tried printing no problem. Perhaps it's the webpages you are trying to print? Could you please share the url of the webpages you are trying to print? Cheers! ...Roland </blockquote> I can't print any web pages. Every URL yields the same problem.

Umnikazi wombuzo

I should also admit this isn't a new problem: it came up a few months ago in a previous version of FF. However I have other computers as well and would print from there, and told myself I would 'fix' this problem when I had time to look at it. But now that I've had the time to look at it I found myself unable to fix it, so decided to reach out for help.

I should also admit this isn't a new problem: it came up a few months ago in a previous version of FF. However I have other computers as well and would print from there, and told myself I would 'fix' this problem when I had time to look at it. But now that I've had the time to look at it I found myself unable to fix it, so decided to reach out for help.

Umnikazi wombuzo

The browser console provides the following messages when I try to print: [Exception... "Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIPrintSettingsService.defaultPrinterName]" nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)" location: "JS frame :: chrome://global/content/printUtils.js :: getDefaultPrinterName :: line 109" data: no] In Printing:Print:Done handler, got unexpected rv

                       2147500037. PrintingChild.jsm:358

OpenGL compositor Initialized Succesfully. Version: 2.1 INTEL-10.2.37 Vendor: Intel Inc. Renderer: Intel HD Graphics 3000 OpenGL Engine FBO Texture Target: TEXTURE_2D

The browser console provides the following messages when I try to print: [Exception... "Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIPrintSettingsService.defaultPrinterName]" nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)" location: "JS frame :: chrome://global/content/printUtils.js :: getDefaultPrinterName :: line 109" data: no] In Printing:Print:Done handler, got unexpected rv 2147500037. PrintingChild.jsm:358 OpenGL compositor Initialized Succesfully. Version: 2.1 INTEL-10.2.37 Vendor: Intel Inc. Renderer: Intel HD Graphics 3000 OpenGL Engine FBO Texture Target: TEXTURE_2D
cor-el
  • Top 10 Contributor
  • Moderator
17267 izisombululo 156036 izimpendulo
Kuphostiwe
Try to reset the print prefs on the <b>about:config</b> page. *https://support.mozilla.org/en-US/kb/how-print-website *http://kb.mozillazine.org/Problems_printing_web_pages

Umnikazi wombuzo

cor-el said

Try to reset the print prefs on the about:config page.

I tried that - did not fix things. I also edited the prefs.js file to remove all the *print_* prefs - this also did not fix things.

''cor-el [[#answer-1170501|said]]'' <blockquote> Try to reset the print prefs on the <b>about:config</b> page. *https://support.mozilla.org/en-US/kb/how-print-website *http://kb.mozillazine.org/Problems_printing_web_pages </blockquote> I tried that - did not fix things. I also edited the prefs.js file to remove all the <tt> *print_* </tt> prefs - this also did not fix things.

Umnikazi wombuzo

So anyone have other ideas? It still doesn't print adn I don't really want to trash my whole profile just to fix this ....

So anyone have other ideas? It still doesn't print adn I don't really want to trash my whole profile just to fix this ....