X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 63.01 options: Your organization has disabled the ability to change some options

Kuphostiwe

My personal copy of Firefox and I am the administrator of my system. I suddenly can't make changes to options and my right click copy/search capabilities are not available

My personal copy of Firefox and I am the administrator of my system. I suddenly can't make changes to options and my right click copy/search capabilities are not available

Isisombululo esikhethiwe

Yes, remove Firefox as well. That should remove the notification.

Funda le mpendulo ngokuhambisana nalesi sihloko 2

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 31.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4270 izisombululo 59892 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

You appear to have policies active, possibly set by your IT department. You can check this on the "Help -> Troubleshooting Information" (about:support) page under application basics (Enterprise Policies).

See the about:policies page for more detail. You can open "about:" pages via the location/address bar or via the Enterprise Policies link.

  • "about:" is a protocol to access special pages

See also:

You appear to have policies active, possibly set by your IT department. You can check this on the "Help -> Troubleshooting Information" (about:support) page under application basics (Enterprise Policies). See the <b>about:policies</b> page for more detail. You can open "<b>about:</b>" pages via the location/address bar or via the Enterprise Policies link. *"about:" is a protocol to access special pages See also: *https://support.mozilla.org/en-US/kb/customizing-firefox-using-group-policy *https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig

Okulungisiwe ngu cor-el

Umnikazi wombuzo

FredMcD: Restarting in safe mode seems to remediate the problem but now that just means I need to figure out what is restricting access when I'm in "normal" mode. Any suggestions?

Cor-el: I don't have an IT dept. I am the IT dept, it's my personal home computer. Policies only has telemetry disabled.

Everything was fine, this just happened right after updating to 63.01 (64bit) a couple days ago.

FredMcD: Restarting in safe mode seems to remediate the problem but now that just means I need to figure out what is restricting access when I'm in "normal" mode. Any suggestions? Cor-el: I don't have an IT dept. I am the IT dept, it's my personal home computer. Policies only has telemetry disabled. Everything was fine, this just happened right after updating to 63.01 (64bit) a couple days ago.
FredMcD
  • Top 10 Contributor
4270 izisombululo 59892 izimpendulo
Kuphostiwe

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

It could be the work of one of your add-ons, or it could be '''Hardware Acceleration. ''' ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link} Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Disable a few add-ons, then '''Restart Firefox. ''' Some added toolbar and anti-virus add-ons are known to cause Firefox issues. '''Disable All Of them. ''' If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group '''ONE AT A TIME''' (restarting FF) until the problem returns. Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

Did you check the about:policies page?

Can you attach a screenshot of the about:policies page?

You can also check the Windows Registry to see if you have this key.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox
Did you check the about:policies page? Can you attach a screenshot of the about:policies page? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot You can also check the Windows Registry to see if you have this key. *HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox

Umnikazi wombuzo

FredMcD: I checked the hardware acceleration setting and disabled it (it was enabled). I've disabled all the add-ons and checked them individually. I found the add-on that was causing my copy/search problem. So thank you for nudging me in the right direction.

Although I'm still getting the "Your organization has disabled..." message at the top of the add-ons page. Still not sure what is going on with that

Cor-el: I check to make sure the regedit value was there and it is. I've attached a copy of the policy settings in FF and the registry setting. See attached images.

Thanks guys for the help.

FredMcD: I checked the hardware acceleration setting and disabled it (it was enabled). I've disabled all the add-ons and checked them individually. I found the add-on that was causing my copy/search problem. So thank you for nudging me in the right direction. Although I'm still getting the "Your organization has disabled..." message at the top of the add-ons page. Still not sure what is going on with that Cor-el: I check to make sure the regedit value was there and it is. I've attached a copy of the policy settings in FF and the registry setting. See attached images. Thanks guys for the help.
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

There is a GPO policy active to disable Telemetry as you can see.

You would have to remove the entire Firefox key that contains this policy to disable the notification. Removing only the keys in the Firefox key is not sufficient, you need to remove the Firefox key.

There is a GPO policy active to disable Telemetry as you can see. You would have to remove the entire Firefox key that contains this policy to disable the notification. Removing only the keys in the Firefox key is not sufficient, you need to remove the Firefox key. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-group-policy

Okulungisiwe ngu cor-el

Umnikazi wombuzo

Cor-el: Why would "Telemetry" have anything to do with permissions?

Cor-el: Why would "Telemetry" have anything to do with permissions?
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

Impendulo Ewusizo

This isn't about permissions, but about having locked some preferences.

If you open the about:config page via the location bar and click the Status header to sort by this column then you should see that at least one pref shows as locked. Having the above mentioned GPO key is sufficient for the presence of this notification.

This specific policy disable sending Telemetry data to Mozilla.

This isn't about permissions, but about having locked some preferences. If you open the <b>about:config</b> page via the location bar and click the Status header to sort by this column then you should see that at least one pref shows as locked. Having the above mentioned GPO key is sufficient for the presence of this notification. This specific policy disable sending Telemetry data to Mozilla. *https://support.mozilla.org/en-US/kb/share-data-mozilla-help-improve-firefox

Umnikazi wombuzo

Cor-el: OK, sorry I took so long to respond but I disabled/removed Telemetry policy/key as recommended. Still getting the message and still can't find any info on this. I checked every install on every machine I have and its the same. It's like I'm the only one who's experiencing it or has reported it.

Honestly I'm not seeing or haven't seen any appreciable restrictions to my install other than that message. I did find the add-on that was affecting copy/paste/search issues, so that was good.

I just want to make sure that any administrative controls are accessible and controlled by me and not some other app or so called "organization/administrator".

Cor-el: OK, sorry I took so long to respond but I disabled/removed Telemetry policy/key as recommended. Still getting the message and still can't find any info on this. I checked every install on every machine I have and its the same. It's like I'm the only one who's experiencing it or has reported it. Honestly I'm not seeing or haven't seen any appreciable restrictions to my install other than that message. I did find the add-on that was affecting copy/paste/search issues, so that was good. I just want to make sure that any administrative controls are accessible and controlled by me and not some other app or so called "organization/administrator".
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Did you remove the Firefox key, leaving only the Mozilla key (or remove the Mozilla key as well if it is empty)?

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla

If you leave an empty Firefox key then Firefox might still show this notification.

Did you remove the Firefox key, leaving only the Mozilla key (or remove the Mozilla key as well if it is empty)? *HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla If you leave an empty Firefox key then Firefox might still show this notification.

Umnikazi wombuzo

Yes, I left the whole thing, just removed the entry. Firefox is still there. Should I remove it?

Yes, I left the whole thing, just removed the entry. Firefox is still there. Should I remove it?
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Yes, remove Firefox as well. That should remove the notification.

Yes, remove Firefox as well. That should remove the notification.

Umnikazi wombuzo

Well, what do you know, it worked. Thank you.

Not sure what the thought process is for the Firefox key, locked configuration and "admin" access is? Can't seem to find any info on it either.

Thanks again and I appreciate you taking the time to help.

Well, what do you know, it worked. Thank you. Not sure what the thought process is for the Firefox key, locked configuration and "admin" access is? Can't seem to find any info on it either. Thanks again and I appreciate you taking the time to help.