X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

DNS in HTTPS

Kuphostiwe

Hi, Dear Firefox Support team. I'm currently using Firefox Nightly version 65.0a1. In the settings I selected enable DNS based on HTTPS and the address is default: https://mozilla.cloudflare-dns.com/dns-query And I can access to this cloudflare-dns website. but when I use wireshark, and browse Internet, I still find I'm doing DNS query each website, why is this happen? Doesn't the Firefox Nightly suppose to tunnel these traffic into https?

Hi, Dear Firefox Support team. I'm currently using Firefox Nightly version 65.0a1. In the settings I selected enable DNS based on HTTPS and the address is default: https://mozilla.cloudflare-dns.com/dns-query And I can access to this cloudflare-dns website. but when I use wireshark, and browse Internet, I still find I'm doing DNS query each website, why is this happen? Doesn't the Firefox Nightly suppose to tunnel these traffic into https?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 31.0 r0*

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17583 izisombululo 159079 izimpendulo
Kuphostiwe
See also: *https://www.ghacks.net/2018/04/02/configure-dns-over-https-in-firefox/

Umnikazi wombuzo

Tried the guide, set the dns in firefox nightly as 1.1.1.1, still get dns query in wireshark.

Tried the guide, set the dns in firefox nightly as 1.1.1.1, still get dns query in wireshark.
cor-el
  • Top 10 Contributor
  • Moderator
17583 izisombululo 159079 izimpendulo
Kuphostiwe

Try to ask at the Stack Overflow forum site, maybe someone over there know the answer.

Try to ask at the Stack Overflow forum site, maybe someone over there know the answer. *http://stackoverflow.com/questions/
Mace2 21 izisombululo 355 izimpendulo
Kuphostiwe

What is happening is your have network.trr.mode set to 2 which allows Doh to default back to your operating system DNS.

You should be able to set network.trr.mode=3 so it only uses the Doh setting in firefox without defaulting to any other DNS. I could not get it to work. You have to restart Firefox I believe for it to take affect.

What is happening is your have network.trr.mode set to 2 which allows Doh to default back to your operating system DNS. You should be able to set network.trr.mode=3 so it only uses the Doh setting in firefox without defaulting to any other DNS. I could not get it to work. You have to restart Firefox I believe for it to take affect.