Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Latest update blocking Wordpress notification in Mozilla Firefox

  • 5 uphendule
  • 1 inale nkinga
  • 577 views
  • Igcine ukuphendulwa ngu springheel

more options

I've attached a screenshot of one of my WP blogs in both IE & Mozilla. After taking a recent update to the Mozilla browser this morning, and as you can see, the notifications in the drop-down menu are showing in Internet Expxlorer but not Mozilla.

I know the protocol, cache has been cleaned, have rebooted the browser in safe mode et al. I even disabled the tracker blocking on the page even though that has never been an issue before (however, I did have to disable that feature on the text editor page when it was first introduced)

That said, I'm obviously missing something and hopefully this will be an easy fix.

Thank you.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Nevermind. I got this.

I'll just switch browsers.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

springheel said

I've attached a screenshot of one of my WP blogs in both IE & Mozilla.

Actually... You haven't (it's the same screenshot, twice. :))

What's with the whole "tracker blocking" deal, is it a Mozilla Firefox browser Extension; starting in Safe Mode should've disabled all of 'em. You could try and Profile Manager - Create, remove, or switch Firefox profiles to see if that's, maybe, the issue.

Okulungisiwe ngu nostromov

more options

I did, didn't I. Sorry. Nerveless that drop-down is completly blank in Mozilla. Nothing but white space.

No, it's not an add-on. It's a built-in feature of the browser. See the "badge" in the address bar; you can enable & disable it there or in options. Relatively the same process as Ad Blocker Plus.

I did open the console (not that I really know what I'm looking at) and after isolating the drop-down in a tab of it's own found these warnings related to that very menu:

Request to access cookie or storage on “https://public-api.wordpress.com/wp-admin/rest-proxy/?v=2.0#https://widgets.wp.com” was blocked because we are blocking all third-party storage access requests and content blocking is enabled. build.min.js:85:150440 Request to access cookie or storage on “https://public-api.wordpress.com/wp-admin/rest-proxy/?v=2.0#https://widgets.wp.com” was blocked because we are blocking all third-party storage access requests and content blocking is enabled.

There is something in the browser that is still blocking those "requests."

I've attached, I hope, the correct screenshot this time. Thank you for pointing that out.

more options

Isisombululo Esikhethiwe

Nevermind. I got this.

I'll just switch browsers.

more options

Hi springhell:

It seems like https://support.mozilla.org/en-US/kb/tracking-protection?as=u&utm_source=inproduct#w_turn-content-blocking-on-or-off

i.e. go to :

  • Menu->Options->Privacy And Security -> Content Blocking and then
  • removing the checkmark next to All Detected Trackers

might fix it?

Cheers!

...Roland

more options

That might be one way to do it, however, I had already tried disabling the tracker on the page & in the frame--it had no effect.

Whatever it is, it's blocking the "cookies" as per the warning/error I got when Isolated the frame/drop-down menu in it's own tab.

Consequently, I went to options>third party cookies, and entered the two flagged addresses into the exceptions list. Nevertheless, I still had to toggle the "third party cookies/block all third party cookies" before it actually took effect.

I don't believe I togggled the Trackers option because I had already tried doing that in the address bar.

Why the browser had decided to flag those two particular addresses I have no idea. I had never had that issue before, but as I mentioned earlier--I did have to turn off the tracker block on the text editing page of the blog.

Who knows why Mozilla engineers do the things they do. One might ask that of every website online that they eventually ruin the functionality of the sites entirely, at least for the average user.

Seems to me the main problem with Mozilla Firefox is that their are too many chefs in the kitchen that they have forgotten all about the average user.

That said--there;s always Chrome & IE or even Opera that are, or may be more "user friendly." I know I'm not the only one who has had issues with Firefox updates, you can find a slew of forums on Google.

And if the chefs can't stand the heat--maybe they should get out of the kitchen.

Typically the forums here are generally very good, however, over a period of 2-3 days, you're the only one who offered a solution.

And for that I thank you, Roland.