Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I stop search suggestions in Windows 10

  • 13 uphendule
  • 1 inale nkinga
  • 57 views
  • Igcine ukuphendulwa ngu fergus0n

more options

I use private browsing in Windows 10 on my laptop. I have unticked the Provide Search Suggestions and the boxes underneath but I still get a blue box under the address bar repeating what I type. Then a white box appears under that with the same info. Extremely annoying. How do I stop these suggestions appearing? Thanks.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (13)

more options

unchick all boxes under default search engine.

more options

There are no tick boxes under Default Search Engine. It's a drop down list from which you pick one (Google for me) Thanks.

more options

I had already unchecked the boxes under Provide Search Suggestions.

more options

Hello fergus0n,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar : browser.urlbar.

and look for the preference :

browser.urlbar.search.suggestions

and set its value to false

Then close and restart Firefox.

Does that work  ?

more options

The list has no entry for browser.urlbar.search.suggestions

This is in the list browser.urlbar.suggest.searches

It is set to true. Should I set it to False?

Thanks.

more options

fergus0n said

The list has no entry for browser.urlbar.search.suggestions

My mistake  ! (hanging my head in shame ......)

browser.urlbar.suggest.searches It is set to true. Should I set it to False?

Yes - please change the value to false and then close and restart Firefox.

(my sincere apologies for that stupid mistake .... )

Okulungisiwe ngu McCoy

more options

Note that the Enter key might not work in the location bar if you disable all suggestions in the location/address bar.

more options

Firefox has just updated me to the latest version (Feb 10). The ANNOYING blue search bar has reappeared under the addess bar. I have gone through all steps given previously but I cannot get rid of it. The value in about:config for urlb..... is set to false but the blue bar remains. Please advise how I can get rid of it. Regards, Richard.

more options

Isisombululo Esikhethiwe

You can use code in userChrome.css remove all suggestions from the address bar drop down list. Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* remove all items from the urlbar drop down */
#PopupAutoCompleteRichResult {display:none !important;}

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

more options

fergus0n said

Firefox has just updated me to the latest version (Feb 10). The ANNOYING blue search bar has reappeared under the addess bar.

Hello Richard,

Assuming that you are talking about the blue 'Search with Google' bar - would you please do this :

On the about:config look for the preference :

browser.urlbar.OneOffSearches and set its value to false

(don't forget to close and restart Firefox)

I hope that will do what you want .....

more options

I have just followed your instructions and it didn't work. I still have the blue bar and now there is a white one underneath it. Don't know why but I can't attach the screen print to this reply. However I sent a pic last year showing both the blue and white search boxes. Regards, Richard.

more options

fergus0n said

I have just followed your instructions and it didn't work. I still have the blue bar and now there is a white one underneath it. Don't know why but I can't attach the screen print to this reply. However I sent a pic last year showing both the blue and white search boxes.

That blue 'Visit' bar : I am quite happy with that bar, as all I have to do after entering an URL, is click on it (instead of pressing Enter). But it seems to bother/annoy others (like you).

Have you done what cor-el suggested yet  ?


As for that other bar - would you try this please :

On the about:config page look for the preference :

keyword.enabled and set it's value to false

(then close and restart Firefox, if you had to change the value)

more options

I followed the instructions from cor-el which has fixed the problem. (I initially misunderstood chrome as referring to Google Chrome browser which I don't use).

I think Mozilla should take note of people's dislike of this unnecessary bar and make it easy to remove using right click/delete or something similar. Thanks and regards.