X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I move my navigation buttons back to where they were and cut my CPU usage?

Kuphostiwe

I just updated to Firefox 62 and my back and forward buttons have moved to the right side of the navigation bar and my reload button is gone entirely.Also I opened my task manager and Firefox is using a lot of my CPU.My CPU usage is usually around 10% , or something like that...pretty low.Now it's using around 70%...Firefox itself using over 60% when usually it's around 1%-3%.Why is this happening and how do I fix it?

I just updated to Firefox 62 and my back and forward buttons have moved to the right side of the navigation bar and my reload button is gone entirely.Also I opened my task manager and Firefox is using a lot of my CPU.My CPU usage is usually around 10% , or something like that...pretty low.Now it's using around 70%...Firefox itself using over 60% when usually it's around 1%-3%.Why is this happening and how do I fix it?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 27.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

Eminye Imininingwane

Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Separate Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

If you use it Reinstall with Flash Player Version: 31.0.0.108 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Hi, please go to the 3 Bar Menu to extreme right and then Customize. You can drag anything around that you wish. Suggest right clicking on the Download Button if this a 1st install of Quantum.

If your a low ram system by all means turn it down, if have a lot of ram turn it up and test.

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

Please let us know if this solved your issue or if need further assistance.

''Separate'' Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 31.0.0.108 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> Hi, please go to the 3 Bar Menu to extreme right and then Customize. You can drag anything around that you wish. Suggest right clicking on the Download Button if this a 1st install of Quantum. *https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars If your a low ram system by all means turn it down, if have a lot of ram turn it up and test. *https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram *https://support.mozilla.org/en-US/kb/performance-settings '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Only Disable as last resort. '''''Multi-processor Can completely disable it this way in about:config :''''' dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false *http://kb.mozillazine.org/About:config Only move to esr if low ram and old system. '''''Firefox Extended Release Version :''''' Firefox ESR does not come with the latest features but it has the latest security and stability fixes. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If do please : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Please let us know if this solved your issue or if need further assistance.
cor-el
  • Top 10 Contributor
  • Moderator
17415 izisombululo 157335 izimpendulo
Kuphostiwe

Open the Customize window and set what toolbars (Show/Hide Toolbars) and toolbar items to display.

  • Right-click empty toolbar area -> Customize
  • "3-bar" menu button -> Customize
  • View -> Toolbars
    *you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily

You can click the Restore Defaults button in the Customize palette window to restore the default toolbar set.

Open the Customize window and set what toolbars (Show/Hide Toolbars) and toolbar items to display. *Right-click empty toolbar area -> Customize *"3-bar" menu button -> Customize *View -> Toolbars<br>*you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily You can click the <u>Restore Defaults</u> button in the Customize palette window to restore the default toolbar set. *https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars *https://support.mozilla.org/en-US/kb/navigation-buttons-missing

Umnikazi wombuzo

Are you telling me to reduce the number of content processes?That's the only thing I see when I uncheck "use recommended performance settings".My system is 6 1/2 years old, but it has a decent quad core and 16 gigs of ram.Like I said, this wasn't an issue until yesterday.

Are you telling me to reduce the number of content processes?That's the only thing I see when I uncheck "use recommended performance settings".My system is 6 1/2 years old, but it has a decent quad core and 16 gigs of ram.Like I said, this wasn't an issue until yesterday.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Correct, Since your having issues with cpu usage so yes. You know Task Manager just monitor it and see what works best for your system. Default is 4, am running 7 with double ram. so not everyone will be the same. Some systems can not even handle using e10's (Quantum) and need to be disabled. Some need to move to the Extended Release as it is set for Organizations and businesses to be more stable and it is at 60.2.0 while General Release is 62.0

You can even go to 32bit if need to.

It all takes testing for what works best for you. Just use Task Manager as your guide and you know your system best.

Correct, Since your having issues with cpu usage so yes. You know Task Manager just monitor it and see what works best for your system. Default is 4, am running 7 with double ram. so not everyone will be the same. Some systems can not even handle using e10's (Quantum) and need to be disabled. Some need to move to the Extended Release as it is set for Organizations and businesses to be more stable and it is at 60.2.0 while General Release is 62.0 You can even go to 32bit if need to. It all takes testing for what works best for you. Just use Task Manager as your guide and you know your system best.

Okulungisiwe ngu Shadow110

Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

As a Multi-thread and multi-processor systems maybe great but can not handle the movement of info as fast as what is being offered to it by a browser that is also multi-thread and multi-processor capable.

As a Multi-thread and multi-processor systems maybe great but can not handle the movement of info as fast as what is being offered to it by a browser that is also multi-thread and multi-processor capable.

Okulungisiwe ngu Shadow110

jscher2000
  • Top 10 Contributor
8636 izisombululo 70638 izimpendulo
Kuphostiwe

Osiris3.0 said

I just updated to Firefox 62 and my back and forward buttons have moved to the right side of the navigation bar and my reload button is gone entirely.Also I opened my task manager and Firefox is using a lot of my CPU.My CPU usage is usually around 10% , or something like that...pretty low.Now it's using around 70%...Firefox itself using over 60% when usually it's around 1%-3%.Why is this happening and how do I fix it?

Osiris3.0 said

Like I said, this wasn't an issue until yesterday.

What was the previous version you were running? You should be able to find your update history on the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, there should be a button for Update History.

Example screenshot:

''Osiris3.0 [[#question-1234058|said]]'' <blockquote> I just updated to Firefox 62 and my back and forward buttons have moved to the right side of the navigation bar and my reload button is gone entirely.Also I opened my task manager and Firefox is using a lot of my CPU.My CPU usage is usually around 10% , or something like that...pretty low.Now it's using around 70%...Firefox itself using over 60% when usually it's around 1%-3%.Why is this happening and how do I fix it? </blockquote> ''Osiris3.0 [[#answer-1154952|said]]'' <blockquote> Like I said, this wasn't an issue until yesterday. </blockquote> What was the previous version you were running? You should be able to find your update history on the Troubleshooting Information page. Either: * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, there should be a button for Update History. Example screenshot: <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2018-09-16-14-09-03-7dab7b.png" width="400">

Okulungisiwe ngu jscher2000

Umnikazi wombuzo

I'm definitely not downgrading my browser and I shouldn't have to.I'm not doing anything different than I was doing before yesterday and my system resources haven't changed, but suddenly FF is consuming much more of them for no apparent reason.

I think this is on Mozilla's end.This is like another issue I had a few months ago.After I updated my browser some of my tabs wouldn't load.I had to roll my browser back to a previous version while people on this forum were telling me to try all kinds of things that didn't work.

A few updates later...problem fixed...just like that.I just want to know that they're aware of the problem, and are on it.

I'm definitely not downgrading my browser and I shouldn't have to.I'm not doing anything different than I was doing before yesterday and my system resources haven't changed, but suddenly FF is consuming much more of them for no apparent reason. I think this is on Mozilla's end.This is like another issue I had a few months ago.After I updated my browser some of my tabs wouldn't load.I had to roll my browser back to a previous version while people on this forum were telling me to try all kinds of things that didn't work. A few updates later...problem fixed...just like that.I just want to know that they're aware of the problem, and are on it.

Umnikazi wombuzo

I was on version 61.0.2.

I was on version 61.0.2.
jscher2000
  • Top 10 Contributor
8636 izisombululo 70638 izimpendulo
Kuphostiwe

Osiris3.0 said

I was on version 61.0.2.

Thanks.

Toolbar layout should not have changed between 61.0.2 and 62.0, especially buttons moving to non-default positions. Is there anything else odd after the update related to your settings or your add-ons?

Sometimes high CPU usage indicates malware, such as add-ons that suddenly got a coin mining feature. If you haven't already, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

''Osiris3.0 [[#answer-1154976|said]]'' <blockquote> I was on version 61.0.2. </blockquote> Thanks. Toolbar layout should not have changed between 61.0.2 and 62.0, especially buttons moving to non-default positions. Is there anything else odd after the update related to your settings or your add-ons? Sometimes high CPU usage indicates malware, such as add-ons that suddenly got a coin mining feature. If you haven't already, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Umnikazi wombuzo

OK, first I forgot to mention that yesterday my computer froze and I had to do a hard shut down.My bad.Restarting my browser after that is when my navigation buttons were moved.I also just noticed some changes I had made in about:config were reset to defaults as well.

Usually when I go to close my browser it asks me if I want to save and quit.I didn't this time, so I had to reset "browser.showquitwarning." back to true instead of it's default of false.I also had to reset "browser.sessionhistory.max_entries" back to 75 from 50 and "browser.sessionstore.max_serialize_back" back to 50 from 10 again.

As for the CPU usage, which started before the hard shut down, I did the safe mode thing and my usage was back down to normal, so I thought it was my extensions.I only have 2 installed, so I disabled one while enabling the other to see which one it was, but once I started loading my tabs my usage shot back up while either one of them was enabled.

My CPU usage also shot back when I disabled both of them, not in safe mode, but just manually disabled.So, that's where I am.

OK, first I forgot to mention that yesterday my computer froze and I had to do a hard shut down.My bad.Restarting my browser after that is when my navigation buttons were moved.I also just noticed some changes I had made in about:config were reset to defaults as well. Usually when I go to close my browser it asks me if I want to save and quit.I didn't this time, so I had to reset "browser.showquitwarning." back to true instead of it's default of false.I also had to reset "browser.sessionhistory.max_entries" back to 75 from 50 and "browser.sessionstore.max_serialize_back" back to 50 from 10 again. As for the CPU usage, which started before the hard shut down, I did the safe mode thing and my usage was back down to normal, so I thought it was my extensions.I only have 2 installed, so I disabled one while enabling the other to see which one it was, but once I started loading my tabs my usage shot back up while either one of them was enabled. My CPU usage also shot back when I disabled both of them, not in safe mode, but just manually disabled.So, that's where I am.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Hi, have you followed this at all that I posted before as it is CPU usage : To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Hi, have you followed this at all that I posted before as it is CPU usage : '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Only Disable as last resort. '''''Multi-processor Can completely disable it this way in about:config :''''' dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false *http://kb.mozillazine.org/About:config

Umnikazi wombuzo

OK, I think I found the culprit.It seems to be a tab, or I guess the website I have open in this particular tab, which in this case is a Tumblr.When I restarted my browser, even with my extensions enabled, and clicked on all my other tabs to reactivate and load them, but that one, my resource usage stayed in normal range.

It's weird.I don't recall having this problem with any Tumblr pages before.Anyway, i'm not done with it yet, but when I am and I close it i'll come back to confirm.

OK, I think I found the culprit.It seems to be a tab, or I guess the website I have open in this particular tab, which in this case is a Tumblr.When I restarted my browser, even with my extensions enabled, and clicked on all my other tabs to reactivate and load them, but that one, my resource usage stayed in normal range. It's weird.I don't recall having this problem with any Tumblr pages before.Anyway, i'm not done with it yet, but when I am and I close it i'll come back to confirm.
Shadow110 1072 izisombululo 14836 izimpendulo
Kuphostiwe

Hi, stranger things but yes a tab can do that if it is full of java script and ads.

Would you please give yourself a scan as it is also a sign of malware : https://www.malwarebytes.com/ as is cpu usage.

Hi, stranger things but yes a tab can do that if it is full of java script and ads. Would you please give yourself a scan as it is also a sign of malware : https://www.malwarebytes.com/ as is cpu usage.