Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

My Facebook page keeps prompting "For a better experience on Facebook, update your browser." I have a Mac OS 10.13.6 + have loaded Firefox 42.0. Suggestions?

  • 1 baphendule
  • 1 inale nkinga
  • 258 views
  • Igcine ukuphendulwa ngu McCoy

more options

Do I have the most up-to-date compatible version of Firefox for my MacBookPro, OS 10.13.6? I have Firefox 42.0. Thank you.

Isisombululo esikhethiwe

Hello elliscashmore,

The Firefox version you are running now is very old and doesn't get any security updates - puts you at risk.

Unless you need the ESR version, you should download Firefox release version 62.0, which you can download from here :

https://www.mozilla.org/firefox/all/

If you need the ESR version version (because you use plugins that are not supported by the release version), you can download the latest version from here :

https://www.mozilla.org/firefox/organizations/all/

Also see : https://www.mozilla.org/en-US/firefox/62.0/system-requirements/h

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (1)

more options

Isisombululo Esikhethiwe

Hello elliscashmore,

The Firefox version you are running now is very old and doesn't get any security updates - puts you at risk.

Unless you need the ESR version, you should download Firefox release version 62.0, which you can download from here :

https://www.mozilla.org/firefox/all/

If you need the ESR version version (because you use plugins that are not supported by the release version), you can download the latest version from here :

https://www.mozilla.org/firefox/organizations/all/

Also see : https://www.mozilla.org/en-US/firefox/62.0/system-requirements/h