Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I disable the "a web page is slowing down your computer" message

  • 6 uphendule
  • 1 inale nkinga
  • 655 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hi,

I'm trying to use Firefox to debug a slow website. Now, I know this website is slow - that's what I'm working on. So I don't need to see the "a website is slowing down your computer" message, I just want to be able to tell Firefox that - for this particular site - I don't want to see that message, I just want you to automatically wait and don't ask me again.

Is it possible to do this? Or if not on a site by site basis, then just disable the message altogether with a setting? It makes it especially difficult to use Firefox for this problem, but I don't want to have to switch to another browser to do it.

Thanks

All Replies (6)

more options
more options

Since you have a reliably slow page, could you test another approach, which is to raise the time that scripts are allowed to run before being considered unresponsive. That's the second section of this older article (I think this is one of the conditions that triggers the newer message):

Warning Unresponsive script - What it means and how to fix it

Would love to hear your feedback on whether that makes a difference.

more options

I see this problem been going on a year? I saw where Developers say ....not us....must be your device or internet connection.....Of course, how insane of me to think Firefox geniuses screwed something up and can't/won't fix. My Blockchain wallet goes thru this every time. Not any longer.....your not that good.

more options

Hi StuUnger2, the problem of scripts not yielding back control to the browser within the allotted time is as old as JavaScript itself. Much more than a year.

Crytographic operations are CPU-intensive. If you find that Firefox doesn't handle them well, do you want to start a new thread about what page has the problem? That would give people something to look at. Otherwise, see:

more options

My original problem wasn't really whether the scripts are slow, it was actually a slow server response to serve the script because it was getting bogged down in another connection (the server being my local PC and a development web server in truth).

So what I needed was the ability to turn off the message so I could get a reliable figure from the network panel of how long everything took, rather than having to click the dialog as fast as I could.

Generally speaking, it's a useful dialog. Except when I'm trying to work out what's causing the dialog and then sort it out :)

more options

If you need to disable this warning for testing then you can temporarily set this pref to "-1"

Note that this can/will block the Firefox user interface, so do not forget to reset the pref or set it to a higher value when you are done testing.